This job view page is being replaced by Spyglass soon. Check out the new job view.
PRJont828: Refactor async service to use an async reconciler interface and handle getting existing resources
ResultFAILURE
Tests 0 failed / 0 succeeded
Started2021-11-30 18:44
Elapsed12m30s
Revisionbe18dd1dea505a11a1de180c5842abd193956637
Refs 1874

No Test Failures!


Error lines from build-log.txt

... skipping 371 lines ...
ok  	sigs.k8s.io/cluster-api-provider-azure/azure/services/async	0.109s
?   	sigs.k8s.io/cluster-api-provider-azure/azure/services/async/mock_async	[no test files]
ok  	sigs.k8s.io/cluster-api-provider-azure/azure/services/availabilitysets	0.075s
?   	sigs.k8s.io/cluster-api-provider-azure/azure/services/availabilitysets/mock_availabilitysets	[no test files]
ok  	sigs.k8s.io/cluster-api-provider-azure/azure/services/bastionhosts	0.070s
?   	sigs.k8s.io/cluster-api-provider-azure/azure/services/bastionhosts/mocks_bastionhosts	[no test files]
--- FAIL: TestDeleteDisk (0.00s)
    --- FAIL: TestDeleteDisk/delete_the_disk (0.00s)
panic: runtime error: invalid memory address or nil pointer dereference [recovered]
	panic: runtime error: invalid memory address or nil pointer dereference [recovered]
	panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x20 pc=0x146e233]

goroutine 13 [running]:
testing.tRunner.func1.2(0x157eac0, 0x230c190)
	/usr/local/go/src/testing/testing.go:1143 +0x332
testing.tRunner.func1(0xc000506a80)
... skipping 11 lines ...
sigs.k8s.io/cluster-api-provider-azure/azure/services/disks.TestDeleteDisk.func4(0xc000506a80)
	/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/azure/services/disks/disks_test.go:126 +0x2b1
testing.tRunner(0xc000506a80, 0xc00062be30)
	/usr/local/go/src/testing/testing.go:1193 +0xef
created by testing.(*T).Run
	/usr/local/go/src/testing/testing.go:1238 +0x2b3
FAIL	sigs.k8s.io/cluster-api-provider-azure/azure/services/disks	0.140s
?   	sigs.k8s.io/cluster-api-provider-azure/azure/services/disks/mock_disks	[no test files]
ok  	sigs.k8s.io/cluster-api-provider-azure/azure/services/groups	0.067s
?   	sigs.k8s.io/cluster-api-provider-azure/azure/services/groups/mock_groups	[no test files]
ok  	sigs.k8s.io/cluster-api-provider-azure/azure/services/inboundnatrules	0.072s
?   	sigs.k8s.io/cluster-api-provider-azure/azure/services/inboundnatrules/mock_inboundnatrules	[no test files]
ok  	sigs.k8s.io/cluster-api-provider-azure/azure/services/loadbalancers	0.145s
... skipping 21 lines ...
ok  	sigs.k8s.io/cluster-api-provider-azure/azure/services/securitygroups	0.079s
?   	sigs.k8s.io/cluster-api-provider-azure/azure/services/securitygroups/mock_securitygroups	[no test files]
ok  	sigs.k8s.io/cluster-api-provider-azure/azure/services/subnets	0.093s
?   	sigs.k8s.io/cluster-api-provider-azure/azure/services/subnets/mock_subnets	[no test files]
ok  	sigs.k8s.io/cluster-api-provider-azure/azure/services/tags	0.079s
?   	sigs.k8s.io/cluster-api-provider-azure/azure/services/tags/mock_tags	[no test files]
--- FAIL: TestReconcileVM (0.00s)
    --- FAIL: TestReconcileVM/create_vm_succeeds_but_failed_to_get_public_IPs (0.00s)
        virtualmachines.go:90: Unexpected call to *mock_virtualmachines.MockVMScope.UpdatePutStatus([DisksReady virtualmachine <nil>]) at /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/azure/services/virtualmachines/virtualmachines.go:90 because: 
            expected call at /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/azure/services/virtualmachines/virtualmachines_test.go:156 doesn't match the argument at index 0.
            Got: DisksReady (v1beta1.ConditionType)
            Want: is equal to VMRunning (v1beta1.ConditionType)
        controller.go:269: missing call(s) to *mock_virtualmachines.MockVMScope.SetAnnotation(is equal to cluster-api-provider-azure (string), is equal to true (string)) /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/azure/services/virtualmachines/virtualmachines_test.go:158
        controller.go:269: missing call(s) to *mock_networkinterfaces.MockClient.Get(expected a context.Context, but got <nil>, is equal to test-group (string), is equal to nic-1 (string)) /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/azure/services/virtualmachines/virtualmachines_test.go:159
        controller.go:269: missing call(s) to *mock_publicips.MockClient.Get(expected a context.Context, but got <nil>, is equal to test-group (string), is equal to pip-1 (string)) /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/azure/services/virtualmachines/virtualmachines_test.go:160
        controller.go:269: missing call(s) to *mock_virtualmachines.MockVMScope.SetProviderID(is equal to azure://test-vm-id (string)) /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/azure/services/virtualmachines/virtualmachines_test.go:157
        controller.go:269: aborting test due to missing call(s)
    --- FAIL: TestReconcileVM/create_vm_succeeds_but_failed_to_get_network_interfaces (0.00s)
        virtualmachines.go:90: Unexpected call to *mock_virtualmachines.MockVMScope.UpdatePutStatus([DisksReady virtualmachine <nil>]) at /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/azure/services/virtualmachines/virtualmachines.go:90 because: 
            expected call at /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/azure/services/virtualmachines/virtualmachines_test.go:143 doesn't match the argument at index 0.
            Got: DisksReady (v1beta1.ConditionType)
            Want: is equal to VMRunning (v1beta1.ConditionType)
        controller.go:269: missing call(s) to *mock_virtualmachines.MockVMScope.SetProviderID(is equal to azure://test-vm-id (string)) /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/azure/services/virtualmachines/virtualmachines_test.go:144
        controller.go:269: missing call(s) to *mock_virtualmachines.MockVMScope.SetAnnotation(is equal to cluster-api-provider-azure (string), is equal to true (string)) /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/azure/services/virtualmachines/virtualmachines_test.go:145
        controller.go:269: missing call(s) to *mock_networkinterfaces.MockClient.Get(expected a context.Context, but got <nil>, is equal to test-group (string), is equal to nic-1 (string)) /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/azure/services/virtualmachines/virtualmachines_test.go:146
        controller.go:269: aborting test due to missing call(s)
    --- FAIL: TestReconcileVM/creating_vm_fails (0.00s)
        virtualmachines.go:90: Unexpected call to *mock_virtualmachines.MockVMScope.UpdatePutStatus([DisksReady virtualmachine #: Internal Server Error: StatusCode=500]) at /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/azure/services/virtualmachines/virtualmachines.go:90 because: 
            expected call at /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/azure/services/virtualmachines/virtualmachines_test.go:133 doesn't match the argument at index 0.
            Got: DisksReady (v1beta1.ConditionType)
            Want: is equal to VMRunning (v1beta1.ConditionType)
FAIL
FAIL	sigs.k8s.io/cluster-api-provider-azure/azure/services/virtualmachines	0.117s
?   	sigs.k8s.io/cluster-api-provider-azure/azure/services/virtualmachines/mock_virtualmachines	[no test files]
ok  	sigs.k8s.io/cluster-api-provider-azure/azure/services/virtualnetworks	0.098s
?   	sigs.k8s.io/cluster-api-provider-azure/azure/services/virtualnetworks/mock_virtualnetworks	[no test files]
ok  	sigs.k8s.io/cluster-api-provider-azure/azure/services/vmextensions	0.115s
?   	sigs.k8s.io/cluster-api-provider-azure/azure/services/vmextensions/mock_vmextensions	[no test files]
ok  	sigs.k8s.io/cluster-api-provider-azure/azure/services/vmssextensions	0.056s
... skipping 31 lines ...
?   	sigs.k8s.io/cluster-api-provider-azure/util/slice	[no test files]
ok  	sigs.k8s.io/cluster-api-provider-azure/util/ssh	0.217s
ok  	sigs.k8s.io/cluster-api-provider-azure/util/system	0.026s
?   	sigs.k8s.io/cluster-api-provider-azure/util/tele	[no test files]
?   	sigs.k8s.io/cluster-api-provider-azure/util/webhook	[no test files]
?   	sigs.k8s.io/cluster-api-provider-azure/version	[no test files]
FAIL
make: *** [Makefile:166: go-test] Error 1