This job view page is being replaced by Spyglass soon. Check out the new job view.
PRlzhecheng: [WIP][NOT FOR REVIEW] Improve test stability
ResultABORTED
Tests 0 failed / 0 succeeded
Started2022-07-07 07:30
Elapsed46m27s
Revision01c388a25f9bb92a134d7322c75bc76fc724875e
Refs 968

No Test Failures!


Error lines from build-log.txt

... skipping 181 lines ...
https://docs.docker.com/engine/reference/commandline/login/#credentials-store

Login Succeeded
/home/prow/go/src/sigs.k8s.io/cloud-provider-azure /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure
/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure
Image Tag is 1b1ed26
Error response from daemon: manifest for capzci.azurecr.io/azure-cloud-controller-manager:1b1ed26 not found: manifest unknown: manifest tagged by "1b1ed26" is not found
Build Linux Azure amd64 cloud controller manager
make: Entering directory '/home/prow/go/src/sigs.k8s.io/cloud-provider-azure'
make ARCH=amd64 build-ccm-image
make[1]: Entering directory '/home/prow/go/src/sigs.k8s.io/cloud-provider-azure'
docker buildx inspect img-builder > /dev/null 2>&1 || docker buildx create --name img-builder --use
img-builder
... skipping 1087 lines ...
certificate.cert-manager.io "selfsigned-cert" deleted
# Create secret for AzureClusterIdentity
./hack/create-identity-secret.sh
make[2]: Entering directory '/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure'
make[2]: Nothing to be done for 'kubectl'.
make[2]: Leaving directory '/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure'
Error from server (NotFound): secrets "cluster-identity-secret" not found
secret/cluster-identity-secret created
secret/cluster-identity-secret labeled
# Create customized cloud provider configs
./hack/create-custom-cloud-provider-config.sh
make[2]: Entering directory '/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure'
make[2]: Nothing to be done for 'kubectl'.
... skipping 140 lines ...
# Wait for the kubeconfig to become available.
timeout --foreground 300 bash -c "while ! /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/hack/tools/bin/kubectl-v1.22.4 get secrets | grep capz-sp9oq8-kubeconfig; do sleep 1; done"
capz-sp9oq8-kubeconfig                 cluster.x-k8s.io/secret   1      1s
# Get kubeconfig and store it locally.
/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/hack/tools/bin/kubectl-v1.22.4 get secrets capz-sp9oq8-kubeconfig -o json | jq -r .data.value | base64 --decode > ./kubeconfig
timeout --foreground 600 bash -c "while ! /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/hack/tools/bin/kubectl-v1.22.4 --kubeconfig=./kubeconfig get nodes | grep control-plane; do sleep 1; done"
error: the server doesn't have a resource type "nodes"
capz-sp9oq8-control-plane-5hslc   NotReady   control-plane   5s    v1.25.0-alpha.2.109+2a017f94bcf8d0
run "/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/hack/tools/bin/kubectl-v1.22.4 --kubeconfig=./kubeconfig ..." to work with the new target cluster
make[1]: Leaving directory '/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure'
Installing cloud-provider-azure components via helm
WARNING: Kubernetes configuration file is group-readable. This is insecure. Location: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig
WARNING: Kubernetes configuration file is world-readable. This is insecure. Location: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig
... skipping 40 lines ...
Jul  7 07:51:49.110: INFO: Created a test namespace "e2e-tests-service-lb-r55hr" [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:109]
Jul  7 07:51:49.110: INFO: Creating a kubernetes client [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:55]
Jul  7 07:51:49.110: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:63]
Jul  7 07:51:49.231: INFO: Creating deployment deployment-lb-test [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:88]
Jul  7 07:51:49.296: INFO: Updating deployment deployment-lb-test [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:107]
STEP: creating a mixed protocol service
Jul  7 07:51:49.679: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:162]
Jul  7 07:51:59.745: INFO: Exposure successfully, get external ip: 20.190.19.224 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:177]
Jul  7 07:51:59.745: INFO: Creating a hostNetwork Pod exec-agnhost-pod in namespace e2e-tests-service-lb-r55hr to exec [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:142]
Jul  7 07:51:59.927: INFO: waiting for the pod status to be Running, current status: Pending [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:258]
Jul  7 07:52:09.995: INFO: checking the connectivity of addr 20.190.19.224:80 with protocol TCP [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:128]
Jul  7 07:52:09.995: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/kubectl.go:100]
Jul  7 07:52:09.995: INFO: Running '/usr/local/bin/kubectl --kubeconfig=/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig --namespace=e2e-tests-service-lb-r55hr exec exec-agnhost-pod -- /bin/sh -x -c nc -vz -w 4  20.190.19.224 80' [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/kubectl.go:140]
... skipping 32 lines ...
Jul  7 07:52:53.157: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:63]
Jul  7 07:52:53.242: INFO: Creating deployment deployment-lb-test [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:88]
STEP: creating a public IP with tags
Jul  7 07:52:53.303: INFO: Creating public IP resource named service-lb-public-IPdb3a [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/network_utils.go:191]
Jul  7 07:52:55.488: INFO: created pip with address 20.3.225.225 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:166]
STEP: creating a service referencing the public IP
Jul  7 07:52:55.624: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:162]
Jul  7 07:53:05.690: INFO: Exposure successfully, get external ip: 20.3.225.225 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:177]
Jul  7 07:53:05.690: INFO: Creating a hostNetwork Pod exec-agnhost-pod in namespace e2e-tests-service-lb-4fjd2 to exec [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:142]
Jul  7 07:53:05.814: INFO: waiting for the pod status to be Running, current status: Pending [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:258]
Jul  7 07:53:15.881: INFO: checking the connectivity of addr 20.3.225.225:80 with protocol TCP [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:128]
Jul  7 07:53:15.881: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/kubectl.go:100]
Jul  7 07:53:15.881: INFO: Running '/usr/local/bin/kubectl --kubeconfig=/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig --namespace=e2e-tests-service-lb-4fjd2 exec exec-agnhost-pod -- /bin/sh -x -c nc -vz -w 4  20.3.225.225 80' [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/kubectl.go:140]
... skipping 25 lines ...
Jul  7 07:53:27.818: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:63]
Jul  7 07:53:27.906: INFO: Creating deployment deployment-lb-test [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:88]
Jul  7 07:53:28.101: INFO: Successfully created LoadBalancer service service-lb-test in namespace e2e-tests-service-lb-csc7v [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:200]
Jul  7 07:53:28.101: INFO: Creating public IP resource named service-lb-public-none-IPc288 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/network_utils.go:191]
Jul  7 07:53:31.564: INFO: PIP to 20.3.231.251 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:205]
STEP: Waiting for exposure of the original service without assigned lb IP
Jul  7 07:53:31.623: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:162]
Jul  7 07:53:41.687: INFO: Exposure successfully, get external ip: 20.190.17.81 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:177]
Jul  7 07:53:41.687: INFO: Creating a hostNetwork Pod exec-agnhost-pod in namespace e2e-tests-service-lb-csc7v to exec [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:142]
Jul  7 07:53:41.860: INFO: waiting for the pod status to be Running, current status: Pending [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:258]
Jul  7 07:53:51.923: INFO: checking the connectivity of addr 20.190.17.81:80 with protocol TCP [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:128]
Jul  7 07:53:51.923: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/kubectl.go:100]
Jul  7 07:53:51.923: INFO: Running '/usr/local/bin/kubectl --kubeconfig=/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig --namespace=e2e-tests-service-lb-csc7v exec exec-agnhost-pod -- /bin/sh -x -c nc -vz -w 4  20.190.17.81 80' [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/kubectl.go:140]
... skipping 36 lines ...
Jul  7 07:54:45.295: INFO: Creating a kubernetes client [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:55]
Jul  7 07:54:45.295: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:63]
Jul  7 07:54:45.378: INFO: Creating deployment deployment-lb-test [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:88]
Jul  7 07:54:45.439: INFO: Getting virtual network list [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/network_utils.go:37]
Jul  7 07:54:47.058: INFO: Successfully created LoadBalancer service service-lb-test in namespace e2e-tests-service-lb-76kn7 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:243]
STEP: Waiting for exposure of internal service with specific IP "10.1.0.6"
Jul  7 07:54:47.131: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:162]
Jul  7 07:54:57.200: INFO: Exposure successfully, get external ip: 10.1.0.6 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:177]
Jul  7 07:54:57.200: INFO: Creating a hostNetwork Pod exec-agnhost-pod in namespace e2e-tests-service-lb-76kn7 to exec [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:142]
Jul  7 07:54:57.319: INFO: waiting for the pod status to be Running, current status: Pending [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:258]
Jul  7 07:55:07.390: INFO: checking the connectivity of addr 10.1.0.6:80 with protocol TCP [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:128]
Jul  7 07:55:07.390: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/kubectl.go:100]
Jul  7 07:55:07.390: INFO: Running '/usr/local/bin/kubectl --kubeconfig=/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig --namespace=e2e-tests-service-lb-76kn7 exec exec-agnhost-pod -- /bin/sh -x -c nc -vz -w 4  10.1.0.6 80' [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/kubectl.go:140]
... skipping 73 lines ...
Jul  7 07:56:00.194: INFO: Creating a kubernetes client [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:55]
Jul  7 07:56:00.194: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:63]
Jul  7 07:56:00.274: INFO: Creating deployment deployment-lb-test [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:88]
Jul  7 07:56:00.527: INFO: Successfully created LoadBalancer service service-lb-test in namespace e2e-tests-service-lb-674wd [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:284]
Jul  7 07:56:00.527: INFO: Creating public IP resource named service-lb-internal-none-public-IP0662 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/network_utils.go:191]
STEP: Waiting for exposure of the original service without assigned lb private IP
Jul  7 07:56:02.470: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:162]
Jul  7 07:56:12.531: INFO: Exposure successfully, get external ip: 10.1.0.6 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:177]
Jul  7 07:56:12.531: INFO: Creating a hostNetwork Pod exec-agnhost-pod in namespace e2e-tests-service-lb-674wd to exec [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:142]
Jul  7 07:56:12.706: INFO: waiting for the pod status to be Running, current status: Pending [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:258]
Jul  7 07:56:22.770: INFO: checking the connectivity of addr 10.1.0.6:80 with protocol TCP [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:128]
Jul  7 07:56:22.770: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/kubectl.go:100]
Jul  7 07:56:22.770: INFO: Running '/usr/local/bin/kubectl --kubeconfig=/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig --namespace=e2e-tests-service-lb-674wd exec exec-agnhost-pod -- /bin/sh -x -c nc -vz -w 4  10.1.0.6 80' [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/kubectl.go:140]
... skipping 74 lines ...
Jul  7 07:57:06.072: INFO: Creating a kubernetes client [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:55]
Jul  7 07:57:06.072: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:63]
Jul  7 07:57:06.160: INFO: Creating deployment deployment-lb-test [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:88]
STEP: Creating an internal Service
Jul  7 07:57:06.369: INFO: Successfully created LoadBalancer service service-lb-test in namespace e2e-tests-service-lb-zr8nr [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:336]
STEP: Waiting for exposure of the internal Service
Jul  7 07:57:06.435: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:162]
Jul  7 07:57:16.506: INFO: Exposure successfully, get external ip: 10.1.0.6 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:177]
Jul  7 07:57:16.506: INFO: Creating a hostNetwork Pod exec-agnhost-pod in namespace e2e-tests-service-lb-zr8nr to exec [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:142]
Jul  7 07:57:16.680: INFO: waiting for the pod status to be Running, current status: Pending [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:258]
Jul  7 07:57:26.749: INFO: checking the connectivity of addr 10.1.0.6:80 with protocol TCP [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:128]
Jul  7 07:57:26.749: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/kubectl.go:100]
Jul  7 07:57:26.749: INFO: Running '/usr/local/bin/kubectl --kubeconfig=/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig --namespace=e2e-tests-service-lb-zr8nr exec exec-agnhost-pod -- /bin/sh -x -c nc -vz -w 4  10.1.0.6 80' [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/kubectl.go:140]
... skipping 73 lines ...
Jul  7 07:58:41.698: INFO: Created a test namespace "e2e-tests-service-lb-vkzjz" [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:109]
Jul  7 07:58:41.699: INFO: Creating a kubernetes client [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:55]
Jul  7 07:58:41.699: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:63]
Jul  7 07:58:41.779: INFO: Creating deployment deployment-lb-test [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:88]
Jul  7 07:58:42.034: INFO: Successfully created LoadBalancer service service-lb-test in namespace e2e-tests-service-lb-vkzjz [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:388]
STEP: Waiting for exposure of a public Service
Jul  7 07:58:42.093: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:162]
Jul  7 07:58:52.161: INFO: Exposure successfully, get external ip: 20.190.21.223 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:177]
Jul  7 07:58:52.161: INFO: Creating a hostNetwork Pod exec-agnhost-pod in namespace e2e-tests-service-lb-vkzjz to exec [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:142]
Jul  7 07:58:52.336: INFO: waiting for the pod status to be Running, current status: Pending [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:258]
Jul  7 07:59:02.400: INFO: checking the connectivity of addr 20.190.21.223:80 with protocol TCP [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:128]
Jul  7 07:59:02.400: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/kubectl.go:100]
Jul  7 07:59:02.401: INFO: Running '/usr/local/bin/kubectl --kubeconfig=/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig --namespace=e2e-tests-service-lb-vkzjz exec exec-agnhost-pod -- /bin/sh -x -c nc -vz -w 4  20.190.21.223 80' [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/kubectl.go:140]
... skipping 74 lines ...
Jul  7 07:59:55.254: INFO: Creating a kubernetes client [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:55]
Jul  7 07:59:55.254: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:63]
Jul  7 07:59:55.335: INFO: Creating deployment deployment-lb-test [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:88]
Jul  7 07:59:55.395: INFO: Creating public IP resource named service-lb-public-remain5b56 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/network_utils.go:191]
Jul  7 07:59:59.545: INFO: Successfully created LoadBalancer service service-lb-test in namespace e2e-tests-service-lb-rxnhk [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:425]
STEP: Waiting for exposure of the original service with assigned lb private IP
Jul  7 07:59:59.627: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:162]
Jul  7 08:00:09.691: INFO: Exposure successfully, get external ip: 40.65.82.158 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:177]
Jul  7 08:00:09.691: INFO: Creating a hostNetwork Pod exec-agnhost-pod in namespace e2e-tests-service-lb-rxnhk to exec [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:142]
Jul  7 08:00:09.811: INFO: waiting for the pod status to be Running, current status: Pending [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:258]
Jul  7 08:00:19.881: INFO: checking the connectivity of addr 40.65.82.158:80 with protocol TCP [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:128]
Jul  7 08:00:19.881: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/kubectl.go:100]
Jul  7 08:00:19.882: INFO: Running '/usr/local/bin/kubectl --kubeconfig=/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig --namespace=e2e-tests-service-lb-rxnhk exec exec-agnhost-pod -- /bin/sh -x -c nc -vz -w 4  40.65.82.158 80' [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/kubectl.go:140]
... skipping 10 lines ...
Jul  7 08:00:51.060: INFO: External IP is still 40.65.82.158, as expected [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:464]
Jul  7 08:01:01.064: INFO: External IP is still 40.65.82.158, as expected [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:464]
Jul  7 08:01:11.059: INFO: External IP is still 40.65.82.158, as expected [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:464]
Jul  7 08:01:21.058: INFO: External IP is still 40.65.82.158, as expected [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:464]
Jul  7 08:01:31.060: INFO: External IP is still 40.65.82.158, as expected [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:464]
Jul  7 08:01:41.060: INFO: External IP is still 40.65.82.158, as expected [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:464]
{"component":"entrypoint","file":"k8s.io/test-infra/prow/entrypoint/run.go:169","func":"k8s.io/test-infra/prow/entrypoint.Options.ExecuteProcess","level":"error","msg":"Entrypoint received interrupt: terminated","severity":"error","time":"2022-07-07T08:01:45Z"}
++ early_exit_handler
++ '[' -n 161 ']'
++ kill -TERM 161
++ cleanup_dind
++ [[ true == \t\r\u\e ]]
++ echo 'Cleaning up after docker'
... skipping 4 lines ...