This job view page is being replaced by Spyglass soon. Check out the new job view.
PRMartinForReal: [release-1.24] fix: should update dns label if target pip already have one and it needs update
ResultABORTED
Tests 0 failed / 0 succeeded
Started2022-11-04 08:06
Elapsed45m18s
Revision658ab19dcb8d5ec7fcf71cedc6d3bbd064fa591f
Refs 2701

No Test Failures!


Error lines from build-log.txt

... skipping 123 lines ...
https://docs.docker.com/engine/reference/commandline/login/#credentials-store

Login Succeeded
/home/prow/go/src/sigs.k8s.io/cloud-provider-azure /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure
/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure
Image Tag is b42d82c
Error response from daemon: manifest for capzci.azurecr.io/azure-cloud-controller-manager:b42d82c not found: manifest unknown: manifest tagged by "b42d82c" is not found
Build Linux Azure amd64 cloud controller manager
make: Entering directory '/home/prow/go/src/sigs.k8s.io/cloud-provider-azure'
make ARCH=amd64 build-ccm-image
make[1]: Entering directory '/home/prow/go/src/sigs.k8s.io/cloud-provider-azure'
docker buildx inspect img-builder > /dev/null || docker buildx create --name img-builder --use
ERROR: no builder "img-builder" found
img-builder
# enable qemu for arm64 build
# https://github.com/docker/buildx/issues/464#issuecomment-741507760
docker run --privileged --rm tonistiigi/binfmt --uninstall qemu-aarch64
Unable to find image 'tonistiigi/binfmt:latest' locally
latest: Pulling from tonistiigi/binfmt
... skipping 1043 lines ...
certificate.cert-manager.io "selfsigned-cert" deleted
# Create secret for AzureClusterIdentity
./hack/create-identity-secret.sh
make[2]: Entering directory '/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure'
make[2]: Nothing to be done for 'kubectl'.
make[2]: Leaving directory '/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure'
Error from server (NotFound): secrets "cluster-identity-secret" not found
secret/cluster-identity-secret created
secret/cluster-identity-secret labeled
# Create customized cloud provider configs
./hack/create-custom-cloud-provider-config.sh
make[2]: Entering directory '/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure'
make[2]: Nothing to be done for 'kubectl'.
... skipping 143 lines ...
# Wait for the kubeconfig to become available.
timeout --foreground 300 bash -c "while ! /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/hack/tools/bin/kubectl-v1.22.4 get secrets | grep capz-zaznxn-kubeconfig; do sleep 1; done"
capz-zaznxn-kubeconfig                 cluster.x-k8s.io/secret   1      1s
# Get kubeconfig and store it locally.
/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/hack/tools/bin/kubectl-v1.22.4 get secrets capz-zaznxn-kubeconfig -o json | jq -r .data.value | base64 --decode > ./kubeconfig
timeout --foreground 600 bash -c "while ! /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/hack/tools/bin/kubectl-v1.22.4 --kubeconfig=./kubeconfig get nodes | grep control-plane; do sleep 1; done"
error: the server doesn't have a resource type "nodes"
capz-zaznxn-control-plane-rtt4n   NotReady   control-plane   23s   v1.24.8-rc.0.22+bef7b2facd452b
run "/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/hack/tools/bin/kubectl-v1.22.4 --kubeconfig=./kubeconfig ..." to work with the new target cluster
make[1]: Leaving directory '/home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure'
Waiting for 1 control plane machine(s), 2 worker machine(s), and  windows machine(s) to become Ready
node/capz-zaznxn-control-plane-rtt4n condition met
node/capz-zaznxn-mp-0000000 condition met
... skipping 97 lines ...
Nov  4 08:30:34.326: INFO: Created a test namespace "e2e-tests-service-lb-zsgmw" [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:109]
Nov  4 08:30:34.326: INFO: Creating a kubernetes client [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:55]
Nov  4 08:30:34.326: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:63]
Nov  4 08:30:34.415: INFO: Creating deployment deployment-lb-test [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:93]
Nov  4 08:30:34.482: INFO: Updating deployment deployment-lb-test [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:112]
STEP: creating a mixed protocol service 11/04/22 08:30:34.561
Nov  4 08:30:34.798: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
Nov  4 08:30:44.870: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
Nov  4 08:30:54.870: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
Nov  4 08:31:04.870: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
Nov  4 08:31:14.870: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
Nov  4 08:31:24.862: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
Nov  4 08:31:34.862: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
Nov  4 08:31:44.861: INFO: Exposure successfully, get external ip: 20.150.158.205 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:180]
Nov  4 08:31:44.861: INFO: Creating a hostNetwork Pod exec-agnhost-pod in namespace e2e-tests-service-lb-zsgmw to exec [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:158]
Nov  4 08:31:44.861: INFO: creating pod exec-agnhost-pod in namespace e2e-tests-service-lb-zsgmw [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:151]
Nov  4 08:31:44.993: INFO: waiting for the pod status to be Running, current status: Pending [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:316]
Nov  4 08:31:55.061: INFO: checking the connectivity of addr 20.150.158.205:80 with protocol TCP [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:131]
Nov  4 08:31:55.061: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/kubectl.go:106]
... skipping 29 lines ...
    Nov  4 08:30:34.326: INFO: Created a test namespace "e2e-tests-service-lb-zsgmw" [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:109]
    Nov  4 08:30:34.326: INFO: Creating a kubernetes client [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:55]
    Nov  4 08:30:34.326: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:63]
    Nov  4 08:30:34.415: INFO: Creating deployment deployment-lb-test [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:93]
    Nov  4 08:30:34.482: INFO: Updating deployment deployment-lb-test [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:112]
    STEP: creating a mixed protocol service 11/04/22 08:30:34.561
    Nov  4 08:30:34.798: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
    Nov  4 08:30:44.870: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
    Nov  4 08:30:54.870: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
    Nov  4 08:31:04.870: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
    Nov  4 08:31:14.870: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
    Nov  4 08:31:24.862: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
    Nov  4 08:31:34.862: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
    Nov  4 08:31:44.861: INFO: Exposure successfully, get external ip: 20.150.158.205 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:180]
    Nov  4 08:31:44.861: INFO: Creating a hostNetwork Pod exec-agnhost-pod in namespace e2e-tests-service-lb-zsgmw to exec [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:158]
    Nov  4 08:31:44.861: INFO: creating pod exec-agnhost-pod in namespace e2e-tests-service-lb-zsgmw [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:151]
    Nov  4 08:31:44.993: INFO: waiting for the pod status to be Running, current status: Pending [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:316]
    Nov  4 08:31:55.061: INFO: checking the connectivity of addr 20.150.158.205:80 with protocol TCP [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:131]
    Nov  4 08:31:55.061: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/kubectl.go:106]
... skipping 28 lines ...
Nov  4 08:33:18.392: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:63]
Nov  4 08:33:18.482: INFO: Creating deployment deployment-lb-test [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:93]
STEP: creating a public IP with tags 11/04/22 08:33:18.546
Nov  4 08:33:18.547: INFO: Creating public IP resource named service-lb-public-IP6838 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/network_utils.go:206]
Nov  4 08:33:20.600: INFO: created pip with address 20.171.49.66 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:171]
STEP: creating a service referencing the public IP 11/04/22 08:33:20.6
Nov  4 08:33:20.737: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
Nov  4 08:33:30.800: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
Nov  4 08:33:40.807: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
Nov  4 08:33:50.801: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
Nov  4 08:34:00.807: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
Nov  4 08:34:10.800: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
Nov  4 08:34:20.805: INFO: Exposure successfully, get external ip: 20.171.49.66 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:180]
Nov  4 08:34:20.805: INFO: Creating a hostNetwork Pod exec-agnhost-pod in namespace e2e-tests-service-lb-2f8m8 to exec [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:158]
Nov  4 08:34:20.805: INFO: creating pod exec-agnhost-pod in namespace e2e-tests-service-lb-2f8m8 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:151]
Nov  4 08:34:20.946: INFO: waiting for the pod status to be Running, current status: Pending [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:316]
Nov  4 08:34:31.017: INFO: checking the connectivity of addr 20.171.49.66:80 with protocol TCP [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:131]
Nov  4 08:34:31.017: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/kubectl.go:106]
... skipping 24 lines ...
    Nov  4 08:33:18.392: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:63]
    Nov  4 08:33:18.482: INFO: Creating deployment deployment-lb-test [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:93]
    STEP: creating a public IP with tags 11/04/22 08:33:18.546
    Nov  4 08:33:18.547: INFO: Creating public IP resource named service-lb-public-IP6838 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/network_utils.go:206]
    Nov  4 08:33:20.600: INFO: created pip with address 20.171.49.66 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:171]
    STEP: creating a service referencing the public IP 11/04/22 08:33:20.6
    Nov  4 08:33:20.737: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
    Nov  4 08:33:30.800: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
    Nov  4 08:33:40.807: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
    Nov  4 08:33:50.801: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
    Nov  4 08:34:00.807: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
    Nov  4 08:34:10.800: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
    Nov  4 08:34:20.805: INFO: Exposure successfully, get external ip: 20.171.49.66 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:180]
    Nov  4 08:34:20.805: INFO: Creating a hostNetwork Pod exec-agnhost-pod in namespace e2e-tests-service-lb-2f8m8 to exec [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:158]
    Nov  4 08:34:20.805: INFO: creating pod exec-agnhost-pod in namespace e2e-tests-service-lb-2f8m8 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:151]
    Nov  4 08:34:20.946: INFO: waiting for the pod status to be Running, current status: Pending [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:316]
    Nov  4 08:34:31.017: INFO: checking the connectivity of addr 20.171.49.66:80 with protocol TCP [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:131]
    Nov  4 08:34:31.017: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/kubectl.go:106]
... skipping 21 lines ...
Nov  4 08:35:25.368: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/utils.go:63]
Nov  4 08:35:25.460: INFO: Creating deployment deployment-lb-test [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:93]
Nov  4 08:35:25.637: INFO: Successfully created LoadBalancer service service-lb-test in namespace e2e-tests-service-lb-g2ttp [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:205]
Nov  4 08:35:25.637: INFO: Creating public IP resource named service-lb-public-none-IPac37 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/network_utils.go:206]
Nov  4 08:35:30.033: INFO: PIP to 20.168.33.82 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/network/ensureloadbalancer.go:210]
STEP: Waiting for exposure of the original service without assigned lb IP 11/04/22 08:35:30.033
Nov  4 08:35:30.095: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
Nov  4 08:35:40.167: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
Nov  4 08:35:50.158: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
Nov  4 08:36:00.162: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
Nov  4 08:36:10.160: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
Nov  4 08:36:20.168: INFO: Fail to find ingress, retry in 10 seconds [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:165]
Nov  4 08:36:30.167: INFO: Exposure successfully, get external ip: 20.14.18.205 [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:180]
Nov  4 08:36:30.167: INFO: Creating a hostNetwork Pod exec-agnhost-pod in namespace e2e-tests-service-lb-g2ttp to exec [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:158]
Nov  4 08:36:30.167: INFO: creating pod exec-agnhost-pod in namespace e2e-tests-service-lb-g2ttp [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:151]
Nov  4 08:36:30.301: INFO: waiting for the pod status to be Running, current status: Pending [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/pod_utils.go:316]
Nov  4 08:36:40.366: INFO: checking the connectivity of addr 20.14.18.205:80 with protocol TCP [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/service_utils.go:131]
Nov  4 08:36:40.366: INFO: Kubernetes configuration file name: /home/prow/go/src/sigs.k8s.io/cluster-api-provider-azure/kubeconfig [/home/prow/go/src/sigs.k8s.io/cloud-provider-azure/tests/e2e/utils/kubectl.go:106]
... skipping 9 lines ...