This job view page is being replaced by Spyglass soon. Check out the new job view.
PRandyzhangx: feat: customize healthPort in helm install
ResultFAILURE
Tests 0 failed / 0 succeeded
Started2021-07-09 03:38
Elapsed4m13s
Revisionc093766adbb4d6b43766b0bf056790bfe769b184
Refs 736

No Test Failures!


Error lines from build-log.txt

Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
+ WRAPPED_COMMAND_PID=31
+ wait 31
+ make verify
go test -v -race ./pkg/... ./test/utils/credentials
=== RUN   TestGetCloudProvider
E0709 03:39:53.433202   11280 azure_config.go:45] Failed to get cloud-config from secret: failed to get secret kube-system/azure-cloud-provider: Get "https://localhost:8080/api/v1/namespaces/kube-system/secrets/azure-cloud-provider": getting credentials: exec: executable foo-command not found

It looks like you are trying to use a client-go credential plugin that is not installed.

To learn more about this feature, consult the documentation available at:
      https://kubernetes.io/docs/reference/access-authn-authz/authentication/#client-go-credential-plugins
--- PASS: TestGetCloudProvider (0.02s)
=== RUN   TestUpdateSubnetServiceEndpoints
=== RUN   TestUpdateSubnetServiceEndpoints/[fail]_no_subnet
=== RUN   TestUpdateSubnetServiceEndpoints/[success]_subnetPropertiesFormat_is_nil
=== RUN   TestUpdateSubnetServiceEndpoints/[success]_ServiceEndpoints_is_nil
=== RUN   TestUpdateSubnetServiceEndpoints/[success]_storageService_does_not_exists
=== RUN   TestUpdateSubnetServiceEndpoints/[success]_storageService_already_exists
=== RUN   TestUpdateSubnetServiceEndpoints/[fail]_SubnetsClient_is_nil
--- PASS: TestUpdateSubnetServiceEndpoints (0.00s)
    --- PASS: TestUpdateSubnetServiceEndpoints/[fail]_no_subnet (0.00s)
    --- PASS: TestUpdateSubnetServiceEndpoints/[success]_subnetPropertiesFormat_is_nil (0.00s)
    --- PASS: TestUpdateSubnetServiceEndpoints/[success]_ServiceEndpoints_is_nil (0.00s)
    --- PASS: TestUpdateSubnetServiceEndpoints/[success]_storageService_does_not_exists (0.00s)
    --- PASS: TestUpdateSubnetServiceEndpoints/[success]_storageService_already_exists (0.00s)
    --- PASS: TestUpdateSubnetServiceEndpoints/[fail]_SubnetsClient_is_nil (0.00s)
=== RUN   TestGetFileSvcClient
--- PASS: TestGetFileSvcClient (0.00s)
=== RUN   TestCreateFileShare
=== RUN   TestCreateFileShare/ShareOptions_empty
=== RUN   TestCreateFileShare/AccountName_invalid
--- PASS: TestCreateFileShare (0.00s)
... skipping 23 lines ...
--- PASS: TestIsCorruptedDir (0.00s)
=== RUN   TestNewDriver
--- PASS: TestNewDriver (0.00s)
=== RUN   TestGetFileURL
--- PASS: TestGetFileURL (0.00s)
=== RUN   TestGetAccountInfo
W0709 03:39:53.442170   11280 azurefile.go:480] parsing volumeID(uniqe-volumeid-nfs) return with error: error parsing volume id: "uniqe-volumeid-nfs", should at least contain two #
--- PASS: TestGetAccountInfo (0.00s)
=== RUN   TestCreateDisk
--- PASS: TestCreateDisk (4.46s)
=== RUN   TestGetFileShareQuota
--- PASS: TestGetFileShareQuota (0.00s)
=== RUN   TestRun
... skipping 120 lines ...
    --- PASS: TestCreateVolume/Valid_request (0.00s)
    --- PASS: TestCreateVolume/invalid_parameter (0.00s)
=== RUN   TestDeleteVolume
=== RUN   TestDeleteVolume/Volume_ID_missing
=== RUN   TestDeleteVolume/Controller_capability_missing
=== RUN   TestDeleteVolume/Invalid_volume_ID
E0709 03:39:57.932991   11280 controllerserver.go:442] GetFileShareInfo(vol_1) in DeleteVolume failed with error: error parsing volume id: "vol_1", should at least contain two #
=== RUN   TestDeleteVolume/Delete_file_share_returns_error
=== RUN   TestDeleteVolume/Valid_request
I0709 03:39:57.934117   11280 azurefile.go:662] remove tag(skip-matching) on account(f5713de20cde511e8ba4900) resourceGroup(vol_1)
W0709 03:39:57.934304   11280 controllerserver.go:473] RemoveStorageAccountTag(skip-matching) under rg(vol_1) account(f5713de20cde511e8ba4900) failed with Retriable: false, RetryAfter: 0s, HTTPStatusCode: 0, RawError: StorageAccountClient is nil
--- PASS: TestDeleteVolume (0.00s)
    --- PASS: TestDeleteVolume/Volume_ID_missing (0.00s)
    --- PASS: TestDeleteVolume/Controller_capability_missing (0.00s)
    --- PASS: TestDeleteVolume/Invalid_volume_ID (0.00s)
    --- PASS: TestDeleteVolume/Delete_file_share_returns_error (0.00s)
    --- PASS: TestDeleteVolume/Valid_request (0.00s)
=== RUN   TestControllerGetVolume
--- PASS: TestControllerGetVolume (0.00s)
=== RUN   TestControllerGetCapabilities
--- PASS: TestControllerGetCapabilities (0.00s)
=== RUN   TestValidateVolumeCapabilities
W0709 03:39:57.935572   11280 azurefile.go:480] parsing volumeID(vol_1) return with error: error parsing volume id: "vol_1", should at least contain two #
--- PASS: TestValidateVolumeCapabilities (0.00s)
=== RUN   TestControllerPublishVolume
W0709 03:39:57.937095   11280 azurefile.go:480] parsing volumeID(vol_1) return with error: error parsing volume id: "vol_1", should at least contain two #
--- PASS: TestControllerPublishVolume (0.00s)
=== RUN   TestControllerUnpublishVolume
--- PASS: TestControllerUnpublishVolume (0.00s)
=== RUN   TestCreateSnapshot
W0709 03:39:57.939181   11280 azurefile.go:480] parsing volumeID(vol_1) return with error: error parsing volume id: "vol_1", should at least contain two #
--- PASS: TestCreateSnapshot (0.00s)
=== RUN   TestDeleteSnapshot
W0709 03:39:57.939648   11280 azurefile.go:480] parsing volumeID(vol_1#) return with error: error parsing volume id: "vol_1#", should at least contain two #
--- PASS: TestDeleteSnapshot (0.00s)
=== RUN   TestControllerExpandVolume
=== RUN   TestControllerExpandVolume/Volume_ID_missing
=== RUN   TestControllerExpandVolume/Volume_Capacity_range_missing
=== RUN   TestControllerExpandVolume/Volume_capabilities_missing
=== RUN   TestControllerExpandVolume/Invalid_Volume_ID
... skipping 10 lines ...
    --- PASS: TestControllerExpandVolume/Volume_capabilities_missing (0.00s)
    --- PASS: TestControllerExpandVolume/Invalid_Volume_ID (0.00s)
    --- PASS: TestControllerExpandVolume/Disk_name_not_empty (0.00s)
    --- PASS: TestControllerExpandVolume/Resize_file_share_returns_error (0.00s)
    --- PASS: TestControllerExpandVolume/Valid_request (0.00s)
=== RUN   TestGetShareURL
W0709 03:39:57.943493   11280 azurefile.go:480] parsing volumeID(vol_1) return with error: error parsing volume id: "vol_1", should at least contain two #
--- PASS: TestGetShareURL (0.00s)
=== RUN   TestGetServiceURL
W0709 03:39:57.944040   11280 azurefile.go:480] parsing volumeID(vol_1) return with error: error parsing volume id: "vol_1", should at least contain two #
E0709 03:39:57.944273   11280 controllerserver.go:855] parse serviceURLTemplate error: parse "https://^f5713de20cde511e8ba4900.file.abc": invalid character "^" in host name
--- PASS: TestGetServiceURL (0.00s)
=== RUN   TestSnapshotExists
W0709 03:39:57.944673   11280 azurefile.go:480] parsing volumeID(vol_1) return with error: error parsing volume id: "vol_1", should at least contain two #
--- PASS: TestSnapshotExists (0.00s)
=== RUN   TestGetCapacity
--- PASS: TestGetCapacity (0.00s)
=== RUN   TestListVolumes
--- PASS: TestListVolumes (0.00s)
=== RUN   TestListSnapshots
... skipping 15 lines ...
--- PASS: TestGetPluginCapabilities (0.00s)
=== RUN   TestNodeGetInfo
--- PASS: TestNodeGetInfo (0.00s)
=== RUN   TestNodeGetCapabilities
--- PASS: TestNodeGetCapabilities (0.00s)
=== RUN   TestNodePublishVolume
E0709 03:39:57.948092   11280 nodeserver.go:432] MakeDir failed on target: /home/prow/go/src/sigs.k8s.io/azurefile-csi-driver/pkg/azurefile/azure.go (mkdir /home/prow/go/src/sigs.k8s.io/azurefile-csi-driver/pkg/azurefile/azure.go: not a directory)
--- PASS: TestNodePublishVolume (0.00s)
=== RUN   TestNodeUnpublishVolume
W0709 03:39:57.949198   11280 mount_helper_common.go:34] Warning: Unmount skipped because path does not exist: /home/prow/go/src/sigs.k8s.io/azurefile-csi-driver/pkg/azurefile/abc.go
--- PASS: TestNodeUnpublishVolume (0.00s)
=== RUN   TestNodeStageVolume
W0709 03:39:57.950262   11280 azurefile.go:480] parsing volumeID(vol_1) return with error: error parsing volume id: "vol_1", should at least contain two #
I0709 03:39:57.951039   11280 mount_linux.go:408] Disk "/home/prow/go/src/sigs.k8s.io/azurefile-csi-driver/pkg/azurefile/proxy-mount/test_disk" appears to be unformatted, attempting to format as type: "ext4" with options: [-F -m0 /home/prow/go/src/sigs.k8s.io/azurefile-csi-driver/pkg/azurefile/proxy-mount/test_disk]
E0709 03:39:57.951274   11280 mount_linux.go:414] format of disk "/home/prow/go/src/sigs.k8s.io/azurefile-csi-driver/pkg/azurefile/proxy-mount/test_disk" failed: type:("ext4") target:("/home/prow/go/src/sigs.k8s.io/azurefile-csi-driver/pkg/azurefile/source_test") options:("barrier=1,errors=remount-ro,loop,noatime,defaults") errcode:(formatting failed) output:() 
I0709 03:39:57.951811   11280 mount_linux.go:408] Disk "/home/prow/go/src/sigs.k8s.io/azurefile-csi-driver/pkg/azurefile/proxy-mount/test_disk" appears to be unformatted, attempting to format as type: "ext4" with options: [-F -m0 /home/prow/go/src/sigs.k8s.io/azurefile-csi-driver/pkg/azurefile/proxy-mount/test_disk]
I0709 03:39:57.951893   11280 mount_linux.go:418] Disk successfully formatted (mkfs): ext4 - /home/prow/go/src/sigs.k8s.io/azurefile-csi-driver/pkg/azurefile/proxy-mount/test_disk /home/prow/go/src/sigs.k8s.io/azurefile-csi-driver/pkg/azurefile/source_test
--- PASS: TestNodeStageVolume (0.00s)
=== RUN   TestNodeUnstageVolume
W0709 03:39:57.952676   11280 mount_helper_common.go:34] Warning: Unmount skipped because path does not exist: /home/prow/go/src/sigs.k8s.io/azurefile-csi-driver/pkg/azurefile/abc.go
W0709 03:39:57.952745   11280 mount_helper_common.go:34] Warning: Unmount skipped because path does not exist: /home/prow/go/src/sigs.k8s.io/azurefile-csi-driver/pkg/azurefile/proxy-mount
--- PASS: TestNodeUnstageVolume (0.00s)
=== RUN   TestNodeGetVolumeStats
--- PASS: TestNodeGetVolumeStats (0.00s)
=== RUN   TestEnsureMountPoint
W0709 03:39:57.953797   11280 nodeserver.go:423] ReadDir ./false_is_likely_target failed with open ./false_is_likely_target: no such file or directory, unmount this directory
E0709 03:39:57.953885   11280 nodeserver.go:432] MakeDir failed on target: ./azure.go (mkdir ./azure.go: not a directory)
--- PASS: TestEnsureMountPoint (0.00s)
=== RUN   TestMakeDir
--- PASS: TestMakeDir (0.00s)
=== RUN   TestNodeExpandVolume
--- PASS: TestNodeExpandVolume (0.00s)
=== RUN   TestSimpleLockEntry
... skipping 305 lines ...
Preparing to unpack .../yamllint_1.15.0-1_all.deb ...
Unpacking yamllint (1.15.0-1) ...
Setting up python3-pkg-resources (40.8.0-1) ...
Setting up python3-pathspec (0.5.9-1) ...
Setting up yamllint (1.15.0-1) ...
checking yamllint under path: deploy/*.yaml ...
deploy/crd-csi-snapshot.yaml:1:1: [error] too many blank lines (1 > 0) (empty-lines)
deploy/crd-csi-snapshot.yaml:20:3: [error] wrong indentation: expected 4 but found 2 (indentation)
deploy/crd-csi-snapshot.yaml:21:5: [error] wrong indentation: expected 6 but found 4 (indentation)
deploy/crd-csi-snapshot.yaml:101:13: [error] wrong indentation: expected 14 but found 12 (indentation)
deploy/crd-csi-snapshot.yaml:173:9: [error] wrong indentation: expected 10 but found 8 (indentation)
deploy/crd-csi-snapshot.yaml:204:3: [error] wrong indentation: expected 4 but found 2 (indentation)
deploy/crd-csi-snapshot.yaml:205:5: [error] wrong indentation: expected 6 but found 4 (indentation)
deploy/crd-csi-snapshot.yaml:238:13: [error] wrong indentation: expected 14 but found 12 (indentation)
deploy/crd-csi-snapshot.yaml:257:9: [error] wrong indentation: expected 10 but found 8 (indentation)
deploy/crd-csi-snapshot.yaml:288:3: [error] wrong indentation: expected 4 but found 2 (indentation)
deploy/crd-csi-snapshot.yaml:289:5: [error] wrong indentation: expected 6 but found 4 (indentation)
deploy/crd-csi-snapshot.yaml:353:17: [error] wrong indentation: expected 18 but found 16 (indentation)
deploy/crd-csi-snapshot.yaml:424:13: [error] wrong indentation: expected 14 but found 12 (indentation)
deploy/crd-csi-snapshot.yaml:490:9: [error] wrong indentation: expected 10 but found 8 (indentation)
checking yamllint under path: deploy/example/*.yaml ...
checking yamllint under path: deploy/example/snapshot/*.yaml ...
checking yamllint under path: deploy/example/disk/*.yaml ...
checking yamllint under path: deploy/example/windows/*.yaml ...
checking yamllint under path: deploy/example/metrics/*.yaml ...
checking yamllint under path: deploy/example/largeFileShares/*.yaml ...
... skipping 306 lines ...
-  logLevel: 5
 
 snapshot:
   enabled: false

latest chart config has changed, pls run "helm package charts/latest/azurefile-csi-driver -d charts/latest/" to update tgz file
make: *** [Makefile:69: verify] Error 1
+ EXIT_VALUE=2
+ set +o xtrace