This job view page is being replaced by Spyglass soon. Check out the new job view.
PRjonathanrainer: Support ReadWriteOncePod
ResultABORTED
Tests 0 failed / 0 succeeded
Started2022-06-24 12:07
Elapsed26m28s
Revision75249fdb8aeea01d2c4a6d5c31a0804e53c9997b
Refs 714

No Test Failures!


Error lines from build-log.txt

... skipping 232 lines ...
#10 2.849 --> Processing Dependency: libperl.so()(64bit) for package: 4:perl-5.16.3-299.amzn2.0.1.x86_64
#10 2.849 ---> Package perl-File-Temp.noarch 0:0.23.01-3.amzn2 will be installed
#10 2.851 ---> Package perl-Getopt-Long.noarch 0:2.40-3.amzn2 will be installed
#10 2.853 --> Processing Dependency: perl(Pod::Usage) >= 1.14 for package: perl-Getopt-Long-2.40-3.amzn2.noarch
#10 2.853 --> Processing Dependency: perl(Text::ParseWords) for package: perl-Getopt-Long-2.40-3.amzn2.noarch
#10 2.854 ---> Package perl-Git.noarch 0:2.32.0-1.amzn2.0.1 will be installed
#10 2.856 --> Processing Dependency: perl(Error) for package: perl-Git-2.32.0-1.amzn2.0.1.noarch
#10 2.858 ---> Package perl-PathTools.x86_64 0:3.40-5.amzn2.0.2 will be installed
#10 2.859 ---> Package perl-TermReadKey.x86_64 0:2.30-20.amzn2.0.2 will be installed
#10 2.861 ---> Package perl-Thread-Queue.noarch 0:3.02-2.amzn2 will be installed
#10 2.861 ---> Package perl-threads.x86_64 0:1.87-4.amzn2.0.2 will be installed
#10 2.863 ---> Package pkgconfig.x86_64 1:0.27.1-4.amzn2.0.2 will be installed
#10 2.866 ---> Package system-rpm-config.noarch 0:9.1.0-76.amzn2.0.14 will be installed
... skipping 15 lines ...
#10 2.931 --> Processing Dependency: openssh = 7.4p1-22.amzn2.0.1 for package: openssh-clients-7.4p1-22.amzn2.0.1.x86_64
#10 2.933 --> Processing Dependency: fipscheck-lib(x86-64) >= 1.3.0 for package: openssh-clients-7.4p1-22.amzn2.0.1.x86_64
#10 2.935 --> Processing Dependency: libfipscheck.so.1()(64bit) for package: openssh-clients-7.4p1-22.amzn2.0.1.x86_64
#10 2.935 --> Processing Dependency: libedit.so.0()(64bit) for package: openssh-clients-7.4p1-22.amzn2.0.1.x86_64
#10 2.937 ---> Package pcre2.x86_64 0:10.23-2.amzn2.0.2 will be installed
#10 2.939 ---> Package perl-Carp.noarch 0:1.26-244.amzn2 will be installed
#10 2.939 ---> Package perl-Error.noarch 1:0.17020-2.amzn2 will be installed
#10 2.940 ---> Package perl-Exporter.noarch 0:5.68-3.amzn2 will be installed
#10 2.941 ---> Package perl-File-Path.noarch 0:2.09-2.amzn2 will be installed
#10 2.942 ---> Package perl-Filter.x86_64 0:1.49-3.amzn2.0.2 will be installed
#10 2.944 ---> Package perl-Pod-Simple.noarch 1:3.28-4.amzn2 will be installed
#10 2.947 --> Processing Dependency: perl(Pod::Escapes) >= 1.04 for package: 1:perl-Pod-Simple-3.28-4.amzn2.noarch
#10 2.950 --> Processing Dependency: perl(Encode) for package: 1:perl-Pod-Simple-3.28-4.amzn2.noarch
... skipping 176 lines ...
#10 3.380  pam                       x86_64 1.1.8-23.amzn2.0.1           amzn2-core 715 k
#10 3.380  patch                     x86_64 2.7.1-12.amzn2.0.2           amzn2-core 110 k
#10 3.380  pcre2                     x86_64 10.23-2.amzn2.0.2            amzn2-core 209 k
#10 3.380  perl                      x86_64 4:5.16.3-299.amzn2.0.1       amzn2-core 8.0 M
#10 3.380  perl-Carp                 noarch 1.26-244.amzn2               amzn2-core  19 k
#10 3.380  perl-Encode               x86_64 2.51-7.amzn2.0.2             amzn2-core 1.5 M
#10 3.380  perl-Error                noarch 1:0.17020-2.amzn2            amzn2-core  32 k
#10 3.380  perl-Exporter             noarch 5.68-3.amzn2                 amzn2-core  29 k
#10 3.380  perl-File-Path            noarch 2.09-2.amzn2                 amzn2-core  27 k
#10 3.380  perl-File-Temp            noarch 0.23.01-3.amzn2              amzn2-core  56 k
#10 3.380  perl-Filter               x86_64 1.49-3.amzn2.0.2             amzn2-core  76 k
#10 3.380  perl-Getopt-Long          noarch 2.40-3.amzn2                 amzn2-core  56 k
#10 3.380  perl-Git                  noarch 2.32.0-1.amzn2.0.1           amzn2-core  43 k
... skipping 88 lines ...
#10 8.739   Installing : 1:perl-Pod-Simple-3.28-4.amzn2.noarch                      34/88 
#10 8.784   Installing : perl-Getopt-Long-2.40-3.amzn2.noarch                       35/88 
#10 8.924   Installing : 4:perl-libs-5.16.3-299.amzn2.0.1.x86_64                    36/88 
#10 10.65   Installing : 4:perl-5.16.3-299.amzn2.0.1.x86_64                         37/88 
#10 10.71   Installing : perl-Thread-Queue-3.02-2.amzn2.noarch                      38/88 
#10 10.75   Installing : perl-TermReadKey-2.30-20.amzn2.0.2.x86_64                  39/88 
#10 10.78   Installing : 1:perl-Error-0.17020-2.amzn2.noarch                        40/88 
#10 10.81   Installing : fipscheck-lib-1.4.1-6.amzn2.0.2.x86_64                     41/88 
#10 10.86   Installing : fipscheck-1.4.1-6.amzn2.0.2.x86_64                         42/88 
#10 10.91   Installing : dwz-0.11-3.amzn2.0.3.x86_64                                43/88 
#10 10.95   Installing : 1:pkgconfig-0.27.1-4.amzn2.0.2.x86_64                      44/88 
#10 11.03   Installing : pcre2-10.23-2.amzn2.0.2.x86_64                             45/88 
#10 11.10   Installing : libsmartcols-2.30.2-2.amzn2.0.7.x86_64                     46/88 
... skipping 33 lines ...
#14 ...

#10 [linux-amazon 3/7] RUN if [ "github" = "yum" ];     then echo "Installing efs-utils from Amazon Linux 2 yum repo" &&          yum -y install amazon-efs-utils-1.31.1-1.amzn2.noarch;     else echo "Installing efs-utils from github using the latest git tag" &&          yum -y install git rpm-build make &&          git clone https://github.com/aws/efs-utils &&          cd efs-utils &&          git checkout $(git describe --tags $(git rev-list --tags --max-count=1)) &&          make rpm && yum -y install build/amazon-efs-utils*rpm &&          cd .. && rm -rf efs-utils &&          yum clean all;     fi
#10 15.96   Installing : systemd-libs-219-78.amzn2.0.18.x86_64                      75/88 
#10 16.03   Installing : 1:dbus-libs-1.10.24-7.amzn2.x86_64                         76/88 
#10 17.59   Installing : systemd-219-78.amzn2.0.18.x86_64                           77/88 
#10 18.10 Failed to get D-Bus connection: Operation not permitted
#10 18.13   Installing : elfutils-default-yama-scope-0.176-2.amzn2.noarch           78/88 
#10 18.32   Installing : 1:dbus-1.10.24-7.amzn2.x86_64                              79/88 
#10 18.41   Installing : elfutils-0.176-2.amzn2.x86_64                              80/88 
#10 18.60   Installing : openssh-7.4p1-22.amzn2.0.1.x86_64                          81/88 
#10 18.79   Installing : openssh-clients-7.4p1-22.amzn2.0.1.x86_64                  82/88 
#10 20.00   Installing : git-core-2.32.0-1.amzn2.0.1.x86_64                         83/88 
... skipping 55 lines ...
#10 22.10   Verifying  : perl-File-Temp-0.23.01-3.amzn2.noarch                      51/88 
#10 22.11   Verifying  : perl-srpm-macros-1-8.amzn2.0.1.noarch                      52/88 
#10 22.13   Verifying  : pam-1.1.8-23.amzn2.0.1.x86_64                              53/88 
#10 22.15   Verifying  : xz-5.2.2-1.amzn2.0.3.x86_64                                54/88 
#10 22.16   Verifying  : ustr-1.0.4-16.amzn2.0.3.x86_64                             55/88 
#10 22.18   Verifying  : less-458-9.amzn2.0.2.x86_64                                56/88 
#10 22.19   Verifying  : 1:perl-Error-0.17020-2.amzn2.noarch                        57/88 
#10 22.21   Verifying  : perl-Pod-Usage-1.63-3.amzn2.noarch                         58/88 
#10 22.23   Verifying  : unzip-6.0-43.amzn2.x86_64                                  59/88 
#10 22.25   Verifying  : 1:perl-parent-0.225-244.amzn2.0.1.noarch                   60/88 
#10 22.27   Verifying  : perl-Pod-Perldoc-3.20-4.amzn2.noarch                       61/88 
#10 22.28   Verifying  : 2:tar-1.26-35.amzn2.x86_64                                 62/88 
#10 22.30   Verifying  : zip-3.0-11.amzn2.0.2.x86_64                                63/88 
... skipping 69 lines ...
#10 22.82   pam.x86_64 0:1.1.8-23.amzn2.0.1                                               
#10 22.82   patch.x86_64 0:2.7.1-12.amzn2.0.2                                             
#10 22.82   pcre2.x86_64 0:10.23-2.amzn2.0.2                                              
#10 22.82   perl.x86_64 4:5.16.3-299.amzn2.0.1                                            
#10 22.82   perl-Carp.noarch 0:1.26-244.amzn2                                             
#10 22.82   perl-Encode.x86_64 0:2.51-7.amzn2.0.2                                         
#10 22.82   perl-Error.noarch 1:0.17020-2.amzn2                                           
#10 22.82   perl-Exporter.noarch 0:5.68-3.amzn2                                           
#10 22.82   perl-File-Path.noarch 0:2.09-2.amzn2                                          
#10 22.82   perl-File-Temp.noarch 0:0.23.01-3.amzn2                                       
#10 22.82   perl-Filter.x86_64 0:1.49-3.amzn2.0.2                                         
#10 22.82   perl-Getopt-Long.noarch 0:2.40-3.amzn2                                        
#10 22.82   perl-Git.noarch 0:2.32.0-1.amzn2.0.1                                          
... skipping 563 lines ...
|. =     S o      |
|o.       .       |
|+.o .   .        |
|o=.+.. .         |
|=+*+. .          |
+----[SHA256]-----+
Error: unable to describe control plane "test-cluster-18432-k8s-local": operation error EKS: DescribeCluster, https response error StatusCode: 404, RequestID: 5479fd10-1613-4e11-873d-25c6c6332c4c, ResourceNotFoundException: No cluster found for name: test-cluster-18432-k8s-local.
###
## Creating cluster test-cluster-18432-k8s-local with /home/prow/go/src/github.com/kubernetes-sigs/aws-efs-csi-driver/hack/e2e/csi-test-artifacts/test-cluster-18432.k8s.local.eksctl.yaml (dry run)
#
###
## Patching cluster test-cluster-18432-k8s-local with ./hack/eksctl-patch.yaml
#
... skipping 100 lines ...
2022-06-24 12:28:06 [ℹ]  adding identity "arn:aws:iam::607362164682:role/Infra-prod-KopsDeleteAllLambdaServiceRoleF1578477-1ELDFIB4KCMXV" to auth ConfigMap
###
## Deploying driver
#
+ /home/prow/go/src/github.com/kubernetes-sigs/aws-efs-csi-driver/hack/e2e/csi-test-artifacts/bin/helm upgrade --install aws-efs-csi-driver --namespace kube-system --set image.repository=607362164682.dkr.ecr.us-west-2.amazonaws.com/aws-efs-csi-driver --set image.tag=18432 --wait --kubeconfig /home/prow/go/src/github.com/kubernetes-sigs/aws-efs-csi-driver/hack/e2e/csi-test-artifacts/test-cluster-18432.k8s.local.eksctl.kubeconfig ./charts/aws-efs-csi-driver -f ./hack/values_eksctl.yaml
Release "aws-efs-csi-driver" does not exist. Installing it now.
Error: timed out waiting for the condition
make: *** [Makefile:131: test-e2e-external-eks] Error 1
+ EXIT_VALUE=2
+ set +o xtrace
Cleaning up after docker in docker.
================================================================================
Cleaning up after docker
Stopping Docker: docker