This job view page is being replaced by Spyglass soon. Check out the new job view.
PRmgdevstack: Promote e2e "verifying service's sessionAffinity for ClusterIP and NodePort services" to Conformance
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-08-29 00:54
Elapsed1h30m
Revision
Buildergke-prow-ssd-pool-1a225945-6r1w
Refs master:41049fdf
76443:fc84ff19
pod722477e2-c9f7-11e9-95e8-0edbbe63ee63
infra-commit7606b98f4
job-versionv1.17.0-alpha.0.845+35a5289dd1ab9c-dirty
pod722477e2-c9f7-11e9-95e8-0edbbe63ee63
repok8s.io/kubernetes
repo-commit35a5289dd1ab9cd6a6899918308154664a8f2b0e
repos{u'k8s.io/kubernetes': u'master:41049fdf4b7b47742faf1f1265100f079afeccf6,76443:fc84ff19464f8fb45653d491acb2e10db0dbacf9', u'k8s.io/release': u'master'}
revisionv1.17.0-alpha.0.845+35a5289dd1ab9c-dirty

Test Failures


Up 59m9s

error creating cluster: cannot deploy: cannot get the create deployment future response: Code="DeploymentFailed" Message="At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/arm-debug for usage details." Details=[{"code":"Conflict","message":"{\r\n  \"status\": \"Failed\",\r\n  \"error\": {\r\n    \"code\": \"ResourceDeploymentFailure\",\r\n    \"message\": \"The resource operation completed with terminal provisioning state 'Failed'.\",\r\n    \"details\": [\r\n      {\r\n        \"code\": \"VMExtensionProvisioningError\",\r\n        \"message\": \"VM has reported a failure when processing extension 'cse-master-0'. Error message: \\\"Enable failed: failed to execute command: command terminated with exit status=30\\n[stdout]\\n\\n[stderr]\\nConnection to k8s.gcr.io 443 port [tcp/https] succeeded!\\nConnection to gcr.io 443 port [tcp/https] succeeded!\\nConnection to docker.io 443 port [tcp/https] succeeded!\\n\\\".\"\r\n      }\r\n    ]\r\n  }\r\n}"}]
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 912 lines ...
W0829 01:43:44.298] 2019/08/29 01:43:44 azure.go:632: Validating deployment ARM templates.
W0829 01:43:45.866] 2019/08/29 01:43:45 azure.go:638: Deploying cluster kubetest-bfe86f8b-c9f7-11e9-93d8-36a1d7e0c120 in resource group kubetest-bfe86f8b-c9f7-11e9-93d8-36a1d7e0c120.
W0829 02:17:54.156] 2019/08/29 02:17:54 azure.go:897: Deleting resource group: kubetest-bfe86f8b-c9f7-11e9-93d8-36a1d7e0c120.
W0829 02:24:41.815] 2019/08/29 02:24:41 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0829 02:24:41.816] 2019/08/29 02:24:41 process.go:153: Running: bash -c . hack/lib/version.sh && KUBE_ROOT=. kube::version::get_version_vars && echo "${KUBE_GIT_VERSION-}"
W0829 02:24:42.528] 2019/08/29 02:24:42 process.go:155: Step 'bash -c . hack/lib/version.sh && KUBE_ROOT=. kube::version::get_version_vars && echo "${KUBE_GIT_VERSION-}"' finished in 708.967007ms
W0829 02:24:42.529] 2019/08/29 02:24:42 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: cannot deploy: cannot get the create deployment future response: Code="DeploymentFailed" Message="At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/arm-debug for usage details." Details=[{"code":"Conflict","message":"{\r\n  \"status\": \"Failed\",\r\n  \"error\": {\r\n    \"code\": \"ResourceDeploymentFailure\",\r\n    \"message\": \"The resource operation completed with terminal provisioning state 'Failed'.\",\r\n    \"details\": [\r\n      {\r\n        \"code\": \"VMExtensionProvisioningError\",\r\n        \"message\": \"VM has reported a failure when processing extension 'cse-master-0'. Error message: \\\"Enable failed: failed to execute command: command terminated with exit status=30\\n[stdout]\\n\\n[stderr]\\nConnection to k8s.gcr.io 443 port [tcp/https] succeeded!\\nConnection to gcr.io 443 port [tcp/https] succeeded!\\nConnection to docker.io 443 port [tcp/https] succeeded!\\n\\\".\"\r\n      }\r\n    ]\r\n  }\r\n}"}]
W0829 02:24:42.531] Traceback (most recent call last):
W0829 02:24:42.531]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0829 02:24:42.535]     main(parse_args())
W0829 02:24:42.535]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0829 02:24:42.535]     mode.start(runner_args)
W0829 02:24:42.535]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0829 02:24:42.535]     check_env(env, self.command, *args)
W0829 02:24:42.535]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0829 02:24:42.535]     subprocess.check_call(cmd, env=env)
W0829 02:24:42.535]   File "/usr/lib/python2.7/subprocess.py", line 186, in check_call
W0829 02:24:42.537]     raise CalledProcessError(retcode, cmd)
W0829 02:24:42.538] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--build=bazel', '--stage=gs://kubernetes-release-pull/ci/pull-kubernetes-e2e-aks-engine-azure-windows', '--up', '--down', '--test', '--deployment=acsengine', '--provider=skeleton', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--ginkgo-parallel=4', '--acsengine-admin-username=azureuser', '--acsengine-admin-password=AdminPassw0rd', '--acsengine-creds=/etc/azure-cred/credentials', '--acsengine-download-url=https://aka.ms/aks-engine/aks-engine-k8s-e2e.tar.gz', '--acsengine-public-key=/etc/azure-ssh/azure-ssh-pub', '--acsengine-winZipBuildScript=https://raw.githubusercontent.com/kubernetes-sigs/windows-testing/master/build/build-windows-k8s.sh', '--acsengine-orchestratorRelease=1.15', '--acsengine-template-url=https://raw.githubusercontent.com/kubernetes-sigs/windows-testing/master/job-templates/kubernetes_release_staging.json', '--acsengine-win-binaries', '--acsengine-hyperkube', '--acsengine-agentpoolcount=2', '--test_args=--ginkgo.flakeAttempts=2 --num-nodes=2 --node-os-distro=windows --ginkgo.focus=\\[Conformance\\]|\\[NodeConformance\\]|\\[sig-windows\\]|\\[sig-apps\\].CronJob|\\[sig-api-machinery\\].ResourceQuota|\\[sig-scheduling\\].SchedulerPreemption --ginkgo.skip=\\[LinuxOnly\\]|GMSA|\\[Serial\\]', '--timeout=450m')' returned non-zero exit status 1
E0829 02:24:42.550] Command failed
I0829 02:24:42.550] process 689 exited with code 1 after 88.8m
E0829 02:24:42.550] FAIL: pull-kubernetes-e2e-aks-engine-azure-windows
I0829 02:24:42.551] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0829 02:24:43.090] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0829 02:24:43.155] process 131616 exited with code 0 after 0.0m
I0829 02:24:43.156] Call:  gcloud config get-value account
I0829 02:24:43.480] process 131628 exited with code 0 after 0.0m
I0829 02:24:43.480] Will upload results to gs://kubernetes-jenkins/pr-logs/ using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0829 02:24:43.481] Upload result and artifacts...
I0829 02:24:43.481] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/pr-logs/pull/76443/pull-kubernetes-e2e-aks-engine-azure-windows/1166876724898566144
I0829 02:24:43.482] Call:  gsutil ls gs://kubernetes-jenkins/pr-logs/pull/76443/pull-kubernetes-e2e-aks-engine-azure-windows/1166876724898566144/artifacts
W0829 02:24:44.695] CommandException: One or more URLs matched no objects.
E0829 02:24:44.825] Command failed
I0829 02:24:44.825] process 131640 exited with code 1 after 0.0m
W0829 02:24:44.826] Remote dir gs://kubernetes-jenkins/pr-logs/pull/76443/pull-kubernetes-e2e-aks-engine-azure-windows/1166876724898566144/artifacts not exist yet
I0829 02:24:44.826] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/pr-logs/pull/76443/pull-kubernetes-e2e-aks-engine-azure-windows/1166876724898566144/artifacts
I0829 02:24:46.671] process 131782 exited with code 0 after 0.0m
I0829 02:24:46.672] Call:  git rev-parse HEAD
I0829 02:24:46.676] process 132306 exited with code 0 after 0.0m
... skipping 20 lines ...