This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-04-01 05:58
Elapsed3m13s
Revision
Builderb6037627-73dd-11ea-901a-3a7046a79cdf
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/e633fb61-5f24-43fb-975f-3040056ff23c/targets/test'}}
resultstorehttps://source.cloud.google.com/results/invocations/e633fb61-5f24-43fb-975f-3040056ff23c/targets/test
infra-commit1b9b50e18
job-versionv1.17.5-beta.0.22+ea3eeb494a528e
revisionv1.17.5-beta.0.22+ea3eeb494a528e

Test Failures


Up 1m2s

error creating cluster: error during gcloud container clusters create --quiet --project=k8s-test-f08378c6bb --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-bd4d093510 --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.5-beta.0.22+ea3eeb494a528e test-bd4d093510: exit status 1
				from junit_runner.xml

Filter through log files


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0401 05:58:18.496] process 49 exited with code 0 after 0.0m
I0401 05:58:18.497] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0401 05:58:18.497] Root: /workspace
I0401 05:58:18.497] cd to /workspace
I0401 05:58:18.498] Configure environment...
I0401 05:58:18.498] Call:  git show -s --format=format:%ct HEAD
W0401 05:58:18.503] fatal: not a git repository (or any of the parent directories): .git
I0401 05:58:18.503] process 63 exited with code 128 after 0.0m
W0401 05:58:18.504] Unable to print commit date for HEAD
I0401 05:58:18.504] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0401 05:58:19.123] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0401 05:58:19.289] process 64 exited with code 0 after 0.0m
I0401 05:58:19.290] Call:  gcloud config get-value account
... skipping 426 lines ...
W0401 06:01:18.807] 2020/04/01 06:01:18 process.go:155: Step 'gcloud compute networks create test-bd4d093510 --project=k8s-test-f08378c6bb --subnet-mode=auto' finished in 1m0.58148834s
W0401 06:01:18.808] 2020/04/01 06:01:18 process.go:153: Running: gcloud container clusters create --quiet --project=k8s-test-f08378c6bb --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-bd4d093510 --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.5-beta.0.22+ea3eeb494a528e test-bd4d093510
W0401 06:01:19.386] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0401 06:01:19.387] WARNING: Starting with version 1.18, clusters will have shielded GKE nodes by default.
W0401 06:01:19.387] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0401 06:01:19.387] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0401 06:01:19.480] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0401 06:01:19.560] 2020/04/01 06:01:19 process.go:155: Step 'gcloud container clusters create --quiet --project=k8s-test-f08378c6bb --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-bd4d093510 --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.5-beta.0.22+ea3eeb494a528e test-bd4d093510' finished in 752.09283ms
W0401 06:01:20.939] 2020/04/01 06:01:20 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0401 06:01:20.947] 2020/04/01 06:01:20 main.go:317: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --quiet --project=k8s-test-f08378c6bb --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-bd4d093510 --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.5-beta.0.22+ea3eeb494a528e test-bd4d093510: exit status 1
W0401 06:01:20.953] Traceback (most recent call last):
W0401 06:01:20.953]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0401 06:01:20.953]     main(parse_args())
W0401 06:01:20.954]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0401 06:01:20.954]     mode.start(runner_args)
W0401 06:01:20.954]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0401 06:01:20.954]     check_env(env, self.command, *args)
W0401 06:01:20.954]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0401 06:01:20.954]     subprocess.check_call(cmd, env=env)
W0401 06:01:20.955]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0401 06:01:20.955]     raise CalledProcessError(retcode, cmd)
W0401 06:01:20.955] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-bd4d093510', '--gcp-network=test-bd4d093510', '--check-leaked-resources', '--gcp-zone=us-west1-c', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-2', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/latest-1.17', '--timeout=660m', '--test_args=--ginkgo.focus=\\[Serial\\]|\\[Disruptive\\] --ginkgo.skip=\\[Flaky\\]|\\[Feature:.+\\] --minStartupPods=8', '--ginkgo-parallel=1')' returned non-zero exit status 1
E0401 06:01:20.970] Command failed
I0401 06:01:20.970] process 274 exited with code 1 after 3.0m
E0401 06:01:20.971] FAIL: ci-kubernetes-e2e-gke-ubuntu2-k8sstable1-serial
I0401 06:01:20.971] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0401 06:01:21.624] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0401 06:01:21.700] process 1448 exited with code 0 after 0.0m
I0401 06:01:21.701] Call:  gcloud config get-value account
I0401 06:01:22.244] process 1462 exited with code 0 after 0.0m
I0401 06:01:22.244] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0401 06:01:22.244] Upload result and artifacts...
I0401 06:01:22.244] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable1-serial/1245228908031250434
I0401 06:01:22.245] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable1-serial/1245228908031250434/artifacts
W0401 06:01:23.452] CommandException: One or more URLs matched no objects.
E0401 06:01:23.662] Command failed
I0401 06:01:23.662] process 1476 exited with code 1 after 0.0m
W0401 06:01:23.662] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable1-serial/1245228908031250434/artifacts not exist yet
I0401 06:01:23.663] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable1-serial/1245228908031250434/artifacts
I0401 06:01:25.964] process 1622 exited with code 0 after 0.0m
I0401 06:01:25.965] Call:  git rev-parse HEAD
W0401 06:01:25.972] fatal: not a git repository (or any of the parent directories): .git
E0401 06:01:25.973] Command failed
I0401 06:01:25.973] process 2150 exited with code 128 after 0.0m
I0401 06:01:25.974] Call:  git rev-parse HEAD
I0401 06:01:25.979] process 2151 exited with code 0 after 0.0m
I0401 06:01:25.980] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable1-serial/jobResultsCache.json
I0401 06:01:27.306] process 2152 exited with code 0 after 0.0m
I0401 06:01:27.307] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable1-serial/jobResultsCache.json#1585706433751066'
... skipping 8 lines ...