This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-04-01 09:59
Elapsed2m59s
Revision
Builder60b1fb29-73ff-11ea-901a-3a7046a79cdf
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/3244957a-e15e-412e-921e-b16fabfb3185/targets/test'}}
resultstorehttps://source.cloud.google.com/results/invocations/3244957a-e15e-412e-921e-b16fabfb3185/targets/test
infra-commit1b9b50e18
job-versionv1.17.5-beta.0.22+ea3eeb494a528e
revisionv1.17.5-beta.0.22+ea3eeb494a528e

Test Failures


Up 43s

error creating cluster: error during gcloud container clusters create --quiet --project=kube-gke-upg-1-4-lat-ctl-skew --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-8de59d074a --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.5-beta.0.22+ea3eeb494a528e test-8de59d074a: exit status 1
				from junit_runner.xml

Filter through log files


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0401 09:59:18.064] process 49 exited with code 0 after 0.0m
I0401 09:59:18.065] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0401 09:59:18.065] Root: /workspace
I0401 09:59:18.065] cd to /workspace
I0401 09:59:18.065] Configure environment...
I0401 09:59:18.066] Call:  git show -s --format=format:%ct HEAD
W0401 09:59:18.070] fatal: not a git repository (or any of the parent directories): .git
I0401 09:59:18.071] process 63 exited with code 128 after 0.0m
W0401 09:59:18.071] Unable to print commit date for HEAD
I0401 09:59:18.071] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0401 09:59:18.730] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0401 09:59:18.878] process 64 exited with code 0 after 0.0m
I0401 09:59:18.878] Call:  gcloud config get-value account
... skipping 426 lines ...
W0401 10:02:03.592] 2020/04/01 10:02:03 process.go:155: Step 'gcloud compute networks create test-8de59d074a --project=kube-gke-upg-1-4-lat-ctl-skew --subnet-mode=auto' finished in 41.949574823s
W0401 10:02:03.593] 2020/04/01 10:02:03 process.go:153: Running: gcloud container clusters create --quiet --project=kube-gke-upg-1-4-lat-ctl-skew --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-8de59d074a --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.5-beta.0.22+ea3eeb494a528e test-8de59d074a
W0401 10:02:04.173] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0401 10:02:04.173] WARNING: Starting with version 1.18, clusters will have shielded GKE nodes by default.
W0401 10:02:04.174] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0401 10:02:04.174] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0401 10:02:04.277] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0401 10:02:04.348] 2020/04/01 10:02:04 process.go:155: Step 'gcloud container clusters create --quiet --project=kube-gke-upg-1-4-lat-ctl-skew --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-8de59d074a --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.5-beta.0.22+ea3eeb494a528e test-8de59d074a' finished in 760.170009ms
W0401 10:02:05.790] 2020/04/01 10:02:05 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0401 10:02:05.799] 2020/04/01 10:02:05 main.go:317: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --quiet --project=kube-gke-upg-1-4-lat-ctl-skew --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-8de59d074a --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.5-beta.0.22+ea3eeb494a528e test-8de59d074a: exit status 1
W0401 10:02:05.805] Traceback (most recent call last):
W0401 10:02:05.805]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0401 10:02:05.805]     main(parse_args())
W0401 10:02:05.806]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0401 10:02:05.806]     mode.start(runner_args)
W0401 10:02:05.806]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0401 10:02:05.806]     check_env(env, self.command, *args)
W0401 10:02:05.806]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0401 10:02:05.807]     subprocess.check_call(cmd, env=env)
W0401 10:02:05.807]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0401 10:02:05.807]     raise CalledProcessError(retcode, cmd)
W0401 10:02:05.808] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-8de59d074a', '--gcp-network=test-8de59d074a', '--check-leaked-resources', '--gcp-zone=us-west1-c', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-2', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/latest-1.17', '--timeout=120m', '--test_args=--ginkgo.skip=\\[Slow\\]|\\[Serial\\]|\\[Disruptive\\]|\\[Flaky\\]|\\[Feature:.+\\] --minStartupPods=8', '--ginkgo-parallel=30')' returned non-zero exit status 1
E0401 10:02:05.817] Command failed
I0401 10:02:05.817] process 274 exited with code 1 after 2.7m
E0401 10:02:05.817] FAIL: ci-kubernetes-e2e-gke-ubuntu2-k8sstable1-default
I0401 10:02:05.817] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0401 10:02:06.501] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0401 10:02:06.564] process 1446 exited with code 0 after 0.0m
I0401 10:02:06.564] Call:  gcloud config get-value account
I0401 10:02:07.126] process 1460 exited with code 0 after 0.0m
I0401 10:02:07.127] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0401 10:02:07.127] Upload result and artifacts...
I0401 10:02:07.127] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable1-default/1245289557574815745
I0401 10:02:07.127] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable1-default/1245289557574815745/artifacts
W0401 10:02:08.325] CommandException: One or more URLs matched no objects.
E0401 10:02:08.477] Command failed
I0401 10:02:08.477] process 1474 exited with code 1 after 0.0m
W0401 10:02:08.477] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable1-default/1245289557574815745/artifacts not exist yet
I0401 10:02:08.477] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable1-default/1245289557574815745/artifacts
I0401 10:02:10.488] process 1620 exited with code 0 after 0.0m
I0401 10:02:10.489] Call:  git rev-parse HEAD
W0401 10:02:10.494] fatal: not a git repository (or any of the parent directories): .git
E0401 10:02:10.495] Command failed
I0401 10:02:10.495] process 2148 exited with code 128 after 0.0m
I0401 10:02:10.495] Call:  git rev-parse HEAD
I0401 10:02:10.501] process 2149 exited with code 0 after 0.0m
I0401 10:02:10.501] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable1-default/jobResultsCache.json
I0401 10:02:11.812] process 2150 exited with code 0 after 0.0m
I0401 10:02:11.813] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable1-default/jobResultsCache.json#1585720899800872'
... skipping 8 lines ...