This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-02-10 14:10
Elapsed4m35s
Revision
Buildergke-prow-default-pool-cf4891d4-xxpr
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/3c9c5a88-57bd-405f-84e2-f079c3edff21/targets/test'}}
pod08ef7516-4c0f-11ea-9d03-564fe64f5f51
resultstorehttps://source.cloud.google.com/results/invocations/3c9c5a88-57bd-405f-84e2-f079c3edff21/targets/test
infra-commit17ac16b80
job-versionv1.14.11-beta.1.2+c8b135d0b49c44
pod08ef7516-4c0f-11ea-9d03-564fe64f5f51
revisionv1.14.11-beta.1.2+c8b135d0b49c44

Test Failures


Up 55s

error creating cluster: error during gcloud container clusters create --quiet --project=gke-up-g1-3-g1-5-up-clu --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-1be8857228 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1.2+c8b135d0b49c44 test-1be8857228: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0210 14:10:52.563] process 47 exited with code 0 after 0.0m
I0210 14:10:52.563] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0210 14:10:52.564] Root: /workspace
I0210 14:10:52.564] cd to /workspace
I0210 14:10:52.564] Configure environment...
I0210 14:10:52.564] Call:  git show -s --format=format:%ct HEAD
W0210 14:10:52.567] fatal: not a git repository (or any of the parent directories): .git
I0210 14:10:52.568] process 60 exited with code 128 after 0.0m
W0210 14:10:52.568] Unable to print commit date for HEAD
I0210 14:10:52.568] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0210 14:10:53.045] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0210 14:10:53.365] process 61 exited with code 0 after 0.0m
I0210 14:10:53.365] Call:  gcloud config get-value account
... skipping 438 lines ...
W0210 14:15:04.384] 2020/02/10 14:15:04 process.go:155: Step 'gcloud compute networks create test-1be8857228 --project=gke-up-g1-3-g1-5-up-clu --subnet-mode=auto' finished in 54.095058785s
W0210 14:15:04.384] 2020/02/10 14:15:04 process.go:153: Running: gcloud container clusters create --quiet --project=gke-up-g1-3-g1-5-up-clu --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-1be8857228 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1.2+c8b135d0b49c44 test-1be8857228
W0210 14:15:04.922] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0210 14:15:04.922] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0210 14:15:04.923] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0210 14:15:04.923] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0210 14:15:05.018] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0210 14:15:05.062] 2020/02/10 14:15:05 process.go:155: Step 'gcloud container clusters create --quiet --project=gke-up-g1-3-g1-5-up-clu --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-1be8857228 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1.2+c8b135d0b49c44 test-1be8857228' finished in 686.907846ms
W0210 14:15:06.480] 2020/02/10 14:15:06 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0210 14:15:15.663] 2020/02/10 14:15:15 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --quiet --project=gke-up-g1-3-g1-5-up-clu --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-1be8857228 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1.2+c8b135d0b49c44 test-1be8857228: exit status 1
W0210 14:15:15.665] Traceback (most recent call last):
W0210 14:15:15.665]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0210 14:15:15.665]     main(parse_args())
W0210 14:15:15.666]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0210 14:15:15.666]     mode.start(runner_args)
W0210 14:15:15.666]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0210 14:15:15.666]     check_env(env, self.command, *args)
W0210 14:15:15.666]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0210 14:15:15.667]     subprocess.check_call(cmd, env=env)
W0210 14:15:15.667]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0210 14:15:15.667]     raise CalledProcessError(retcode, cmd)
W0210 14:15:15.668] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-1be8857228', '--gcp-network=test-1be8857228', '--check-leaked-resources', '--gcp-zone=us-west1-c', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-1', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/latest-1.14', '--timeout=150m', '--test_args=--ginkgo.focus=\\[Slow\\] --ginkgo.skip=\\[Serial\\]|\\[Disruptive\\]|\\[Flaky\\]|\\[Feature:.+\\] --minStartupPods=8', '--ginkgo-parallel=30')' returned non-zero exit status 1
E0210 14:15:15.676] Command failed
I0210 14:15:15.676] process 268 exited with code 1 after 4.3m
E0210 14:15:15.676] FAIL: ci-kubernetes-e2e-gke-ubuntu1-k8sstable3-slow
I0210 14:15:15.677] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0210 14:15:17.447] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0210 14:15:17.506] process 1403 exited with code 0 after 0.0m
I0210 14:15:17.506] Call:  gcloud config get-value account
I0210 14:15:18.025] process 1416 exited with code 0 after 0.0m
I0210 14:15:18.026] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0210 14:15:18.026] Upload result and artifacts...
I0210 14:15:18.026] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sstable3-slow/1226871087040565253
I0210 14:15:18.026] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sstable3-slow/1226871087040565253/artifacts
W0210 14:15:19.290] CommandException: One or more URLs matched no objects.
E0210 14:15:19.438] Command failed
I0210 14:15:19.546] process 1429 exited with code 1 after 0.0m
W0210 14:15:19.547] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sstable3-slow/1226871087040565253/artifacts not exist yet
I0210 14:15:19.547] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sstable3-slow/1226871087040565253/artifacts
I0210 14:15:22.101] process 1574 exited with code 0 after 0.0m
I0210 14:15:22.102] Call:  git rev-parse HEAD
W0210 14:15:22.109] fatal: not a git repository (or any of the parent directories): .git
E0210 14:15:22.109] Command failed
I0210 14:15:22.109] process 2101 exited with code 128 after 0.0m
I0210 14:15:22.109] Call:  git rev-parse HEAD
I0210 14:15:22.114] process 2102 exited with code 0 after 0.0m
I0210 14:15:22.114] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sstable3-slow/jobResultsCache.json
I0210 14:15:23.265] process 2103 exited with code 0 after 0.0m
I0210 14:15:23.266] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sstable3-slow/jobResultsCache.json#1581322504412071'
... skipping 8 lines ...