This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-04-09 10:00
Elapsed3m48s
Revision
Buildere098943d-7a48-11ea-81ca-8e4c2b7d37f3
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/285624e7-f2e4-4374-b5d7-090382c5db1f/targets/test'}}
resultstorehttps://source.cloud.google.com/results/invocations/285624e7-f2e4-4374-b5d7-090382c5db1f/targets/test
infra-commit26b2d1882
job-versionv1.19.0-alpha.1.447+7b20442513a518
revisionv1.19.0-alpha.1.447+7b20442513a518

Test Failures


Up 1m19s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.19.0-alpha.1.447+7b20442513a518 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0409 10:00:41.822] process 49 exited with code 0 after 0.0m
I0409 10:00:41.822] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0409 10:00:41.823] Root: /workspace
I0409 10:00:41.823] cd to /workspace
I0409 10:00:41.823] Configure environment...
I0409 10:00:41.824] Call:  git show -s --format=format:%ct HEAD
W0409 10:00:41.829] fatal: not a git repository (or any of the parent directories): .git
I0409 10:00:41.830] process 63 exited with code 128 after 0.0m
W0409 10:00:41.830] Unable to print commit date for HEAD
I0409 10:00:41.831] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0409 10:00:42.496] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0409 10:00:42.649] process 64 exited with code 0 after 0.0m
I0409 10:00:42.649] Call:  gcloud config get-value account
... skipping 432 lines ...
W0409 10:04:17.299] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0409 10:04:17.300] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0409 10:04:17.300] WARNING: Starting with version 1.18, clusters will have shielded GKE nodes by default.
W0409 10:04:17.300] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0409 10:04:17.301] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0409 10:04:17.301] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0409 10:04:17.381] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0409 10:04:17.453] 2020/04/09 10:04:17 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.19.0-alpha.1.447+7b20442513a518 bootstrap-e2e' finished in 758.046429ms
W0409 10:04:18.894] 2020/04/09 10:04:18 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0409 10:04:18.903] 2020/04/09 10:04:18 main.go:314: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.19.0-alpha.1.447+7b20442513a518 bootstrap-e2e: exit status 1
W0409 10:04:18.910] Traceback (most recent call last):
W0409 10:04:18.911]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0409 10:04:18.911]     main(parse_args())
W0409 10:04:18.911]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0409 10:04:18.911]     mode.start(runner_args)
W0409 10:04:18.911]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0409 10:04:18.912]     check_env(env, self.command, *args)
W0409 10:04:18.912]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0409 10:04:18.912]     subprocess.check_call(cmd, env=env)
W0409 10:04:18.912]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0409 10:04:18.912]     raise CalledProcessError(retcode, cmd)
W0409 10:04:18.913] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0409 10:04:18.923] Command failed
I0409 10:04:18.924] process 274 exited with code 1 after 3.6m
E0409 10:04:18.924] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu
I0409 10:04:18.924] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0409 10:04:19.564] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0409 10:04:19.635] process 1460 exited with code 0 after 0.0m
I0409 10:04:19.635] Call:  gcloud config get-value account
I0409 10:04:20.202] process 1474 exited with code 0 after 0.0m
I0409 10:04:20.202] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0409 10:04:20.203] Upload result and artifacts...
I0409 10:04:20.203] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1248188991858020357
I0409 10:04:20.203] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1248188991858020357/artifacts
W0409 10:04:21.364] CommandException: One or more URLs matched no objects.
E0409 10:04:21.529] Command failed
I0409 10:04:21.529] process 1488 exited with code 1 after 0.0m
W0409 10:04:21.529] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1248188991858020357/artifacts not exist yet
I0409 10:04:21.529] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1248188991858020357/artifacts
I0409 10:04:23.511] process 1634 exited with code 0 after 0.0m
I0409 10:04:23.513] Call:  git rev-parse HEAD
W0409 10:04:23.518] fatal: not a git repository (or any of the parent directories): .git
E0409 10:04:23.519] Command failed
I0409 10:04:23.519] process 2162 exited with code 128 after 0.0m
I0409 10:04:23.519] Call:  git rev-parse HEAD
I0409 10:04:23.525] process 2163 exited with code 0 after 0.0m
I0409 10:04:23.526] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/jobResultsCache.json
I0409 10:04:24.894] process 2164 exited with code 0 after 0.0m
I0409 10:04:24.895] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/jobResultsCache.json#1586419446805215'
... skipping 8 lines ...