This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-04-07 20:00
Elapsed3m32s
Revision
Builder5cdb273a-790a-11ea-81ca-8e4c2b7d37f3
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/260d9f7a-e8b2-4c37-9923-30d78792638a/targets/test'}}
resultstorehttps://source.cloud.google.com/results/invocations/260d9f7a-e8b2-4c37-9923-30d78792638a/targets/test
infra-commitdfa851b80
job-versionv1.19.0-alpha.1.392+46b28910895747
revisionv1.19.0-alpha.1.392+46b28910895747

Test Failures


Up 38s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.19.0-alpha.1.392+46b28910895747 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0407 20:00:49.229] process 49 exited with code 0 after 0.0m
I0407 20:00:49.229] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0407 20:00:49.230] Root: /workspace
I0407 20:00:49.230] cd to /workspace
I0407 20:00:49.230] Configure environment...
I0407 20:00:49.231] Call:  git show -s --format=format:%ct HEAD
W0407 20:00:49.242] fatal: not a git repository (or any of the parent directories): .git
I0407 20:00:49.243] process 63 exited with code 128 after 0.0m
W0407 20:00:49.243] Unable to print commit date for HEAD
I0407 20:00:49.243] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0407 20:00:50.828] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0407 20:00:51.356] process 64 exited with code 0 after 0.0m
I0407 20:00:51.357] Call:  gcloud config get-value account
... skipping 432 lines ...
W0407 20:04:02.086] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0407 20:04:02.087] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0407 20:04:02.088] WARNING: Starting with version 1.18, clusters will have shielded GKE nodes by default.
W0407 20:04:02.088] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0407 20:04:02.089] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0407 20:04:02.090] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0407 20:04:02.204] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0407 20:04:02.284] 2020/04/07 20:04:02 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.19.0-alpha.1.392+46b28910895747 bootstrap-e2e' finished in 970.549676ms
W0407 20:04:04.377] 2020/04/07 20:04:04 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0407 20:04:04.400] 2020/04/07 20:04:04 main.go:314: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.19.0-alpha.1.392+46b28910895747 bootstrap-e2e: exit status 1
W0407 20:04:04.432] Traceback (most recent call last):
W0407 20:04:04.432]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0407 20:04:04.432]     main(parse_args())
W0407 20:04:04.432]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0407 20:04:04.432]     mode.start(runner_args)
W0407 20:04:04.433]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0407 20:04:04.433]     check_env(env, self.command, *args)
W0407 20:04:04.433]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0407 20:04:04.433]     subprocess.check_call(cmd, env=env)
W0407 20:04:04.433]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0407 20:04:04.434]     raise CalledProcessError(retcode, cmd)
W0407 20:04:04.434] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0407 20:04:04.441] Command failed
I0407 20:04:04.441] process 274 exited with code 1 after 3.1m
E0407 20:04:04.441] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu
I0407 20:04:04.441] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0407 20:04:05.484] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0407 20:04:05.599] process 1458 exited with code 0 after 0.0m
I0407 20:04:05.600] Call:  gcloud config get-value account
I0407 20:04:06.353] process 1472 exited with code 0 after 0.0m
I0407 20:04:06.353] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0407 20:04:06.353] Upload result and artifacts...
I0407 20:04:06.353] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1247615211888709633
I0407 20:04:06.354] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1247615211888709633/artifacts
W0407 20:04:08.240] CommandException: One or more URLs matched no objects.
E0407 20:04:08.547] Command failed
I0407 20:04:08.547] process 1486 exited with code 1 after 0.0m
W0407 20:04:08.547] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1247615211888709633/artifacts not exist yet
I0407 20:04:08.548] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1247615211888709633/artifacts
I0407 20:04:12.224] process 1632 exited with code 0 after 0.1m
I0407 20:04:12.225] Call:  git rev-parse HEAD
W0407 20:04:12.236] fatal: not a git repository (or any of the parent directories): .git
E0407 20:04:12.236] Command failed
I0407 20:04:12.236] process 2160 exited with code 128 after 0.0m
I0407 20:04:12.236] Call:  git rev-parse HEAD
I0407 20:04:12.245] process 2161 exited with code 0 after 0.0m
I0407 20:04:12.246] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/jobResultsCache.json
I0407 20:04:14.408] process 2162 exited with code 0 after 0.0m
I0407 20:04:14.409] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/jobResultsCache.json#1586282763354488'
... skipping 8 lines ...