This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-04-07 14:01
Elapsed2m56s
Revision
Builder3558b77f-78d8-11ea-81ca-8e4c2b7d37f3
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/e6e2964b-f68d-4ba5-a70e-296fd64e9a69/targets/test'}}
resultstorehttps://source.cloud.google.com/results/invocations/e6e2964b-f68d-4ba5-a70e-296fd64e9a69/targets/test
infra-commit850fc2149
job-versionv1.19.0-alpha.1.390+a7f43a72032028
revisionv1.19.0-alpha.1.390+a7f43a72032028

Test Failures


Up 50s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.19.0-alpha.1.390+a7f43a72032028 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0407 14:01:35.821] process 50 exited with code 0 after 0.0m
I0407 14:01:35.821] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0407 14:01:35.821] Root: /workspace
I0407 14:01:35.821] cd to /workspace
I0407 14:01:35.821] Configure environment...
I0407 14:01:35.822] Call:  git show -s --format=format:%ct HEAD
W0407 14:01:35.826] fatal: not a git repository (or any of the parent directories): .git
I0407 14:01:35.826] process 64 exited with code 128 after 0.0m
W0407 14:01:35.826] Unable to print commit date for HEAD
I0407 14:01:35.827] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0407 14:01:36.467] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0407 14:01:36.828] process 65 exited with code 0 after 0.0m
I0407 14:01:36.828] Call:  gcloud config get-value account
... skipping 432 lines ...
W0407 14:04:20.192] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0407 14:04:20.192] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0407 14:04:20.193] WARNING: Starting with version 1.18, clusters will have shielded GKE nodes by default.
W0407 14:04:20.193] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0407 14:04:20.193] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0407 14:04:20.194] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0407 14:04:20.280] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0407 14:04:20.338] 2020/04/07 14:04:20 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.19.0-alpha.1.390+a7f43a72032028 bootstrap-e2e' finished in 653.656404ms
W0407 14:04:21.789] 2020/04/07 14:04:21 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0407 14:04:21.810] 2020/04/07 14:04:21 main.go:314: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.19.0-alpha.1.390+a7f43a72032028 bootstrap-e2e: exit status 1
W0407 14:04:21.816] Traceback (most recent call last):
W0407 14:04:21.816]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0407 14:04:21.816]     main(parse_args())
W0407 14:04:21.816]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0407 14:04:21.816]     mode.start(runner_args)
W0407 14:04:21.816]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0407 14:04:21.817]     check_env(env, self.command, *args)
W0407 14:04:21.817]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0407 14:04:21.817]     subprocess.check_call(cmd, env=env)
W0407 14:04:21.817]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0407 14:04:21.817]     raise CalledProcessError(retcode, cmd)
W0407 14:04:21.818] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0407 14:04:21.830] Command failed
I0407 14:04:21.831] process 275 exited with code 1 after 2.7m
E0407 14:04:21.831] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu
I0407 14:04:21.831] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0407 14:04:22.482] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0407 14:04:22.549] process 1462 exited with code 0 after 0.0m
I0407 14:04:22.549] Call:  gcloud config get-value account
I0407 14:04:23.098] process 1476 exited with code 0 after 0.0m
I0407 14:04:23.098] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0407 14:04:23.098] Upload result and artifacts...
I0407 14:04:23.099] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1247524865938821124
I0407 14:04:23.099] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1247524865938821124/artifacts
W0407 14:04:24.146] CommandException: One or more URLs matched no objects.
E0407 14:04:24.278] Command failed
I0407 14:04:24.279] process 1490 exited with code 1 after 0.0m
W0407 14:04:24.279] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1247524865938821124/artifacts not exist yet
I0407 14:04:24.279] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1247524865938821124/artifacts
I0407 14:04:26.133] process 1636 exited with code 0 after 0.0m
I0407 14:04:26.134] Call:  git rev-parse HEAD
W0407 14:04:26.138] fatal: not a git repository (or any of the parent directories): .git
E0407 14:04:26.139] Command failed
I0407 14:04:26.139] process 2164 exited with code 128 after 0.0m
I0407 14:04:26.139] Call:  git rev-parse HEAD
I0407 14:04:26.144] process 2165 exited with code 0 after 0.0m
I0407 14:04:26.144] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/jobResultsCache.json
I0407 14:04:27.338] process 2166 exited with code 0 after 0.0m
I0407 14:04:27.339] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/jobResultsCache.json#1586261106293340'
... skipping 8 lines ...