This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-04-07 10:01
Elapsed3m16s
Revision
Builderaf03d60a-78b6-11ea-81ca-8e4c2b7d37f3
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/6fcd0051-beeb-4999-ba98-65b9012941ba/targets/test'}}
resultstorehttps://source.cloud.google.com/results/invocations/6fcd0051-beeb-4999-ba98-65b9012941ba/targets/test
infra-commitb1bb4dbd1
job-versionv1.19.0-alpha.1.382+38f0a8bc74bed9
revisionv1.19.0-alpha.1.382+38f0a8bc74bed9

Test Failures


Up 44s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.19.0-alpha.1.382+38f0a8bc74bed9 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0407 10:01:39.026] process 50 exited with code 0 after 0.0m
I0407 10:01:39.026] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0407 10:01:39.026] Root: /workspace
I0407 10:01:39.026] cd to /workspace
I0407 10:01:39.027] Configure environment...
I0407 10:01:39.027] Call:  git show -s --format=format:%ct HEAD
W0407 10:01:39.031] fatal: not a git repository (or any of the parent directories): .git
I0407 10:01:39.032] process 64 exited with code 128 after 0.0m
W0407 10:01:39.032] Unable to print commit date for HEAD
I0407 10:01:39.032] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0407 10:01:39.644] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0407 10:01:39.998] process 65 exited with code 0 after 0.0m
I0407 10:01:39.998] Call:  gcloud config get-value account
... skipping 432 lines ...
W0407 10:04:43.727] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0407 10:04:43.728] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0407 10:04:43.728] WARNING: Starting with version 1.18, clusters will have shielded GKE nodes by default.
W0407 10:04:43.728] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0407 10:04:43.730] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0407 10:04:43.730] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0407 10:04:43.819] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0407 10:04:43.882] 2020/04/07 10:04:43 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.19.0-alpha.1.382+38f0a8bc74bed9 bootstrap-e2e' finished in 707.483615ms
W0407 10:04:45.215] 2020/04/07 10:04:45 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0407 10:04:45.222] 2020/04/07 10:04:45 main.go:314: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.19.0-alpha.1.382+38f0a8bc74bed9 bootstrap-e2e: exit status 1
W0407 10:04:45.226] Traceback (most recent call last):
W0407 10:04:45.227]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0407 10:04:45.227]     main(parse_args())
W0407 10:04:45.227]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0407 10:04:45.227]     mode.start(runner_args)
W0407 10:04:45.227]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0407 10:04:45.228]     check_env(env, self.command, *args)
W0407 10:04:45.228]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0407 10:04:45.228]     subprocess.check_call(cmd, env=env)
W0407 10:04:45.228]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0407 10:04:45.228]     raise CalledProcessError(retcode, cmd)
W0407 10:04:45.229] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0407 10:04:45.237] Command failed
I0407 10:04:45.237] process 275 exited with code 1 after 3.1m
E0407 10:04:45.238] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu
I0407 10:04:45.238] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0407 10:04:45.836] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0407 10:04:45.900] process 1463 exited with code 0 after 0.0m
I0407 10:04:45.900] Call:  gcloud config get-value account
I0407 10:04:46.418] process 1477 exited with code 0 after 0.0m
I0407 10:04:46.419] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0407 10:04:46.419] Upload result and artifacts...
I0407 10:04:46.419] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1247464467550179336
I0407 10:04:46.419] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1247464467550179336/artifacts
W0407 10:04:47.536] CommandException: One or more URLs matched no objects.
E0407 10:04:47.691] Command failed
I0407 10:04:47.691] process 1491 exited with code 1 after 0.0m
W0407 10:04:47.691] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1247464467550179336/artifacts not exist yet
I0407 10:04:47.691] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1247464467550179336/artifacts
I0407 10:04:49.498] process 1637 exited with code 0 after 0.0m
I0407 10:04:49.499] Call:  git rev-parse HEAD
W0407 10:04:49.503] fatal: not a git repository (or any of the parent directories): .git
E0407 10:04:49.504] Command failed
I0407 10:04:49.504] process 2165 exited with code 128 after 0.0m
I0407 10:04:49.504] Call:  git rev-parse HEAD
I0407 10:04:49.509] process 2166 exited with code 0 after 0.0m
I0407 10:04:49.509] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/jobResultsCache.json
I0407 10:04:50.704] process 2167 exited with code 0 after 0.0m
I0407 10:04:50.705] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/jobResultsCache.json#1586246762552446'
... skipping 8 lines ...