This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-02-18 20:01
Elapsed3m9s
Revision
Buildergke-prow-default-pool-cf4891d4-2j9c
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/b2472ef9-83df-4164-a661-f15b26feb9c2/targets/test'}}
pod4a2db5b5-5289-11ea-a3dd-429debf84329
resultstorehttps://source.cloud.google.com/results/invocations/b2472ef9-83df-4164-a661-f15b26feb9c2/targets/test
infra-commit9b0a0acee
job-versionv1.19.0-alpha.0.2+d5e0a941aa4d1c
pod4a2db5b5-5289-11ea-a3dd-429debf84329
revisionv1.19.0-alpha.0.2+d5e0a941aa4d1c

Test Failures


Up 56s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-04 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.19.0-alpha.0.2+d5e0a941aa4d1c bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0218 20:01:10.898] process 47 exited with code 0 after 0.0m
I0218 20:01:10.898] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0218 20:01:10.898] Root: /workspace
I0218 20:01:10.899] cd to /workspace
I0218 20:01:10.899] Configure environment...
I0218 20:01:10.899] Call:  git show -s --format=format:%ct HEAD
W0218 20:01:10.904] fatal: not a git repository (or any of the parent directories): .git
I0218 20:01:10.905] process 60 exited with code 128 after 0.0m
W0218 20:01:10.905] Unable to print commit date for HEAD
I0218 20:01:10.905] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0218 20:01:11.429] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0218 20:01:11.775] process 61 exited with code 0 after 0.0m
I0218 20:01:11.775] Call:  gcloud config get-value account
... skipping 437 lines ...
W0218 20:04:08.741] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0218 20:04:08.742] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0218 20:04:08.742] WARNING: Starting with version 1.18, clusters will have shielded GKE nodes by default.
W0218 20:04:08.742] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0218 20:04:08.743] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0218 20:04:08.743] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0218 20:04:08.839] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0218 20:04:08.897] 2020/02/18 20:04:08 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-04 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.19.0-alpha.0.2+d5e0a941aa4d1c bootstrap-e2e' finished in 684.650658ms
W0218 20:04:10.122] 2020/02/18 20:04:10 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0218 20:04:10.133] 2020/02/18 20:04:10 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-04 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.19.0-alpha.0.2+d5e0a941aa4d1c bootstrap-e2e: exit status 1
W0218 20:04:10.141] Traceback (most recent call last):
W0218 20:04:10.141]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0218 20:04:10.141]     main(parse_args())
W0218 20:04:10.141]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0218 20:04:10.141]     mode.start(runner_args)
W0218 20:04:10.142]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0218 20:04:10.142]     check_env(env, self.command, *args)
W0218 20:04:10.142]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0218 20:04:10.142]     subprocess.check_call(cmd, env=env)
W0218 20:04:10.142]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0218 20:04:10.142]     raise CalledProcessError(retcode, cmd)
W0218 20:04:10.143] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0218 20:04:10.154] Command failed
I0218 20:04:10.154] process 268 exited with code 1 after 2.9m
E0218 20:04:10.154] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu
I0218 20:04:10.155] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0218 20:04:10.682] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0218 20:04:10.758] process 1415 exited with code 0 after 0.0m
I0218 20:04:10.758] Call:  gcloud config get-value account
I0218 20:04:11.182] process 1428 exited with code 0 after 0.0m
I0218 20:04:11.182] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0218 20:04:11.182] Upload result and artifacts...
I0218 20:04:11.182] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1229858346224324611
I0218 20:04:11.183] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1229858346224324611/artifacts
W0218 20:04:12.263] CommandException: One or more URLs matched no objects.
E0218 20:04:12.404] Command failed
I0218 20:04:12.404] process 1441 exited with code 1 after 0.0m
W0218 20:04:12.404] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1229858346224324611/artifacts not exist yet
I0218 20:04:12.405] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1229858346224324611/artifacts
I0218 20:04:14.324] process 1586 exited with code 0 after 0.0m
I0218 20:04:14.324] Call:  git rev-parse HEAD
W0218 20:04:14.328] fatal: not a git repository (or any of the parent directories): .git
E0218 20:04:14.329] Command failed
I0218 20:04:14.329] process 2113 exited with code 128 after 0.0m
I0218 20:04:14.329] Call:  git rev-parse HEAD
I0218 20:04:14.334] process 2114 exited with code 0 after 0.0m
I0218 20:04:14.334] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/jobResultsCache.json
I0218 20:04:15.605] process 2115 exited with code 0 after 0.0m
I0218 20:04:15.606] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/jobResultsCache.json#1582049149877891'
... skipping 8 lines ...