This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-02-17 20:01
Elapsed2m54s
Revision
Buildergke-prow-default-pool-cf4891d4-fwhg
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/1aabd493-4f2c-4c70-82fe-3b6aec392969/targets/test'}}
pod3059e0b5-51c0-11ea-9bea-16a0f55e352c
resultstorehttps://source.cloud.google.com/results/invocations/1aabd493-4f2c-4c70-82fe-3b6aec392969/targets/test
infra-commit8ab6e0b2c
job-versionv1.18.0-alpha.5.174+ea5cef1c65b589
pod3059e0b5-51c0-11ea-9bea-16a0f55e352c
revisionv1.18.0-alpha.5.174+ea5cef1c65b589

Test Failures


Up 40s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.5.174+ea5cef1c65b589 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0217 20:01:42.522] process 47 exited with code 0 after 0.0m
I0217 20:01:42.523] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0217 20:01:42.524] Root: /workspace
I0217 20:01:42.524] cd to /workspace
I0217 20:01:42.524] Configure environment...
I0217 20:01:42.525] Call:  git show -s --format=format:%ct HEAD
W0217 20:01:42.530] fatal: not a git repository (or any of the parent directories): .git
I0217 20:01:42.530] process 60 exited with code 128 after 0.0m
W0217 20:01:42.531] Unable to print commit date for HEAD
I0217 20:01:42.531] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0217 20:01:43.072] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0217 20:01:43.412] process 61 exited with code 0 after 0.0m
I0217 20:01:43.413] Call:  gcloud config get-value account
... skipping 437 lines ...
W0217 20:04:24.818] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0217 20:04:24.819] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0217 20:04:24.819] WARNING: Starting with version 1.18, clusters will have shielded GKE nodes by default.
W0217 20:04:24.819] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0217 20:04:24.819] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0217 20:04:24.820] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0217 20:04:24.895] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0217 20:04:24.958] 2020/02/17 20:04:24 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.5.174+ea5cef1c65b589 bootstrap-e2e' finished in 721.506422ms
W0217 20:04:26.433] 2020/02/17 20:04:26 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0217 20:04:26.440] 2020/02/17 20:04:26 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.5.174+ea5cef1c65b589 bootstrap-e2e: exit status 1
W0217 20:04:26.447] Traceback (most recent call last):
W0217 20:04:26.448]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0217 20:04:26.448]     main(parse_args())
W0217 20:04:26.448]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0217 20:04:26.448]     mode.start(runner_args)
W0217 20:04:26.448]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0217 20:04:26.448]     check_env(env, self.command, *args)
W0217 20:04:26.449]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0217 20:04:26.449]     subprocess.check_call(cmd, env=env)
W0217 20:04:26.449]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0217 20:04:26.449]     raise CalledProcessError(retcode, cmd)
W0217 20:04:26.450] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0217 20:04:26.461] Command failed
I0217 20:04:26.461] process 268 exited with code 1 after 2.7m
E0217 20:04:26.461] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu
I0217 20:04:26.462] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0217 20:04:27.106] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0217 20:04:27.180] process 1415 exited with code 0 after 0.0m
I0217 20:04:27.181] Call:  gcloud config get-value account
I0217 20:04:27.710] process 1428 exited with code 0 after 0.0m
I0217 20:04:27.710] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0217 20:04:27.710] Upload result and artifacts...
I0217 20:04:27.710] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1229496098180042752
I0217 20:04:27.711] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1229496098180042752/artifacts
W0217 20:04:28.988] CommandException: One or more URLs matched no objects.
E0217 20:04:29.155] Command failed
I0217 20:04:29.155] process 1441 exited with code 1 after 0.0m
W0217 20:04:29.155] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1229496098180042752/artifacts not exist yet
I0217 20:04:29.155] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1229496098180042752/artifacts
I0217 20:04:31.240] process 1586 exited with code 0 after 0.0m
I0217 20:04:31.241] Call:  git rev-parse HEAD
W0217 20:04:31.248] fatal: not a git repository (or any of the parent directories): .git
E0217 20:04:31.248] Command failed
I0217 20:04:31.248] process 2113 exited with code 128 after 0.0m
I0217 20:04:31.249] Call:  git rev-parse HEAD
I0217 20:04:31.258] process 2114 exited with code 0 after 0.0m
I0217 20:04:31.259] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/jobResultsCache.json
I0217 20:04:32.555] process 2115 exited with code 0 after 0.0m
I0217 20:04:32.557] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/jobResultsCache.json#1581962792798691'
... skipping 8 lines ...