This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-02-17 10:01
Elapsed2m35s
Revision
Buildergke-prow-default-pool-cf4891d4-6stf
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/189cb1ac-f766-4a01-a83f-9cc9a4356bc1/targets/test'}}
pod5db5f63b-516c-11ea-9bea-16a0f55e352c
resultstorehttps://source.cloud.google.com/results/invocations/189cb1ac-f766-4a01-a83f-9cc9a4356bc1/targets/test
infra-commit51ad7a656
job-versionv1.18.0-alpha.5.170+3ed0f1bec132e0
pod5db5f63b-516c-11ea-9bea-16a0f55e352c
revisionv1.18.0-alpha.5.170+3ed0f1bec132e0

Test Failures


Up 39s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus-1-7 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.5.170+3ed0f1bec132e0 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0217 10:01:41.190] process 47 exited with code 0 after 0.0m
I0217 10:01:41.191] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0217 10:01:41.191] Root: /workspace
I0217 10:01:41.191] cd to /workspace
I0217 10:01:41.191] Configure environment...
I0217 10:01:41.192] Call:  git show -s --format=format:%ct HEAD
W0217 10:01:41.195] fatal: not a git repository (or any of the parent directories): .git
I0217 10:01:41.196] process 60 exited with code 128 after 0.0m
W0217 10:01:41.196] Unable to print commit date for HEAD
I0217 10:01:41.196] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0217 10:01:41.675] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0217 10:01:42.017] process 61 exited with code 0 after 0.0m
I0217 10:01:42.017] Call:  gcloud config get-value account
... skipping 433 lines ...
W0217 10:04:06.748] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0217 10:04:06.749] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0217 10:04:06.749] WARNING: Starting with version 1.18, clusters will have shielded GKE nodes by default.
W0217 10:04:06.749] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0217 10:04:06.749] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0217 10:04:06.750] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0217 10:04:06.826] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0217 10:04:06.872] 2020/02/17 10:04:06 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus-1-7 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.5.170+3ed0f1bec132e0 bootstrap-e2e' finished in 569.970265ms
W0217 10:04:07.934] 2020/02/17 10:04:07 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0217 10:04:07.942] 2020/02/17 10:04:07 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus-1-7 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.5.170+3ed0f1bec132e0 bootstrap-e2e: exit status 1
W0217 10:04:07.945] Traceback (most recent call last):
W0217 10:04:07.946]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0217 10:04:07.946]     main(parse_args())
W0217 10:04:07.946]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0217 10:04:07.946]     mode.start(runner_args)
W0217 10:04:07.946]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0217 10:04:07.946]     check_env(env, self.command, *args)
W0217 10:04:07.946]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0217 10:04:07.947]     subprocess.check_call(cmd, env=env)
W0217 10:04:07.947]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0217 10:04:07.947]     raise CalledProcessError(retcode, cmd)
W0217 10:04:07.948] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0217 10:04:07.955] Command failed
I0217 10:04:07.956] process 268 exited with code 1 after 2.4m
E0217 10:04:07.956] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu
I0217 10:04:07.956] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0217 10:04:08.411] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0217 10:04:08.458] process 1404 exited with code 0 after 0.0m
I0217 10:04:08.458] Call:  gcloud config get-value account
I0217 10:04:08.835] process 1417 exited with code 0 after 0.0m
I0217 10:04:08.835] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0217 10:04:08.836] Upload result and artifacts...
I0217 10:04:08.836] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1229345091311636482
I0217 10:04:08.836] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1229345091311636482/artifacts
W0217 10:04:09.778] CommandException: One or more URLs matched no objects.
E0217 10:04:09.892] Command failed
I0217 10:04:09.893] process 1430 exited with code 1 after 0.0m
W0217 10:04:09.893] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1229345091311636482/artifacts not exist yet
I0217 10:04:09.893] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1229345091311636482/artifacts
I0217 10:04:11.550] process 1575 exited with code 0 after 0.0m
I0217 10:04:11.551] Call:  git rev-parse HEAD
W0217 10:04:11.554] fatal: not a git repository (or any of the parent directories): .git
E0217 10:04:11.554] Command failed
I0217 10:04:11.555] process 2102 exited with code 128 after 0.0m
I0217 10:04:11.555] Call:  git rev-parse HEAD
I0217 10:04:11.558] process 2103 exited with code 0 after 0.0m
I0217 10:04:11.559] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/jobResultsCache.json
I0217 10:04:12.561] process 2104 exited with code 0 after 0.0m
I0217 10:04:12.561] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/jobResultsCache.json#1581926761677883'
... skipping 8 lines ...