This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-02-17 04:01
Elapsed3m16s
Revision
Buildergke-prow-default-pool-cf4891d4-f13q
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/298086fb-0a86-4459-b774-59d288d72c5a/targets/test'}}
pod13026d75-513a-11ea-9bea-16a0f55e352c
resultstorehttps://source.cloud.google.com/results/invocations/298086fb-0a86-4459-b774-59d288d72c5a/targets/test
infra-commitf5dd3ee0e
job-versionv1.18.0-alpha.5.168+48def7e7c32ac6
pod13026d75-513a-11ea-9bea-16a0f55e352c
revisionv1.18.0-alpha.5.168+48def7e7c32ac6

Test Failures


Up 41s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.5.168+48def7e7c32ac6 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0217 04:01:42.534] process 47 exited with code 0 after 0.0m
I0217 04:01:42.534] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0217 04:01:42.534] Root: /workspace
I0217 04:01:42.535] cd to /workspace
I0217 04:01:42.535] Configure environment...
I0217 04:01:42.535] Call:  git show -s --format=format:%ct HEAD
W0217 04:01:42.541] fatal: not a git repository (or any of the parent directories): .git
I0217 04:01:42.541] process 60 exited with code 128 after 0.0m
W0217 04:01:42.542] Unable to print commit date for HEAD
I0217 04:01:42.542] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0217 04:01:43.127] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0217 04:01:43.462] process 61 exited with code 0 after 0.0m
I0217 04:01:43.463] Call:  gcloud config get-value account
... skipping 437 lines ...
W0217 04:04:40.703] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0217 04:04:40.704] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0217 04:04:40.705] WARNING: Starting with version 1.18, clusters will have shielded GKE nodes by default.
W0217 04:04:40.705] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0217 04:04:40.706] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0217 04:04:40.706] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0217 04:04:40.861] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0217 04:04:40.935] 2020/02/17 04:04:40 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.5.168+48def7e7c32ac6 bootstrap-e2e' finished in 1.061945526s
W0217 04:04:42.967] 2020/02/17 04:04:42 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0217 04:04:42.975] 2020/02/17 04:04:42 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.5.168+48def7e7c32ac6 bootstrap-e2e: exit status 1
W0217 04:04:42.986] Traceback (most recent call last):
W0217 04:04:42.987]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0217 04:04:42.987]     main(parse_args())
W0217 04:04:42.987]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0217 04:04:42.987]     mode.start(runner_args)
W0217 04:04:42.988]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0217 04:04:42.988]     check_env(env, self.command, *args)
W0217 04:04:42.988]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0217 04:04:42.988]     subprocess.check_call(cmd, env=env)
W0217 04:04:42.988]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0217 04:04:42.988]     raise CalledProcessError(retcode, cmd)
W0217 04:04:42.989] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0217 04:04:43.005] Command failed
I0217 04:04:43.006] process 268 exited with code 1 after 3.0m
E0217 04:04:43.006] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu
I0217 04:04:43.007] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0217 04:04:43.984] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0217 04:04:44.063] process 1412 exited with code 0 after 0.0m
I0217 04:04:44.064] Call:  gcloud config get-value account
I0217 04:04:44.779] process 1425 exited with code 0 after 0.0m
I0217 04:04:44.779] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0217 04:04:44.779] Upload result and artifacts...
I0217 04:04:44.779] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1229254494957604865
I0217 04:04:44.780] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1229254494957604865/artifacts
W0217 04:04:46.526] CommandException: One or more URLs matched no objects.
E0217 04:04:46.772] Command failed
I0217 04:04:46.773] process 1438 exited with code 1 after 0.0m
W0217 04:04:46.773] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1229254494957604865/artifacts not exist yet
I0217 04:04:46.773] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1229254494957604865/artifacts
I0217 04:04:49.925] process 1583 exited with code 0 after 0.1m
I0217 04:04:49.926] Call:  git rev-parse HEAD
W0217 04:04:49.933] fatal: not a git repository (or any of the parent directories): .git
E0217 04:04:49.933] Command failed
I0217 04:04:49.933] process 2110 exited with code 128 after 0.0m
I0217 04:04:49.934] Call:  git rev-parse HEAD
I0217 04:04:49.945] process 2111 exited with code 0 after 0.0m
I0217 04:04:49.945] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/jobResultsCache.json
I0217 04:04:52.142] process 2112 exited with code 0 after 0.0m
I0217 04:04:52.143] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/jobResultsCache.json#1581905146330199'
... skipping 8 lines ...