This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-02-16 18:01
Elapsed2m55s
Revision
Buildergke-prow-default-pool-cf4891d4-gjgt
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/15f51120-eb69-4e5d-ad49-7887c6a97919/targets/test'}}
pod4150eae2-50e6-11ea-9bea-16a0f55e352c
resultstorehttps://source.cloud.google.com/results/invocations/15f51120-eb69-4e5d-ad49-7887c6a97919/targets/test
infra-commitf5dd3ee0e
job-versionv1.18.0-alpha.5.164+8b2f08f39d4221
pod4150eae2-50e6-11ea-9bea-16a0f55e352c
revisionv1.18.0-alpha.5.164+8b2f08f39d4221

Test Failures


Up 51s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.5.164+8b2f08f39d4221 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0216 18:01:40.994] process 47 exited with code 0 after 0.0m
I0216 18:01:40.995] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0216 18:01:40.995] Root: /workspace
I0216 18:01:40.995] cd to /workspace
I0216 18:01:40.995] Configure environment...
I0216 18:01:40.995] Call:  git show -s --format=format:%ct HEAD
W0216 18:01:41.000] fatal: not a git repository (or any of the parent directories): .git
I0216 18:01:41.001] process 60 exited with code 128 after 0.0m
W0216 18:01:41.001] Unable to print commit date for HEAD
I0216 18:01:41.001] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0216 18:01:41.604] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0216 18:01:41.756] process 61 exited with code 0 after 0.0m
I0216 18:01:41.756] Call:  gcloud config get-value account
... skipping 433 lines ...
W0216 18:04:23.297] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0216 18:04:23.297] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0216 18:04:23.297] WARNING: Starting with version 1.18, clusters will have shielded GKE nodes by default.
W0216 18:04:23.298] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0216 18:04:23.298] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0216 18:04:23.298] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0216 18:04:23.430] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0216 18:04:23.502] 2020/02/16 18:04:23 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.5.164+8b2f08f39d4221 bootstrap-e2e' finished in 837.269092ms
W0216 18:04:24.922] 2020/02/16 18:04:24 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0216 18:04:24.931] 2020/02/16 18:04:24 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.5.164+8b2f08f39d4221 bootstrap-e2e: exit status 1
W0216 18:04:24.939] Traceback (most recent call last):
W0216 18:04:24.939]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0216 18:04:24.940]     main(parse_args())
W0216 18:04:24.940]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0216 18:04:24.940]     mode.start(runner_args)
W0216 18:04:24.940]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0216 18:04:24.941]     check_env(env, self.command, *args)
W0216 18:04:24.941]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0216 18:04:24.941]     subprocess.check_call(cmd, env=env)
W0216 18:04:24.941]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0216 18:04:24.941]     raise CalledProcessError(retcode, cmd)
W0216 18:04:24.942] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0216 18:04:24.956] Command failed
I0216 18:04:24.956] process 268 exited with code 1 after 2.7m
E0216 18:04:24.956] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu
I0216 18:04:24.957] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0216 18:04:25.626] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0216 18:04:25.685] process 1403 exited with code 0 after 0.0m
I0216 18:04:25.685] Call:  gcloud config get-value account
I0216 18:04:26.146] process 1416 exited with code 0 after 0.0m
I0216 18:04:26.146] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0216 18:04:26.146] Upload result and artifacts...
I0216 18:04:26.147] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1229103500038770690
I0216 18:04:26.147] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1229103500038770690/artifacts
W0216 18:04:27.273] CommandException: One or more URLs matched no objects.
E0216 18:04:27.427] Command failed
I0216 18:04:27.428] process 1429 exited with code 1 after 0.0m
W0216 18:04:27.428] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1229103500038770690/artifacts not exist yet
I0216 18:04:27.428] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1229103500038770690/artifacts
I0216 18:04:29.587] process 1574 exited with code 0 after 0.0m
I0216 18:04:29.588] Call:  git rev-parse HEAD
W0216 18:04:29.593] fatal: not a git repository (or any of the parent directories): .git
E0216 18:04:29.593] Command failed
I0216 18:04:29.593] process 2101 exited with code 128 after 0.0m
I0216 18:04:29.594] Call:  git rev-parse HEAD
I0216 18:04:29.600] process 2102 exited with code 0 after 0.0m
I0216 18:04:29.601] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/jobResultsCache.json
I0216 18:04:31.001] process 2103 exited with code 0 after 0.0m
I0216 18:04:31.002] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/jobResultsCache.json#1581869050193433'
... skipping 8 lines ...