This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-02-16 04:01
Elapsed2m59s
Revision
Buildergke-prow-default-pool-cf4891d4-t4sm
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/98f58d09-cb64-410d-9690-71c92e4691cf/targets/test'}}
pode95e4aea-5070-11ea-9bea-16a0f55e352c
resultstorehttps://source.cloud.google.com/results/invocations/98f58d09-cb64-410d-9690-71c92e4691cf/targets/test
infra-commitf5dd3ee0e
job-versionv1.18.0-alpha.5.160+3b22fcc7bdcf5c
pode95e4aea-5070-11ea-9bea-16a0f55e352c
revisionv1.18.0-alpha.5.160+3b22fcc7bdcf5c

Test Failures


Up 1m1s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-04 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.5.160+3b22fcc7bdcf5c bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0216 04:01:40.472] process 47 exited with code 0 after 0.0m
I0216 04:01:40.473] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0216 04:01:40.473] Root: /workspace
I0216 04:01:40.473] cd to /workspace
I0216 04:01:40.473] Configure environment...
I0216 04:01:40.474] Call:  git show -s --format=format:%ct HEAD
W0216 04:01:40.478] fatal: not a git repository (or any of the parent directories): .git
I0216 04:01:40.478] process 60 exited with code 128 after 0.0m
W0216 04:01:40.479] Unable to print commit date for HEAD
I0216 04:01:40.479] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0216 04:01:41.081] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0216 04:01:41.443] process 61 exited with code 0 after 0.0m
I0216 04:01:41.444] Call:  gcloud config get-value account
... skipping 437 lines ...
W0216 04:04:29.436] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0216 04:04:29.436] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0216 04:04:29.437] WARNING: Starting with version 1.18, clusters will have shielded GKE nodes by default.
W0216 04:04:29.437] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0216 04:04:29.437] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0216 04:04:29.438] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0216 04:04:29.527] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0216 04:04:29.579] 2020/02/16 04:04:29 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-04 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.5.160+3b22fcc7bdcf5c bootstrap-e2e' finished in 675.058171ms
W0216 04:04:30.760] 2020/02/16 04:04:30 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0216 04:04:30.769] 2020/02/16 04:04:30 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-04 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.5.160+3b22fcc7bdcf5c bootstrap-e2e: exit status 1
W0216 04:04:30.772] Traceback (most recent call last):
W0216 04:04:30.773]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0216 04:04:30.773]     main(parse_args())
W0216 04:04:30.773]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0216 04:04:30.773]     mode.start(runner_args)
W0216 04:04:30.774]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0216 04:04:30.774]     check_env(env, self.command, *args)
W0216 04:04:30.774]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0216 04:04:30.774]     subprocess.check_call(cmd, env=env)
W0216 04:04:30.774]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0216 04:04:30.774]     raise CalledProcessError(retcode, cmd)
W0216 04:04:30.775] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0216 04:04:30.783] Command failed
I0216 04:04:30.783] process 268 exited with code 1 after 2.8m
E0216 04:04:30.783] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu
I0216 04:04:30.784] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0216 04:04:31.294] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0216 04:04:31.350] process 1416 exited with code 0 after 0.0m
I0216 04:04:31.350] Call:  gcloud config get-value account
I0216 04:04:31.794] process 1429 exited with code 0 after 0.0m
I0216 04:04:31.795] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0216 04:04:31.795] Upload result and artifacts...
I0216 04:04:31.795] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1228892112544600066
I0216 04:04:31.795] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1228892112544600066/artifacts
W0216 04:04:32.817] CommandException: One or more URLs matched no objects.
E0216 04:04:32.954] Command failed
I0216 04:04:32.955] process 1442 exited with code 1 after 0.0m
W0216 04:04:32.955] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1228892112544600066/artifacts not exist yet
I0216 04:04:32.955] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/1228892112544600066/artifacts
I0216 04:04:34.800] process 1587 exited with code 0 after 0.0m
I0216 04:04:34.800] Call:  git rev-parse HEAD
W0216 04:04:34.804] fatal: not a git repository (or any of the parent directories): .git
E0216 04:04:34.805] Command failed
I0216 04:04:34.805] process 2114 exited with code 128 after 0.0m
I0216 04:04:34.805] Call:  git rev-parse HEAD
I0216 04:04:34.809] process 2115 exited with code 0 after 0.0m
I0216 04:04:34.810] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/jobResultsCache.json
I0216 04:04:35.989] process 2116 exited with code 0 after 0.0m
I0216 04:04:35.990] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu/jobResultsCache.json#1581818740111623'
... skipping 8 lines ...