This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-21 18:01
Elapsed2m31s
Revision
Buildergke-prow-ssd-pool-1a225945-49gz
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/3282a857-546b-4aa9-995c-8e317e855913/targets/test'}}
podc849dd4e-0c88-11ea-b26a-065b5133c63f
resultstorehttps://source.cloud.google.com/results/invocations/3282a857-546b-4aa9-995c-8e317e855913/targets/test
infra-commit2bc76599f
job-versionv1.15.7-beta.0.1+54260e2be0c03f
podc849dd4e-0c88-11ea-b26a-065b5133c63f
revisionv1.15.7-beta.0.1+54260e2be0c03f

Test Failures


Up 42s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1121 18:01:03.129] process 47 exited with code 0 after 0.0m
I1121 18:01:03.129] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1121 18:01:03.129] Root: /workspace
I1121 18:01:03.130] cd to /workspace
I1121 18:01:03.130] Configure environment...
I1121 18:01:03.130] Call:  git show -s --format=format:%ct HEAD
W1121 18:01:03.135] fatal: not a git repository (or any of the parent directories): .git
I1121 18:01:03.136] process 60 exited with code 128 after 0.0m
W1121 18:01:03.136] Unable to print commit date for HEAD
I1121 18:01:03.137] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1121 18:01:03.731] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1121 18:01:03.912] process 61 exited with code 0 after 0.0m
I1121 18:01:03.912] Call:  gcloud config get-value account
... skipping 425 lines ...
W1121 18:03:15.178] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1121 18:03:15.178] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1121 18:03:15.179] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1121 18:03:15.180] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1121 18:03:15.180] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1121 18:03:15.181] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1121 18:03:16.801] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Node version "1.15.7-beta.0.1+54260e2be0c03f" is unsupported.
W1121 18:03:16.875] 2019/11/21 18:03:16 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e' finished in 2.200336183s
W1121 18:03:18.630] 2019/11/21 18:03:18 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1121 18:03:22.487] 2019/11/21 18:03:22 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e: exit status 1
W1121 18:03:22.495] Traceback (most recent call last):
W1121 18:03:22.496]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1121 18:03:22.496]     main(parse_args())
W1121 18:03:22.496]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1121 18:03:22.497]     mode.start(runner_args)
W1121 18:03:22.497]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1121 18:03:22.497]     check_env(env, self.command, *args)
W1121 18:03:22.497]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1121 18:03:22.497]     subprocess.check_call(cmd, env=env)
W1121 18:03:22.498]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1121 18:03:22.498]     raise CalledProcessError(retcode, cmd)
W1121 18:03:22.499] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1121 18:03:22.507] Command failed
I1121 18:03:22.507] process 268 exited with code 1 after 2.3m
E1121 18:03:22.507] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1121 18:03:22.508] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1121 18:03:23.101] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1121 18:03:23.173] process 1433 exited with code 0 after 0.0m
I1121 18:03:23.174] Call:  gcloud config get-value account
I1121 18:03:23.578] process 1446 exited with code 0 after 0.0m
I1121 18:03:23.578] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1121 18:03:23.578] Upload result and artifacts...
I1121 18:03:23.579] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1197575598692634630
I1121 18:03:23.579] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1197575598692634630/artifacts
W1121 18:03:24.647] CommandException: One or more URLs matched no objects.
E1121 18:03:24.802] Command failed
I1121 18:03:24.803] process 1459 exited with code 1 after 0.0m
W1121 18:03:24.804] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1197575598692634630/artifacts not exist yet
I1121 18:03:24.804] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1197575598692634630/artifacts
I1121 18:03:26.585] process 1604 exited with code 0 after 0.0m
I1121 18:03:26.586] Call:  git rev-parse HEAD
W1121 18:03:26.591] fatal: not a git repository (or any of the parent directories): .git
E1121 18:03:26.592] Command failed
I1121 18:03:26.592] process 2131 exited with code 128 after 0.0m
I1121 18:03:26.593] Call:  git rev-parse HEAD
I1121 18:03:26.598] process 2132 exited with code 0 after 0.0m
I1121 18:03:26.599] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1121 18:03:27.879] process 2133 exited with code 0 after 0.0m
I1121 18:03:27.880] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1574316209459098'
... skipping 8 lines ...