This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-20 18:01
Elapsed3m30s
Revision
Buildergke-prow-ssd-pool-1a225945-w688
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/67f653a6-00b9-439e-9d55-194df05b0bb5/targets/test'}}
podb58a39f1-0bbf-11ea-b5e9-3289c6e090ac
resultstorehttps://source.cloud.google.com/results/invocations/67f653a6-00b9-439e-9d55-194df05b0bb5/targets/test
infra-commitb1692ff83
job-versionv1.15.7-beta.0.1+54260e2be0c03f
podb58a39f1-0bbf-11ea-b5e9-3289c6e090ac
revisionv1.15.7-beta.0.1+54260e2be0c03f

Test Failures


Up 1m9s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1120 18:01:33.066] process 47 exited with code 0 after 0.0m
I1120 18:01:33.067] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1120 18:01:33.067] Root: /workspace
I1120 18:01:33.067] cd to /workspace
I1120 18:01:33.067] Configure environment...
I1120 18:01:33.068] Call:  git show -s --format=format:%ct HEAD
W1120 18:01:33.073] fatal: not a git repository (or any of the parent directories): .git
I1120 18:01:33.074] process 60 exited with code 128 after 0.0m
W1120 18:01:33.074] Unable to print commit date for HEAD
I1120 18:01:33.075] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1120 18:01:33.682] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1120 18:01:34.037] process 61 exited with code 0 after 0.0m
I1120 18:01:34.037] Call:  gcloud config get-value account
... skipping 425 lines ...
W1120 18:04:42.802] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1120 18:04:42.803] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1120 18:04:42.804] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1120 18:04:42.804] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1120 18:04:42.805] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1120 18:04:42.806] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1120 18:04:45.630] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Node version "1.15.7-beta.0.1+54260e2be0c03f" is unsupported.
W1120 18:04:45.702] 2019/11/20 18:04:45 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e' finished in 3.424083181s
W1120 18:04:47.556] 2019/11/20 18:04:47 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1120 18:04:53.236] 2019/11/20 18:04:53 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e: exit status 1
W1120 18:04:53.241] Traceback (most recent call last):
W1120 18:04:53.242]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1120 18:04:53.242]     main(parse_args())
W1120 18:04:53.242]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1120 18:04:53.242]     mode.start(runner_args)
W1120 18:04:53.242]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1120 18:04:53.242]     check_env(env, self.command, *args)
W1120 18:04:53.243]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1120 18:04:53.243]     subprocess.check_call(cmd, env=env)
W1120 18:04:53.243]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1120 18:04:53.243]     raise CalledProcessError(retcode, cmd)
W1120 18:04:53.243] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1120 18:04:53.250] Command failed
I1120 18:04:53.251] process 268 exited with code 1 after 3.3m
E1120 18:04:53.251] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1120 18:04:53.252] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1120 18:04:53.840] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1120 18:04:53.911] process 1431 exited with code 0 after 0.0m
I1120 18:04:53.912] Call:  gcloud config get-value account
I1120 18:04:54.324] process 1444 exited with code 0 after 0.0m
I1120 18:04:54.325] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1120 18:04:54.325] Upload result and artifacts...
I1120 18:04:54.325] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1197213312211750918
I1120 18:04:54.326] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1197213312211750918/artifacts
W1120 18:04:55.327] CommandException: One or more URLs matched no objects.
E1120 18:04:55.465] Command failed
I1120 18:04:55.466] process 1457 exited with code 1 after 0.0m
W1120 18:04:55.466] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1197213312211750918/artifacts not exist yet
I1120 18:04:55.466] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1197213312211750918/artifacts
I1120 18:04:57.329] process 1602 exited with code 0 after 0.0m
I1120 18:04:57.330] Call:  git rev-parse HEAD
W1120 18:04:57.335] fatal: not a git repository (or any of the parent directories): .git
E1120 18:04:57.336] Command failed
I1120 18:04:57.336] process 2129 exited with code 128 after 0.0m
I1120 18:04:57.336] Call:  git rev-parse HEAD
I1120 18:04:57.342] process 2130 exited with code 0 after 0.0m
I1120 18:04:57.342] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1120 18:04:58.474] process 2131 exited with code 0 after 0.0m
I1120 18:04:58.475] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1574229864802095'
... skipping 8 lines ...