This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-19 18:01
Elapsed3m31s
Revision
Buildergke-prow-ssd-pool-1a225945-n4mt
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/330b95a8-5cd9-4df3-b46a-03c91252593b/targets/test'}}
pod7d6642dd-0af6-11ea-be88-5a2ed842773b
resultstorehttps://source.cloud.google.com/results/invocations/330b95a8-5cd9-4df3-b46a-03c91252593b/targets/test
infra-commit00c5af8fa
job-versionv1.15.7-beta.0.1+54260e2be0c03f
pod7d6642dd-0af6-11ea-be88-5a2ed842773b
revisionv1.15.7-beta.0.1+54260e2be0c03f

Test Failures


Up 1m33s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1119 18:01:37.239] process 47 exited with code 0 after 0.0m
I1119 18:01:37.240] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1119 18:01:37.240] Root: /workspace
I1119 18:01:37.240] cd to /workspace
I1119 18:01:37.240] Configure environment...
I1119 18:01:37.241] Call:  git show -s --format=format:%ct HEAD
W1119 18:01:37.246] fatal: not a git repository (or any of the parent directories): .git
I1119 18:01:37.246] process 60 exited with code 128 after 0.0m
W1119 18:01:37.247] Unable to print commit date for HEAD
I1119 18:01:37.247] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1119 18:01:37.794] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1119 18:01:38.171] process 61 exited with code 0 after 0.0m
I1119 18:01:38.171] Call:  gcloud config get-value account
... skipping 425 lines ...
W1119 18:03:58.046] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1119 18:03:58.046] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1119 18:03:58.047] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1119 18:03:58.047] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1119 18:03:58.048] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1119 18:03:58.048] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1119 18:04:45.449] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1119 18:04:45.521] 2019/11/19 18:04:45 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e' finished in 47.961495402s
W1119 18:04:47.328] 2019/11/19 18:04:47 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1119 18:04:59.288] 2019/11/19 18:04:59 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e: exit status 1
W1119 18:04:59.292] Traceback (most recent call last):
W1119 18:04:59.292]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1119 18:04:59.293]     main(parse_args())
W1119 18:04:59.293]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1119 18:04:59.293]     mode.start(runner_args)
W1119 18:04:59.294]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1119 18:04:59.294]     check_env(env, self.command, *args)
W1119 18:04:59.295]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1119 18:04:59.296]     subprocess.check_call(cmd, env=env)
W1119 18:04:59.296]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1119 18:04:59.296]     raise CalledProcessError(retcode, cmd)
W1119 18:04:59.297] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1119 18:04:59.307] Command failed
I1119 18:04:59.308] process 268 exited with code 1 after 3.3m
E1119 18:04:59.308] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1119 18:04:59.308] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1119 18:04:59.877] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1119 18:04:59.961] process 1430 exited with code 0 after 0.0m
I1119 18:04:59.962] Call:  gcloud config get-value account
I1119 18:05:00.348] process 1443 exited with code 0 after 0.0m
I1119 18:05:00.349] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1119 18:05:00.349] Upload result and artifacts...
I1119 18:05:00.349] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1196850826883108867
I1119 18:05:00.350] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1196850826883108867/artifacts
W1119 18:05:01.356] CommandException: One or more URLs matched no objects.
E1119 18:05:01.504] Command failed
I1119 18:05:01.504] process 1456 exited with code 1 after 0.0m
W1119 18:05:01.504] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1196850826883108867/artifacts not exist yet
I1119 18:05:01.505] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1196850826883108867/artifacts
I1119 18:05:03.395] process 1601 exited with code 0 after 0.0m
I1119 18:05:03.396] Call:  git rev-parse HEAD
W1119 18:05:03.400] fatal: not a git repository (or any of the parent directories): .git
E1119 18:05:03.401] Command failed
I1119 18:05:03.401] process 2128 exited with code 128 after 0.0m
I1119 18:05:03.401] Call:  git rev-parse HEAD
I1119 18:05:03.405] process 2129 exited with code 0 after 0.0m
I1119 18:05:03.406] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1119 18:05:04.487] process 2130 exited with code 0 after 0.0m
I1119 18:05:04.489] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1574143438869302'
... skipping 8 lines ...