This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-19 06:01
Elapsed2m59s
Revision
Buildergke-prow-ssd-pool-1a225945-9x2b
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/9b8fe55c-58bf-4074-8c73-4b0bf0cae588/targets/test'}}
pode787e16a-0a91-11ea-be88-5a2ed842773b
resultstorehttps://source.cloud.google.com/results/invocations/9b8fe55c-58bf-4074-8c73-4b0bf0cae588/targets/test
infra-commitc63b86354
job-versionv1.15.7-beta.0.1+54260e2be0c03f
pode787e16a-0a91-11ea-be88-5a2ed842773b
revisionv1.15.7-beta.0.1+54260e2be0c03f

Test Failures


Up 1m31s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1119 06:01:01.483] process 47 exited with code 0 after 0.0m
I1119 06:01:01.483] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1119 06:01:01.483] Root: /workspace
I1119 06:01:01.483] cd to /workspace
I1119 06:01:01.483] Configure environment...
I1119 06:01:01.484] Call:  git show -s --format=format:%ct HEAD
W1119 06:01:01.488] fatal: not a git repository (or any of the parent directories): .git
I1119 06:01:01.488] process 60 exited with code 128 after 0.0m
W1119 06:01:01.489] Unable to print commit date for HEAD
I1119 06:01:01.489] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1119 06:01:01.961] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1119 06:01:02.269] process 61 exited with code 0 after 0.0m
I1119 06:01:02.270] Call:  gcloud config get-value account
... skipping 425 lines ...
W1119 06:03:02.158] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1119 06:03:02.159] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1119 06:03:02.160] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1119 06:03:02.160] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1119 06:03:02.161] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1119 06:03:02.161] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1119 06:03:48.277] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1119 06:03:48.318] 2019/11/19 06:03:48 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e' finished in 46.533450667s
W1119 06:03:49.805] 2019/11/19 06:03:49 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1119 06:03:52.852] 2019/11/19 06:03:52 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e: exit status 1
W1119 06:03:52.853] Traceback (most recent call last):
W1119 06:03:52.853]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1119 06:03:52.853]     main(parse_args())
W1119 06:03:52.853]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1119 06:03:52.853]     mode.start(runner_args)
W1119 06:03:52.853]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1119 06:03:52.853]     check_env(env, self.command, *args)
W1119 06:03:52.853]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1119 06:03:52.854]     subprocess.check_call(cmd, env=env)
W1119 06:03:52.854]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1119 06:03:52.854]     raise CalledProcessError(retcode, cmd)
W1119 06:03:52.854] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1119 06:03:52.862] Command failed
I1119 06:03:52.862] process 268 exited with code 1 after 2.8m
E1119 06:03:52.862] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1119 06:03:52.862] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1119 06:03:53.328] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1119 06:03:53.386] process 1432 exited with code 0 after 0.0m
I1119 06:03:53.386] Call:  gcloud config get-value account
I1119 06:03:53.677] process 1445 exited with code 0 after 0.0m
I1119 06:03:53.677] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1119 06:03:53.678] Upload result and artifacts...
I1119 06:03:53.678] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1196669629162852353
I1119 06:03:53.678] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1196669629162852353/artifacts
W1119 06:03:54.440] CommandException: One or more URLs matched no objects.
E1119 06:03:54.540] Command failed
I1119 06:03:54.540] process 1458 exited with code 1 after 0.0m
W1119 06:03:54.540] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1196669629162852353/artifacts not exist yet
I1119 06:03:54.541] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1196669629162852353/artifacts
I1119 06:03:56.047] process 1603 exited with code 0 after 0.0m
I1119 06:03:56.048] Call:  git rev-parse HEAD
W1119 06:03:56.052] fatal: not a git repository (or any of the parent directories): .git
E1119 06:03:56.053] Command failed
I1119 06:03:56.053] process 2130 exited with code 128 after 0.0m
I1119 06:03:56.053] Call:  git rev-parse HEAD
I1119 06:03:56.056] process 2131 exited with code 0 after 0.0m
I1119 06:03:56.057] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1119 06:03:56.897] process 2132 exited with code 0 after 0.0m
I1119 06:03:56.898] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1574100270853623'
... skipping 8 lines ...