This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-18 18:01
Elapsed3m29s
Revision
Buildergke-prow-ssd-pool-1a225945-hj09
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/f68b108c-29e8-45ea-9809-79050c809c07/targets/test'}}
pod52643daf-0a2d-11ea-be88-5a2ed842773b
resultstorehttps://source.cloud.google.com/results/invocations/f68b108c-29e8-45ea-9809-79050c809c07/targets/test
infra-commitf5460a99a
job-versionv1.15.7-beta.0.1+54260e2be0c03f
pod52643daf-0a2d-11ea-be88-5a2ed842773b
revisionv1.15.7-beta.0.1+54260e2be0c03f

Test Failures


Up 1m43s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1118 18:01:03.511] process 47 exited with code 0 after 0.0m
I1118 18:01:03.512] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1118 18:01:03.512] Root: /workspace
I1118 18:01:03.512] cd to /workspace
I1118 18:01:03.512] Configure environment...
I1118 18:01:03.513] Call:  git show -s --format=format:%ct HEAD
W1118 18:01:03.518] fatal: not a git repository (or any of the parent directories): .git
I1118 18:01:03.519] process 60 exited with code 128 after 0.0m
W1118 18:01:03.519] Unable to print commit date for HEAD
I1118 18:01:03.520] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1118 18:01:04.106] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1118 18:01:04.450] process 61 exited with code 0 after 0.0m
I1118 18:01:04.451] Call:  gcloud config get-value account
... skipping 425 lines ...
W1118 18:03:22.349] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1118 18:03:22.350] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1118 18:03:22.350] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1118 18:03:22.351] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1118 18:03:22.351] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1118 18:03:22.352] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1118 18:04:15.158] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1118 18:04:15.206] 2019/11/18 18:04:15 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e' finished in 53.283196511s
W1118 18:04:16.724] 2019/11/18 18:04:16 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1118 18:04:23.844] 2019/11/18 18:04:23 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e: exit status 1
W1118 18:04:23.848] Traceback (most recent call last):
W1118 18:04:23.848]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1118 18:04:23.848]     main(parse_args())
W1118 18:04:23.849]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1118 18:04:23.849]     mode.start(runner_args)
W1118 18:04:23.849]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1118 18:04:23.849]     check_env(env, self.command, *args)
W1118 18:04:23.850]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1118 18:04:23.850]     subprocess.check_call(cmd, env=env)
W1118 18:04:23.850]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1118 18:04:23.850]     raise CalledProcessError(retcode, cmd)
W1118 18:04:23.851] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1118 18:04:23.859] Command failed
I1118 18:04:23.859] process 268 exited with code 1 after 3.3m
E1118 18:04:23.859] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1118 18:04:23.859] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1118 18:04:24.386] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1118 18:04:24.442] process 1432 exited with code 0 after 0.0m
I1118 18:04:24.443] Call:  gcloud config get-value account
I1118 18:04:24.775] process 1445 exited with code 0 after 0.0m
I1118 18:04:24.775] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1118 18:04:24.775] Upload result and artifacts...
I1118 18:04:24.775] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1196488433799794691
I1118 18:04:24.776] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1196488433799794691/artifacts
W1118 18:04:25.634] CommandException: One or more URLs matched no objects.
E1118 18:04:25.745] Command failed
I1118 18:04:25.746] process 1458 exited with code 1 after 0.0m
W1118 18:04:25.746] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1196488433799794691/artifacts not exist yet
I1118 18:04:25.747] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1196488433799794691/artifacts
I1118 18:04:27.383] process 1603 exited with code 0 after 0.0m
I1118 18:04:27.384] Call:  git rev-parse HEAD
W1118 18:04:27.388] fatal: not a git repository (or any of the parent directories): .git
E1118 18:04:27.388] Command failed
I1118 18:04:27.388] process 2130 exited with code 128 after 0.0m
I1118 18:04:27.389] Call:  git rev-parse HEAD
I1118 18:04:27.393] process 2131 exited with code 0 after 0.0m
I1118 18:04:27.395] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1118 18:04:28.456] process 2132 exited with code 0 after 0.0m
I1118 18:04:28.457] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1574057066590791'
... skipping 8 lines ...