This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-18 06:01
Elapsed2m58s
Revision
Buildergke-prow-ssd-pool-1a225945-s2ps
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/2fea1692-43ba-4eb1-b233-dd193b6a7731/targets/test'}}
podbd41d700-09c8-11ea-be88-5a2ed842773b
resultstorehttps://source.cloud.google.com/results/invocations/2fea1692-43ba-4eb1-b233-dd193b6a7731/targets/test
infra-commit5d65c2d6f
job-versionv1.15.7-beta.0.1+54260e2be0c03f
podbd41d700-09c8-11ea-be88-5a2ed842773b
revisionv1.15.7-beta.0.1+54260e2be0c03f

Test Failures


Up 1m36s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1118 06:01:28.908] process 47 exited with code 0 after 0.0m
I1118 06:01:28.908] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1118 06:01:28.909] Root: /workspace
I1118 06:01:28.909] cd to /workspace
I1118 06:01:28.909] Configure environment...
I1118 06:01:28.910] Call:  git show -s --format=format:%ct HEAD
W1118 06:01:28.912] fatal: not a git repository (or any of the parent directories): .git
I1118 06:01:28.913] process 60 exited with code 128 after 0.0m
W1118 06:01:28.913] Unable to print commit date for HEAD
I1118 06:01:28.913] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1118 06:01:29.315] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1118 06:01:29.620] process 61 exited with code 0 after 0.0m
I1118 06:01:29.620] Call:  gcloud config get-value account
... skipping 425 lines ...
W1118 06:03:29.654] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1118 06:03:29.654] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1118 06:03:29.655] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1118 06:03:29.655] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1118 06:03:29.656] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1118 06:03:29.656] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1118 06:04:20.506] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1118 06:04:20.536] 2019/11/18 06:04:20 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e' finished in 51.193284033s
W1118 06:04:21.728] 2019/11/18 06:04:21 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1118 06:04:21.739] 2019/11/18 06:04:21 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e: exit status 1
W1118 06:04:21.743] Traceback (most recent call last):
W1118 06:04:21.743]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1118 06:04:21.743]     main(parse_args())
W1118 06:04:21.743]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1118 06:04:21.743]     mode.start(runner_args)
W1118 06:04:21.743]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1118 06:04:21.743]     check_env(env, self.command, *args)
W1118 06:04:21.743]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1118 06:04:21.744]     subprocess.check_call(cmd, env=env)
W1118 06:04:21.744]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1118 06:04:21.744]     raise CalledProcessError(retcode, cmd)
W1118 06:04:21.744] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1118 06:04:21.748] Command failed
I1118 06:04:21.749] process 268 exited with code 1 after 2.8m
E1118 06:04:21.749] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1118 06:04:21.749] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1118 06:04:22.145] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1118 06:04:22.179] process 1390 exited with code 0 after 0.0m
I1118 06:04:22.179] Call:  gcloud config get-value account
I1118 06:04:22.409] process 1403 exited with code 0 after 0.0m
I1118 06:04:22.409] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1118 06:04:22.410] Upload result and artifacts...
I1118 06:04:22.410] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1196307363447967744
I1118 06:04:22.410] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1196307363447967744/artifacts
W1118 06:04:23.037] CommandException: One or more URLs matched no objects.
E1118 06:04:23.108] Command failed
I1118 06:04:23.109] process 1416 exited with code 1 after 0.0m
W1118 06:04:23.109] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1196307363447967744/artifacts not exist yet
I1118 06:04:23.109] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1196307363447967744/artifacts
I1118 06:04:24.351] process 1561 exited with code 0 after 0.0m
I1118 06:04:24.351] Call:  git rev-parse HEAD
W1118 06:04:24.354] fatal: not a git repository (or any of the parent directories): .git
E1118 06:04:24.355] Command failed
I1118 06:04:24.355] process 2088 exited with code 128 after 0.0m
I1118 06:04:24.355] Call:  git rev-parse HEAD
I1118 06:04:24.358] process 2089 exited with code 0 after 0.0m
I1118 06:04:24.358] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1118 06:04:25.035] process 2090 exited with code 0 after 0.0m
I1118 06:04:25.036] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1574013870796264'
... skipping 8 lines ...