This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-16 18:01
Elapsed3m46s
Revision
Buildergke-prow-ssd-pool-1a225945-lf79
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/a9b41cd4-ee5a-4923-a11b-b9bdfad14567/targets/test'}}
podff51452e-089a-11ea-be88-5a2ed842773b
resultstorehttps://source.cloud.google.com/results/invocations/a9b41cd4-ee5a-4923-a11b-b9bdfad14567/targets/test
infra-commit0eec43e43
job-versionv1.15.7-beta.0.1+54260e2be0c03f
podff51452e-089a-11ea-be88-5a2ed842773b
revisionv1.15.7-beta.0.1+54260e2be0c03f

Test Failures


Up 1m40s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1116 18:01:39.307] process 47 exited with code 0 after 0.0m
I1116 18:01:39.307] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1116 18:01:39.307] Root: /workspace
I1116 18:01:39.308] cd to /workspace
I1116 18:01:39.308] Configure environment...
I1116 18:01:39.308] Call:  git show -s --format=format:%ct HEAD
W1116 18:01:39.312] fatal: not a git repository (or any of the parent directories): .git
I1116 18:01:39.313] process 60 exited with code 128 after 0.0m
W1116 18:01:39.313] Unable to print commit date for HEAD
I1116 18:01:39.313] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1116 18:01:39.996] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1116 18:01:40.371] process 61 exited with code 0 after 0.0m
I1116 18:01:40.372] Call:  gcloud config get-value account
... skipping 425 lines ...
W1116 18:04:17.672] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1116 18:04:17.673] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1116 18:04:17.674] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1116 18:04:17.674] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1116 18:04:17.675] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1116 18:04:17.675] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1116 18:05:02.167] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1116 18:05:02.211] 2019/11/16 18:05:02 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e' finished in 44.913688669s
W1116 18:05:03.828] 2019/11/16 18:05:03 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1116 18:05:17.429] 2019/11/16 18:05:17 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e: exit status 1
W1116 18:05:17.435] Traceback (most recent call last):
W1116 18:05:17.435]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1116 18:05:17.436]     main(parse_args())
W1116 18:05:17.436]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1116 18:05:17.436]     mode.start(runner_args)
W1116 18:05:17.436]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1116 18:05:17.436]     check_env(env, self.command, *args)
W1116 18:05:17.437]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1116 18:05:17.437]     subprocess.check_call(cmd, env=env)
W1116 18:05:17.437]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1116 18:05:17.437]     raise CalledProcessError(retcode, cmd)
W1116 18:05:17.438] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1116 18:05:17.440] Command failed
I1116 18:05:17.441] process 268 exited with code 1 after 3.6m
E1116 18:05:17.441] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1116 18:05:17.441] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1116 18:05:17.972] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1116 18:05:18.024] process 1389 exited with code 0 after 0.0m
I1116 18:05:18.024] Call:  gcloud config get-value account
I1116 18:05:18.345] process 1402 exited with code 0 after 0.0m
I1116 18:05:18.345] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1116 18:05:18.346] Upload result and artifacts...
I1116 18:05:18.346] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1195763794085679105
I1116 18:05:18.346] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1195763794085679105/artifacts
W1116 18:05:19.247] CommandException: One or more URLs matched no objects.
E1116 18:05:19.357] Command failed
I1116 18:05:19.357] process 1415 exited with code 1 after 0.0m
W1116 18:05:19.357] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1195763794085679105/artifacts not exist yet
I1116 18:05:19.358] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1195763794085679105/artifacts
I1116 18:05:20.991] process 1560 exited with code 0 after 0.0m
I1116 18:05:20.991] Call:  git rev-parse HEAD
W1116 18:05:20.995] fatal: not a git repository (or any of the parent directories): .git
E1116 18:05:20.995] Command failed
I1116 18:05:20.995] process 2087 exited with code 128 after 0.0m
I1116 18:05:20.996] Call:  git rev-parse HEAD
I1116 18:05:21.000] process 2088 exited with code 0 after 0.0m
I1116 18:05:21.000] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1116 18:05:21.901] process 2089 exited with code 0 after 0.0m
I1116 18:05:21.902] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1573884321761551'
... skipping 8 lines ...