This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-16 06:01
Elapsed3m41s
Revision
Buildergke-prow-ssd-pool-1a225945-khv0
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/6ed927cb-879e-4226-bcc8-b787ae19dd34/targets/test'}}
pod6b8e7599-0836-11ea-be88-5a2ed842773b
resultstorehttps://source.cloud.google.com/results/invocations/6ed927cb-879e-4226-bcc8-b787ae19dd34/targets/test
infra-commite6eb7488e
job-versionv1.15.7-beta.0.1+54260e2be0c03f
pod6b8e7599-0836-11ea-be88-5a2ed842773b
revisionv1.15.7-beta.0.1+54260e2be0c03f

Test Failures


Up 1m27s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1116 06:01:42.287] process 48 exited with code 0 after 0.0m
I1116 06:01:42.287] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1116 06:01:42.288] Root: /workspace
I1116 06:01:42.288] cd to /workspace
I1116 06:01:42.288] Configure environment...
I1116 06:01:42.289] Call:  git show -s --format=format:%ct HEAD
W1116 06:01:42.295] fatal: not a git repository (or any of the parent directories): .git
I1116 06:01:42.296] process 61 exited with code 128 after 0.0m
W1116 06:01:42.296] Unable to print commit date for HEAD
I1116 06:01:42.297] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1116 06:01:43.097] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1116 06:01:43.478] process 62 exited with code 0 after 0.0m
I1116 06:01:43.479] Call:  gcloud config get-value account
... skipping 421 lines ...
W1116 06:04:08.129] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1116 06:04:08.131] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1116 06:04:08.132] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1116 06:04:08.132] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1116 06:04:08.133] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1116 06:04:08.133] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1116 06:05:00.227] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1116 06:05:00.291] 2019/11/16 06:05:00 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e' finished in 52.681930181s
W1116 06:05:01.980] 2019/11/16 06:05:01 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1116 06:05:14.763] 2019/11/16 06:05:14 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e: exit status 1
W1116 06:05:14.763] Traceback (most recent call last):
W1116 06:05:14.764]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1116 06:05:14.764]     main(parse_args())
W1116 06:05:14.764]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1116 06:05:14.764]     mode.start(runner_args)
W1116 06:05:14.764]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1116 06:05:14.764]     check_env(env, self.command, *args)
W1116 06:05:14.764]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1116 06:05:14.764]     subprocess.check_call(cmd, env=env)
W1116 06:05:14.765]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1116 06:05:14.765]     raise CalledProcessError(retcode, cmd)
W1116 06:05:14.765] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1116 06:05:14.774] Command failed
I1116 06:05:14.775] process 269 exited with code 1 after 3.5m
E1116 06:05:14.775] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1116 06:05:14.775] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1116 06:05:15.309] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1116 06:05:15.374] process 1379 exited with code 0 after 0.0m
I1116 06:05:15.374] Call:  gcloud config get-value account
I1116 06:05:15.738] process 1392 exited with code 0 after 0.0m
I1116 06:05:15.739] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1116 06:05:15.739] Upload result and artifacts...
I1116 06:05:15.739] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1195582601088208909
I1116 06:05:15.739] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1195582601088208909/artifacts
W1116 06:05:16.648] CommandException: One or more URLs matched no objects.
E1116 06:05:16.789] Command failed
I1116 06:05:16.790] process 1405 exited with code 1 after 0.0m
W1116 06:05:16.790] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1195582601088208909/artifacts not exist yet
I1116 06:05:16.790] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1195582601088208909/artifacts
I1116 06:05:18.590] process 1550 exited with code 0 after 0.0m
I1116 06:05:18.591] Call:  git rev-parse HEAD
W1116 06:05:18.595] fatal: not a git repository (or any of the parent directories): .git
E1116 06:05:18.596] Command failed
I1116 06:05:18.596] process 2077 exited with code 128 after 0.0m
I1116 06:05:18.596] Call:  git rev-parse HEAD
I1116 06:05:18.602] process 2078 exited with code 0 after 0.0m
I1116 06:05:18.602] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1116 06:05:19.595] process 2079 exited with code 0 after 0.0m
I1116 06:05:19.596] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1573841217087898'
... skipping 8 lines ...