This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-15 06:00
Elapsed3m19s
Revision
Buildergke-prow-ssd-pool-1a225945-m94v
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/a700cdb4-a1cf-4906-ab38-4cccff20036e/targets/test'}}
pod31fda8bb-076d-11ea-b5c7-e216f5392f03
resultstorehttps://source.cloud.google.com/results/invocations/a700cdb4-a1cf-4906-ab38-4cccff20036e/targets/test
infra-commited1e2dd7a
job-versionv1.15.7-beta.0.1+54260e2be0c03f
pod31fda8bb-076d-11ea-b5c7-e216f5392f03
revisionv1.15.7-beta.0.1+54260e2be0c03f

Test Failures


Up 1m32s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1115 06:00:55.271] process 45 exited with code 0 after 0.0m
I1115 06:00:55.271] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1115 06:00:55.271] Root: /workspace
I1115 06:00:55.272] cd to /workspace
I1115 06:00:55.272] Configure environment...
I1115 06:00:55.272] Call:  git show -s --format=format:%ct HEAD
W1115 06:00:55.275] fatal: not a git repository (or any of the parent directories): .git
I1115 06:00:55.276] process 57 exited with code 128 after 0.0m
W1115 06:00:55.276] Unable to print commit date for HEAD
I1115 06:00:55.276] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1115 06:00:55.864] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1115 06:00:56.310] process 58 exited with code 0 after 0.0m
I1115 06:00:56.311] Call:  gcloud config get-value account
... skipping 421 lines ...
W1115 06:03:05.006] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1115 06:03:05.007] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1115 06:03:05.007] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1115 06:03:05.008] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1115 06:03:05.009] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1115 06:03:05.009] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1115 06:03:55.544] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1115 06:03:55.600] 2019/11/15 06:03:55 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e' finished in 50.995107136s
W1115 06:03:57.190] 2019/11/15 06:03:57 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1115 06:04:06.084] 2019/11/15 06:04:06 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e: exit status 1
W1115 06:04:06.087] Traceback (most recent call last):
W1115 06:04:06.088]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1115 06:04:06.088]     main(parse_args())
W1115 06:04:06.089]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1115 06:04:06.089]     mode.start(runner_args)
W1115 06:04:06.089]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1115 06:04:06.090]     check_env(env, self.command, *args)
W1115 06:04:06.090]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1115 06:04:06.091]     subprocess.check_call(cmd, env=env)
W1115 06:04:06.091]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1115 06:04:06.091]     raise CalledProcessError(retcode, cmd)
W1115 06:04:06.092] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1115 06:04:06.098] Command failed
I1115 06:04:06.098] process 262 exited with code 1 after 3.1m
E1115 06:04:06.098] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1115 06:04:06.099] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1115 06:04:06.695] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1115 06:04:06.756] process 1364 exited with code 0 after 0.0m
I1115 06:04:06.756] Call:  gcloud config get-value account
I1115 06:04:07.054] process 1376 exited with code 0 after 0.0m
I1115 06:04:07.054] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1115 06:04:07.054] Upload result and artifacts...
I1115 06:04:07.054] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1195220044368318468
I1115 06:04:07.055] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1195220044368318468/artifacts
W1115 06:04:07.834] CommandException: One or more URLs matched no objects.
E1115 06:04:07.971] Command failed
I1115 06:04:07.972] process 1388 exited with code 1 after 0.0m
W1115 06:04:07.972] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1195220044368318468/artifacts not exist yet
I1115 06:04:07.972] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1195220044368318468/artifacts
I1115 06:04:09.601] process 1532 exited with code 0 after 0.0m
I1115 06:04:09.602] Call:  git rev-parse HEAD
W1115 06:04:09.614] fatal: not a git repository (or any of the parent directories): .git
E1115 06:04:09.615] Command failed
I1115 06:04:09.615] process 2058 exited with code 128 after 0.0m
I1115 06:04:09.615] Call:  git rev-parse HEAD
I1115 06:04:09.619] process 2059 exited with code 0 after 0.0m
I1115 06:04:09.619] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1115 06:04:10.646] process 2060 exited with code 0 after 0.0m
I1115 06:04:10.647] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1573754682031434'
... skipping 8 lines ...