This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-14 18:00
Elapsed3m45s
Revision
Buildergke-prow-ssd-pool-1a225945-s2ps
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/3c9029a1-0789-4efc-a0f0-e9658eac0a91/targets/test'}}
pod9c76c385-0708-11ea-b5c7-e216f5392f03
resultstorehttps://source.cloud.google.com/results/invocations/3c9029a1-0789-4efc-a0f0-e9658eac0a91/targets/test
infra-commite3e01110a
job-versionv1.15.7-beta.0.1+54260e2be0c03f
pod9c76c385-0708-11ea-b5c7-e216f5392f03
revisionv1.15.7-beta.0.1+54260e2be0c03f

Test Failures


Up 1m23s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1114 18:00:58.866] process 46 exited with code 0 after 0.0m
I1114 18:00:58.867] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1114 18:00:58.867] Root: /workspace
I1114 18:00:58.867] cd to /workspace
I1114 18:00:58.868] Configure environment...
I1114 18:00:58.868] Call:  git show -s --format=format:%ct HEAD
W1114 18:00:58.873] fatal: not a git repository (or any of the parent directories): .git
I1114 18:00:58.874] process 58 exited with code 128 after 0.0m
W1114 18:00:58.874] Unable to print commit date for HEAD
I1114 18:00:58.874] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1114 18:00:59.411] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1114 18:00:59.782] process 59 exited with code 0 after 0.0m
I1114 18:00:59.783] Call:  gcloud config get-value account
... skipping 425 lines ...
W1114 18:03:28.998] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1114 18:03:28.999] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1114 18:03:29.000] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1114 18:03:29.001] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1114 18:03:29.002] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1114 18:03:29.002] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1114 18:04:16.946] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1114 18:04:17.032] 2019/11/14 18:04:17 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e' finished in 48.48013346s
W1114 18:04:18.859] 2019/11/14 18:04:18 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1114 18:04:33.300] 2019/11/14 18:04:33 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.7-beta.0.1+54260e2be0c03f bootstrap-e2e: exit status 1
W1114 18:04:33.304] Traceback (most recent call last):
W1114 18:04:33.304]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1114 18:04:33.305]     main(parse_args())
W1114 18:04:33.305]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1114 18:04:33.305]     mode.start(runner_args)
W1114 18:04:33.305]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1114 18:04:33.306]     check_env(env, self.command, *args)
W1114 18:04:33.306]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1114 18:04:33.306]     subprocess.check_call(cmd, env=env)
W1114 18:04:33.306]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1114 18:04:33.306]     raise CalledProcessError(retcode, cmd)
W1114 18:04:33.307] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1114 18:04:33.316] Command failed
I1114 18:04:33.317] process 263 exited with code 1 after 3.5m
E1114 18:04:33.317] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1114 18:04:33.317] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1114 18:04:33.995] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1114 18:04:34.069] process 1377 exited with code 0 after 0.0m
I1114 18:04:34.070] Call:  gcloud config get-value account
I1114 18:04:34.476] process 1389 exited with code 0 after 0.0m
I1114 18:04:34.476] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1114 18:04:34.476] Upload result and artifacts...
I1114 18:04:34.476] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1195038849978339333
I1114 18:04:34.477] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1195038849978339333/artifacts
W1114 18:04:35.611] CommandException: One or more URLs matched no objects.
E1114 18:04:35.760] Command failed
I1114 18:04:35.760] process 1401 exited with code 1 after 0.0m
W1114 18:04:35.760] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1195038849978339333/artifacts not exist yet
I1114 18:04:35.761] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1195038849978339333/artifacts
I1114 18:04:37.806] process 1545 exited with code 0 after 0.0m
I1114 18:04:37.841] Call:  git rev-parse HEAD
W1114 18:04:37.848] fatal: not a git repository (or any of the parent directories): .git
E1114 18:04:37.849] Command failed
I1114 18:04:37.849] process 2071 exited with code 128 after 0.0m
I1114 18:04:37.849] Call:  git rev-parse HEAD
I1114 18:04:37.855] process 2072 exited with code 0 after 0.0m
I1114 18:04:37.856] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1114 18:04:39.167] process 2073 exited with code 0 after 0.0m
I1114 18:04:39.168] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1573711428020778'
... skipping 8 lines ...