This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-13 18:01
Elapsed3m4s
Revision
Buildergke-prow-ssd-pool-1a225945-4sp7
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/29533677-afbe-4eab-bd65-e01816057c33/targets/test'}}
pod6f7307e7-063f-11ea-993c-5ac2047d9356
resultstorehttps://source.cloud.google.com/results/invocations/29533677-afbe-4eab-bd65-e01816057c33/targets/test
infra-commit135018395
job-versionv1.15.6-beta.0.38+7015f71e75f670
pod6f7307e7-063f-11ea-993c-5ac2047d9356
revisionv1.15.6-beta.0.38+7015f71e75f670

Test Failures


Up 1m28s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.38+7015f71e75f670 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1113 18:01:02.882] process 45 exited with code 0 after 0.0m
I1113 18:01:02.883] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1113 18:01:02.883] Root: /workspace
I1113 18:01:02.883] cd to /workspace
I1113 18:01:02.883] Configure environment...
I1113 18:01:02.884] Call:  git show -s --format=format:%ct HEAD
W1113 18:01:02.887] fatal: not a git repository (or any of the parent directories): .git
I1113 18:01:02.888] process 57 exited with code 128 after 0.0m
W1113 18:01:02.888] Unable to print commit date for HEAD
I1113 18:01:02.889] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1113 18:01:03.391] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1113 18:01:03.711] process 58 exited with code 0 after 0.0m
I1113 18:01:03.711] Call:  gcloud config get-value account
... skipping 425 lines ...
W1113 18:03:06.784] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1113 18:03:06.785] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1113 18:03:06.786] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1113 18:03:06.786] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1113 18:03:06.787] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1113 18:03:06.787] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1113 18:03:54.771] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1113 18:03:54.814] 2019/11/13 18:03:54 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.38+7015f71e75f670 bootstrap-e2e' finished in 48.395160234s
W1113 18:03:56.281] 2019/11/13 18:03:56 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1113 18:04:00.638] 2019/11/13 18:04:00 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.38+7015f71e75f670 bootstrap-e2e: exit status 1
W1113 18:04:00.641] Traceback (most recent call last):
W1113 18:04:00.642]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1113 18:04:00.642]     main(parse_args())
W1113 18:04:00.642]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1113 18:04:00.642]     mode.start(runner_args)
W1113 18:04:00.642]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1113 18:04:00.642]     check_env(env, self.command, *args)
W1113 18:04:00.643]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1113 18:04:00.643]     subprocess.check_call(cmd, env=env)
W1113 18:04:00.643]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1113 18:04:00.643]     raise CalledProcessError(retcode, cmd)
W1113 18:04:00.644] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1113 18:04:00.654] Command failed
I1113 18:04:00.655] process 262 exited with code 1 after 2.9m
E1113 18:04:00.655] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1113 18:04:00.655] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1113 18:04:01.164] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1113 18:04:01.224] process 1379 exited with code 0 after 0.0m
I1113 18:04:01.224] Call:  gcloud config get-value account
I1113 18:04:01.542] process 1391 exited with code 0 after 0.0m
I1113 18:04:01.542] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1113 18:04:01.542] Upload result and artifacts...
I1113 18:04:01.542] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1194676503023980548
I1113 18:04:01.543] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1194676503023980548/artifacts
W1113 18:04:02.386] CommandException: One or more URLs matched no objects.
E1113 18:04:02.494] Command failed
I1113 18:04:02.494] process 1403 exited with code 1 after 0.0m
W1113 18:04:02.494] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1194676503023980548/artifacts not exist yet
I1113 18:04:02.495] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1194676503023980548/artifacts
I1113 18:04:03.951] process 1547 exited with code 0 after 0.0m
I1113 18:04:03.952] Call:  git rev-parse HEAD
W1113 18:04:03.955] fatal: not a git repository (or any of the parent directories): .git
E1113 18:04:03.955] Command failed
I1113 18:04:03.956] process 2073 exited with code 128 after 0.0m
I1113 18:04:03.956] Call:  git rev-parse HEAD
I1113 18:04:03.959] process 2074 exited with code 0 after 0.0m
I1113 18:04:03.960] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1113 18:04:04.793] process 2075 exited with code 0 after 0.0m
I1113 18:04:04.794] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1573625088497247'
... skipping 8 lines ...