This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-13 06:01
Elapsed3m43s
Revision
Buildergke-prow-ssd-pool-1a225945-d0kf
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/6dad208c-b841-4d16-8e43-0d3f3deccda6/targets/test'}}
podd9650608-05da-11ea-993c-5ac2047d9356
resultstorehttps://source.cloud.google.com/results/invocations/6dad208c-b841-4d16-8e43-0d3f3deccda6/targets/test
infra-commitcce53531b
job-versionv1.15.6-beta.0.38+7015f71e75f670
podd9650608-05da-11ea-993c-5ac2047d9356
revisionv1.15.6-beta.0.38+7015f71e75f670

Test Failures


Up 1m29s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.38+7015f71e75f670 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1113 06:01:06.592] process 45 exited with code 0 after 0.0m
I1113 06:01:06.593] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1113 06:01:06.593] Root: /workspace
I1113 06:01:06.593] cd to /workspace
I1113 06:01:06.593] Configure environment...
I1113 06:01:06.593] Call:  git show -s --format=format:%ct HEAD
W1113 06:01:06.597] fatal: not a git repository (or any of the parent directories): .git
I1113 06:01:06.597] process 57 exited with code 128 after 0.0m
W1113 06:01:06.597] Unable to print commit date for HEAD
I1113 06:01:06.598] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1113 06:01:07.123] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1113 06:01:07.444] process 58 exited with code 0 after 0.0m
I1113 06:01:07.445] Call:  gcloud config get-value account
... skipping 425 lines ...
W1113 06:03:47.880] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1113 06:03:47.881] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1113 06:03:47.881] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1113 06:03:47.882] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1113 06:03:47.883] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1113 06:03:47.883] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1113 06:04:37.086] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1113 06:04:37.128] 2019/11/13 06:04:37 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.38+7015f71e75f670 bootstrap-e2e' finished in 49.684493933s
W1113 06:04:38.660] 2019/11/13 06:04:38 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1113 06:04:41.807] 2019/11/13 06:04:41 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.38+7015f71e75f670 bootstrap-e2e: exit status 1
W1113 06:04:41.812] Traceback (most recent call last):
W1113 06:04:41.813]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1113 06:04:41.813]     main(parse_args())
W1113 06:04:41.813]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1113 06:04:41.813]     mode.start(runner_args)
W1113 06:04:41.814]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1113 06:04:41.814]     check_env(env, self.command, *args)
W1113 06:04:41.814]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1113 06:04:41.814]     subprocess.check_call(cmd, env=env)
W1113 06:04:41.815]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1113 06:04:41.815]     raise CalledProcessError(retcode, cmd)
W1113 06:04:41.815] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1113 06:04:41.821] Command failed
I1113 06:04:41.822] process 262 exited with code 1 after 3.5m
E1113 06:04:41.822] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1113 06:04:41.823] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1113 06:04:42.335] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1113 06:04:42.388] process 1381 exited with code 0 after 0.0m
I1113 06:04:42.389] Call:  gcloud config get-value account
I1113 06:04:42.696] process 1393 exited with code 0 after 0.0m
I1113 06:04:42.697] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1113 06:04:42.697] Upload result and artifacts...
I1113 06:04:42.697] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1194495304225787905
I1113 06:04:42.698] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1194495304225787905/artifacts
W1113 06:04:43.568] CommandException: One or more URLs matched no objects.
E1113 06:04:43.674] Command failed
I1113 06:04:43.674] process 1405 exited with code 1 after 0.0m
W1113 06:04:43.675] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1194495304225787905/artifacts not exist yet
I1113 06:04:43.675] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1194495304225787905/artifacts
I1113 06:04:45.328] process 1549 exited with code 0 after 0.0m
I1113 06:04:45.329] Call:  git rev-parse HEAD
W1113 06:04:45.333] fatal: not a git repository (or any of the parent directories): .git
E1113 06:04:45.333] Command failed
I1113 06:04:45.333] process 2075 exited with code 128 after 0.0m
I1113 06:04:45.334] Call:  git rev-parse HEAD
I1113 06:04:45.337] process 2076 exited with code 0 after 0.0m
I1113 06:04:45.338] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1113 06:04:46.233] process 2077 exited with code 0 after 0.0m
I1113 06:04:46.234] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1573581916233152'
... skipping 8 lines ...