This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-12 18:01
Elapsed3m46s
Revision
Buildergke-prow-ssd-pool-1a225945-6r1w
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/bbf8ae5c-6faf-4406-9b16-5e9324690ddf/targets/test'}}
pod582539ad-0576-11ea-906a-faf80766f8b6
resultstorehttps://source.cloud.google.com/results/invocations/bbf8ae5c-6faf-4406-9b16-5e9324690ddf/targets/test
infra-commit7d1113798
job-versionv1.15.6-beta.0.38+7015f71e75f670
pod582539ad-0576-11ea-906a-faf80766f8b6
revisionv1.15.6-beta.0.38+7015f71e75f670

Test Failures


Up 2m7s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.38+7015f71e75f670 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1112 18:01:31.773] process 45 exited with code 0 after 0.0m
I1112 18:01:31.774] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1112 18:01:31.774] Root: /workspace
I1112 18:01:31.774] cd to /workspace
I1112 18:01:31.774] Configure environment...
I1112 18:01:31.775] Call:  git show -s --format=format:%ct HEAD
W1112 18:01:31.778] fatal: not a git repository (or any of the parent directories): .git
I1112 18:01:31.778] process 57 exited with code 128 after 0.0m
W1112 18:01:31.779] Unable to print commit date for HEAD
I1112 18:01:31.779] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1112 18:01:32.259] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1112 18:01:32.567] process 58 exited with code 0 after 0.0m
I1112 18:01:32.568] Call:  gcloud config get-value account
... skipping 425 lines ...
W1112 18:04:17.725] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1112 18:04:17.725] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1112 18:04:17.726] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1112 18:04:17.726] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1112 18:04:17.727] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1112 18:04:17.727] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1112 18:05:03.677] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1112 18:05:03.713] 2019/11/12 18:05:03 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.38+7015f71e75f670 bootstrap-e2e' finished in 46.339007168s
W1112 18:05:05.107] 2019/11/12 18:05:05 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1112 18:05:10.586] 2019/11/12 18:05:10 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.38+7015f71e75f670 bootstrap-e2e: exit status 1
W1112 18:05:10.588] Traceback (most recent call last):
W1112 18:05:10.588]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1112 18:05:10.588]     main(parse_args())
W1112 18:05:10.589]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1112 18:05:10.589]     mode.start(runner_args)
W1112 18:05:10.589]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1112 18:05:10.589]     check_env(env, self.command, *args)
W1112 18:05:10.589]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1112 18:05:10.589]     subprocess.check_call(cmd, env=env)
W1112 18:05:10.589]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1112 18:05:10.590]     raise CalledProcessError(retcode, cmd)
W1112 18:05:10.590] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1112 18:05:10.596] Command failed
I1112 18:05:10.597] process 262 exited with code 1 after 3.6m
E1112 18:05:10.597] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1112 18:05:10.597] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1112 18:05:11.085] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1112 18:05:11.137] process 1379 exited with code 0 after 0.0m
I1112 18:05:11.137] Call:  gcloud config get-value account
I1112 18:05:11.425] process 1391 exited with code 0 after 0.0m
I1112 18:05:11.426] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1112 18:05:11.426] Upload result and artifacts...
I1112 18:05:11.426] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1194314231801974787
I1112 18:05:11.426] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1194314231801974787/artifacts
W1112 18:05:12.163] CommandException: One or more URLs matched no objects.
E1112 18:05:12.255] Command failed
I1112 18:05:12.255] process 1403 exited with code 1 after 0.0m
W1112 18:05:12.256] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1194314231801974787/artifacts not exist yet
I1112 18:05:12.256] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1194314231801974787/artifacts
I1112 18:05:13.589] process 1547 exited with code 0 after 0.0m
I1112 18:05:13.590] Call:  git rev-parse HEAD
W1112 18:05:13.593] fatal: not a git repository (or any of the parent directories): .git
E1112 18:05:13.594] Command failed
I1112 18:05:13.594] process 2073 exited with code 128 after 0.0m
I1112 18:05:13.594] Call:  git rev-parse HEAD
I1112 18:05:13.597] process 2074 exited with code 0 after 0.0m
I1112 18:05:13.598] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1112 18:05:14.394] process 2075 exited with code 0 after 0.0m
I1112 18:05:14.395] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1573538708309118'
... skipping 8 lines ...