This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-11 06:00
Elapsed3m9s
Revision
Buildergke-prow-ssd-pool-1a225945-6r1w
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/e5e3ff40-8dda-4306-819a-647651e7e03a/targets/test'}}
pod87b926a2-0448-11ea-88c9-c26ecbf388b3
resultstorehttps://source.cloud.google.com/results/invocations/e5e3ff40-8dda-4306-819a-647651e7e03a/targets/test
infra-commit830666073
job-versionv1.15.6-beta.0.38+7015f71e75f670
pod87b926a2-0448-11ea-88c9-c26ecbf388b3
revisionv1.15.6-beta.0.38+7015f71e75f670

Test Failures


Up 1m38s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.38+7015f71e75f670 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1111 06:00:56.293] process 51 exited with code 0 after 0.0m
I1111 06:00:56.293] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1111 06:00:56.293] Root: /workspace
I1111 06:00:56.293] cd to /workspace
I1111 06:00:56.293] Configure environment...
I1111 06:00:56.294] Call:  git show -s --format=format:%ct HEAD
W1111 06:00:56.297] fatal: not a git repository (or any of the parent directories): .git
I1111 06:00:56.298] process 63 exited with code 128 after 0.0m
W1111 06:00:56.298] Unable to print commit date for HEAD
I1111 06:00:56.298] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1111 06:00:56.764] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1111 06:00:57.072] process 64 exited with code 0 after 0.0m
I1111 06:00:57.072] Call:  gcloud config get-value account
... skipping 425 lines ...
W1111 06:03:03.429] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1111 06:03:03.430] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1111 06:03:03.430] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1111 06:03:03.431] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1111 06:03:03.432] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1111 06:03:03.432] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1111 06:03:51.472] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1111 06:03:51.524] 2019/11/11 06:03:51 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.38+7015f71e75f670 bootstrap-e2e' finished in 48.534478994s
W1111 06:03:53.067] 2019/11/11 06:03:53 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1111 06:03:58.381] 2019/11/11 06:03:58 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.38+7015f71e75f670 bootstrap-e2e: exit status 1
W1111 06:03:58.383] Traceback (most recent call last):
W1111 06:03:58.383]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1111 06:03:58.383]     main(parse_args())
W1111 06:03:58.384]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1111 06:03:58.384]     mode.start(runner_args)
W1111 06:03:58.384]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1111 06:03:58.384]     check_env(env, self.command, *args)
W1111 06:03:58.385]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1111 06:03:58.385]     subprocess.check_call(cmd, env=env)
W1111 06:03:58.385]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1111 06:03:58.385]     raise CalledProcessError(retcode, cmd)
W1111 06:03:58.386] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1111 06:03:58.391] Command failed
I1111 06:03:58.391] process 268 exited with code 1 after 3.0m
E1111 06:03:58.391] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1111 06:03:58.391] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1111 06:03:58.880] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1111 06:03:58.928] process 1384 exited with code 0 after 0.0m
I1111 06:03:58.929] Call:  gcloud config get-value account
I1111 06:03:59.208] process 1396 exited with code 0 after 0.0m
I1111 06:03:59.208] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1111 06:03:59.208] Upload result and artifacts...
I1111 06:03:59.209] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1193770507359490048
I1111 06:03:59.209] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1193770507359490048/artifacts
W1111 06:03:59.959] CommandException: One or more URLs matched no objects.
E1111 06:04:00.078] Command failed
I1111 06:04:00.078] process 1408 exited with code 1 after 0.0m
W1111 06:04:00.079] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1193770507359490048/artifacts not exist yet
I1111 06:04:00.079] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1193770507359490048/artifacts
I1111 06:04:01.568] process 1552 exited with code 0 after 0.0m
I1111 06:04:01.569] Call:  git rev-parse HEAD
W1111 06:04:01.572] fatal: not a git repository (or any of the parent directories): .git
E1111 06:04:01.573] Command failed
I1111 06:04:01.573] process 2078 exited with code 128 after 0.0m
I1111 06:04:01.573] Call:  git rev-parse HEAD
I1111 06:04:01.576] process 2079 exited with code 0 after 0.0m
I1111 06:04:01.577] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1111 06:04:02.431] process 2080 exited with code 0 after 0.0m
I1111 06:04:02.431] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1573409042559037'
... skipping 8 lines ...