This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-10 18:01
Elapsed2m59s
Revision
Buildergke-prow-ssd-pool-1a225945-s2ps
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/9ca9d712-4c09-461c-a865-da60fc48e436/targets/test'}}
podfb103031-03e3-11ea-b541-aebeeb3e99ae
resultstorehttps://source.cloud.google.com/results/invocations/9ca9d712-4c09-461c-a865-da60fc48e436/targets/test
infra-commit830666073
job-versionv1.15.6-beta.0.38+7015f71e75f670
podfb103031-03e3-11ea-b541-aebeeb3e99ae
revisionv1.15.6-beta.0.38+7015f71e75f670

Test Failures


Up 1m22s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.38+7015f71e75f670 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1110 18:01:04.360] process 45 exited with code 0 after 0.0m
I1110 18:01:04.360] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1110 18:01:04.361] Root: /workspace
I1110 18:01:04.361] cd to /workspace
I1110 18:01:04.361] Configure environment...
I1110 18:01:04.361] Call:  git show -s --format=format:%ct HEAD
W1110 18:01:04.365] fatal: not a git repository (or any of the parent directories): .git
I1110 18:01:04.366] process 57 exited with code 128 after 0.0m
W1110 18:01:04.366] Unable to print commit date for HEAD
I1110 18:01:04.367] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1110 18:01:04.915] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1110 18:01:05.262] process 58 exited with code 0 after 0.0m
I1110 18:01:05.263] Call:  gcloud config get-value account
... skipping 425 lines ...
W1110 18:03:04.755] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1110 18:03:04.755] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1110 18:03:04.755] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1110 18:03:04.755] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1110 18:03:04.756] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1110 18:03:04.756] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1110 18:03:47.979] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1110 18:03:48.027] 2019/11/10 18:03:48 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.38+7015f71e75f670 bootstrap-e2e' finished in 43.704978324s
W1110 18:03:49.542] 2019/11/10 18:03:49 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1110 18:03:56.151] 2019/11/10 18:03:56 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.38+7015f71e75f670 bootstrap-e2e: exit status 1
W1110 18:03:56.151] Traceback (most recent call last):
W1110 18:03:56.151]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1110 18:03:56.152]     main(parse_args())
W1110 18:03:56.152]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1110 18:03:56.152]     mode.start(runner_args)
W1110 18:03:56.152]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1110 18:03:56.152]     check_env(env, self.command, *args)
W1110 18:03:56.152]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1110 18:03:56.152]     subprocess.check_call(cmd, env=env)
W1110 18:03:56.152]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1110 18:03:56.152]     raise CalledProcessError(retcode, cmd)
W1110 18:03:56.153] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1110 18:03:56.161] Command failed
I1110 18:03:56.161] process 262 exited with code 1 after 2.8m
E1110 18:03:56.161] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1110 18:03:56.162] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1110 18:03:56.670] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1110 18:03:56.724] process 1378 exited with code 0 after 0.0m
I1110 18:03:56.724] Call:  gcloud config get-value account
I1110 18:03:57.026] process 1390 exited with code 0 after 0.0m
I1110 18:03:57.026] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1110 18:03:57.027] Upload result and artifacts...
I1110 18:03:57.027] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1193589341931180033
I1110 18:03:57.027] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1193589341931180033/artifacts
W1110 18:03:57.843] CommandException: One or more URLs matched no objects.
E1110 18:03:57.952] Command failed
I1110 18:03:57.952] process 1402 exited with code 1 after 0.0m
W1110 18:03:57.953] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1193589341931180033/artifacts not exist yet
I1110 18:03:57.953] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1193589341931180033/artifacts
I1110 18:03:59.529] process 1546 exited with code 0 after 0.0m
I1110 18:03:59.529] Call:  git rev-parse HEAD
W1110 18:03:59.533] fatal: not a git repository (or any of the parent directories): .git
E1110 18:03:59.534] Command failed
I1110 18:03:59.534] process 2072 exited with code 128 after 0.0m
I1110 18:03:59.534] Call:  git rev-parse HEAD
I1110 18:03:59.538] process 2073 exited with code 0 after 0.0m
I1110 18:03:59.538] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1110 18:04:00.430] process 2074 exited with code 0 after 0.0m
I1110 18:04:00.431] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1573365876443444'
... skipping 8 lines ...