This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-09 18:01
Elapsed3m17s
Revision
Buildergke-prow-ssd-pool-1a225945-hj09
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/e15ec31c-9211-4d7b-8d81-da88843ae644/targets/test'}}
podd1a39e20-031a-11ea-b541-aebeeb3e99ae
resultstorehttps://source.cloud.google.com/results/invocations/e15ec31c-9211-4d7b-8d81-da88843ae644/targets/test
infra-commita21e59685
job-versionv1.15.6-beta.0.38+7015f71e75f670
podd1a39e20-031a-11ea-b541-aebeeb3e99ae
revisionv1.15.6-beta.0.38+7015f71e75f670

Test Failures


Up 1m35s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.38+7015f71e75f670 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1109 18:01:04.418] process 46 exited with code 0 after 0.0m
I1109 18:01:04.419] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1109 18:01:04.419] Root: /workspace
I1109 18:01:04.419] cd to /workspace
I1109 18:01:04.419] Configure environment...
I1109 18:01:04.420] Call:  git show -s --format=format:%ct HEAD
W1109 18:01:04.424] fatal: not a git repository (or any of the parent directories): .git
I1109 18:01:04.425] process 58 exited with code 128 after 0.0m
W1109 18:01:04.425] Unable to print commit date for HEAD
I1109 18:01:04.426] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1109 18:01:04.998] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1109 18:01:05.383] process 59 exited with code 0 after 0.0m
I1109 18:01:05.384] Call:  gcloud config get-value account
... skipping 425 lines ...
W1109 18:03:12.852] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1109 18:03:12.853] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1109 18:03:12.854] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1109 18:03:12.855] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1109 18:03:12.855] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1109 18:03:12.856] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1109 18:04:03.638] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1109 18:04:03.681] 2019/11/09 18:04:03 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.38+7015f71e75f670 bootstrap-e2e' finished in 51.249446756s
W1109 18:04:05.289] 2019/11/09 18:04:05 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1109 18:04:13.498] 2019/11/09 18:04:13 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.38+7015f71e75f670 bootstrap-e2e: exit status 1
W1109 18:04:13.502] Traceback (most recent call last):
W1109 18:04:13.503]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1109 18:04:13.503]     main(parse_args())
W1109 18:04:13.504]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1109 18:04:13.504]     mode.start(runner_args)
W1109 18:04:13.504]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1109 18:04:13.504]     check_env(env, self.command, *args)
W1109 18:04:13.504]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1109 18:04:13.504]     subprocess.check_call(cmd, env=env)
W1109 18:04:13.505]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1109 18:04:13.505]     raise CalledProcessError(retcode, cmd)
W1109 18:04:13.505] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1109 18:04:13.513] Command failed
I1109 18:04:13.513] process 263 exited with code 1 after 3.1m
E1109 18:04:13.513] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1109 18:04:13.514] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1109 18:04:14.017] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1109 18:04:14.088] process 1380 exited with code 0 after 0.0m
I1109 18:04:14.088] Call:  gcloud config get-value account
I1109 18:04:14.432] process 1392 exited with code 0 after 0.0m
I1109 18:04:14.433] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1109 18:04:14.433] Upload result and artifacts...
I1109 18:04:14.433] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1193226949003055104
I1109 18:04:14.434] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1193226949003055104/artifacts
W1109 18:04:15.362] CommandException: One or more URLs matched no objects.
E1109 18:04:15.496] Command failed
I1109 18:04:15.496] process 1404 exited with code 1 after 0.0m
W1109 18:04:15.496] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1193226949003055104/artifacts not exist yet
I1109 18:04:15.497] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1193226949003055104/artifacts
I1109 18:04:17.138] process 1548 exited with code 0 after 0.0m
I1109 18:04:17.139] Call:  git rev-parse HEAD
W1109 18:04:17.143] fatal: not a git repository (or any of the parent directories): .git
E1109 18:04:17.144] Command failed
I1109 18:04:17.144] process 2074 exited with code 128 after 0.0m
I1109 18:04:17.145] Call:  git rev-parse HEAD
I1109 18:04:17.149] process 2075 exited with code 0 after 0.0m
I1109 18:04:17.150] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1109 18:04:18.143] process 2076 exited with code 0 after 0.0m
I1109 18:04:18.144] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1573279505584970'
... skipping 8 lines ...