This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-09 06:01
Elapsed3m29s
Revision
Buildergke-prow-ssd-pool-1a225945-v0k1
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/5f2a2035-a9e0-49a7-b333-96c62e38c577/targets/test'}}
pod3d2fe6fa-02b6-11ea-b541-aebeeb3e99ae
resultstorehttps://source.cloud.google.com/results/invocations/5f2a2035-a9e0-49a7-b333-96c62e38c577/targets/test
infra-commitcf0351102
job-versionv1.15.6-beta.0.36+bdf7dada072d51
pod3d2fe6fa-02b6-11ea-b541-aebeeb3e99ae
revisionv1.15.6-beta.0.36+bdf7dada072d51

Test Failures


Up 1m29s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.36+bdf7dada072d51 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1109 06:01:36.895] process 45 exited with code 0 after 0.0m
I1109 06:01:36.896] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1109 06:01:36.896] Root: /workspace
I1109 06:01:36.896] cd to /workspace
I1109 06:01:36.896] Configure environment...
I1109 06:01:36.897] Call:  git show -s --format=format:%ct HEAD
W1109 06:01:36.901] fatal: not a git repository (or any of the parent directories): .git
I1109 06:01:36.901] process 57 exited with code 128 after 0.0m
W1109 06:01:36.901] Unable to print commit date for HEAD
I1109 06:01:36.902] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1109 06:01:37.401] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1109 06:01:37.750] process 58 exited with code 0 after 0.0m
I1109 06:01:37.750] Call:  gcloud config get-value account
... skipping 425 lines ...
W1109 06:04:03.630] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1109 06:04:03.631] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1109 06:04:03.632] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1109 06:04:03.632] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1109 06:04:03.633] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1109 06:04:03.633] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1109 06:04:52.560] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1109 06:04:52.622] 2019/11/09 06:04:52 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.36+bdf7dada072d51 bootstrap-e2e' finished in 49.352681458s
W1109 06:04:54.730] 2019/11/09 06:04:54 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1109 06:04:59.640] 2019/11/09 06:04:59 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.36+bdf7dada072d51 bootstrap-e2e: exit status 1
W1109 06:04:59.645] Traceback (most recent call last):
W1109 06:04:59.645]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1109 06:04:59.646]     main(parse_args())
W1109 06:04:59.646]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1109 06:04:59.646]     mode.start(runner_args)
W1109 06:04:59.646]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1109 06:04:59.646]     check_env(env, self.command, *args)
W1109 06:04:59.646]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1109 06:04:59.647]     subprocess.check_call(cmd, env=env)
W1109 06:04:59.647]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1109 06:04:59.647]     raise CalledProcessError(retcode, cmd)
W1109 06:04:59.648] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1109 06:04:59.656] Command failed
I1109 06:04:59.656] process 262 exited with code 1 after 3.3m
E1109 06:04:59.657] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1109 06:04:59.657] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1109 06:05:00.117] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1109 06:05:00.168] process 1377 exited with code 0 after 0.0m
I1109 06:05:00.168] Call:  gcloud config get-value account
I1109 06:05:00.467] process 1389 exited with code 0 after 0.0m
I1109 06:05:00.468] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1109 06:05:00.468] Upload result and artifacts...
I1109 06:05:00.468] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1193045878680588296
I1109 06:05:00.469] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1193045878680588296/artifacts
W1109 06:05:01.234] CommandException: One or more URLs matched no objects.
E1109 06:05:01.373] Command failed
I1109 06:05:01.373] process 1401 exited with code 1 after 0.0m
W1109 06:05:01.373] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1193045878680588296/artifacts not exist yet
I1109 06:05:01.374] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1193045878680588296/artifacts
I1109 06:05:02.843] process 1545 exited with code 0 after 0.0m
I1109 06:05:02.844] Call:  git rev-parse HEAD
W1109 06:05:02.848] fatal: not a git repository (or any of the parent directories): .git
E1109 06:05:02.848] Command failed
I1109 06:05:02.849] process 2071 exited with code 128 after 0.0m
I1109 06:05:02.849] Call:  git rev-parse HEAD
I1109 06:05:02.852] process 2072 exited with code 0 after 0.0m
I1109 06:05:02.853] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1109 06:05:03.681] process 2073 exited with code 0 after 0.0m
I1109 06:05:03.682] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1573236314390515'
... skipping 8 lines ...