This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-08 06:00
Elapsed3m52s
Revision
Buildergke-prow-ssd-pool-1a225945-nj5q
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/890a504b-2f68-48fa-973d-83c508a6e776/targets/test'}}
pod0b1d76d1-01ed-11ea-952f-2277ac613adf
resultstorehttps://source.cloud.google.com/results/invocations/890a504b-2f68-48fa-973d-83c508a6e776/targets/test
infra-commite59fdbe22
job-versionv1.15.6-beta.0.24+5be4fd3795b520
pod0b1d76d1-01ed-11ea-952f-2277ac613adf
revisionv1.15.6-beta.0.24+5be4fd3795b520

Test Failures


Up 1m51s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.24+5be4fd3795b520 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1108 06:00:57.066] process 45 exited with code 0 after 0.0m
I1108 06:00:57.067] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1108 06:00:57.067] Root: /workspace
I1108 06:00:57.067] cd to /workspace
I1108 06:00:57.067] Configure environment...
I1108 06:00:57.068] Call:  git show -s --format=format:%ct HEAD
W1108 06:00:57.071] fatal: not a git repository (or any of the parent directories): .git
I1108 06:00:57.072] process 57 exited with code 128 after 0.0m
W1108 06:00:57.072] Unable to print commit date for HEAD
I1108 06:00:57.072] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1108 06:00:57.591] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1108 06:00:57.933] process 58 exited with code 0 after 0.0m
I1108 06:00:57.933] Call:  gcloud config get-value account
... skipping 425 lines ...
W1108 06:03:45.310] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1108 06:03:45.311] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1108 06:03:45.312] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1108 06:03:45.312] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1108 06:03:45.313] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1108 06:03:45.313] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1108 06:04:36.017] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1108 06:04:36.063] 2019/11/08 06:04:36 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.24+5be4fd3795b520 bootstrap-e2e' finished in 51.135632307s
W1108 06:04:37.608] 2019/11/08 06:04:37 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1108 06:04:41.205] 2019/11/08 06:04:41 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.24+5be4fd3795b520 bootstrap-e2e: exit status 1
W1108 06:04:41.205] Traceback (most recent call last):
W1108 06:04:41.205]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1108 06:04:41.206]     main(parse_args())
W1108 06:04:41.206]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1108 06:04:41.206]     mode.start(runner_args)
W1108 06:04:41.206]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1108 06:04:41.206]     check_env(env, self.command, *args)
W1108 06:04:41.206]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1108 06:04:41.207]     subprocess.check_call(cmd, env=env)
W1108 06:04:41.207]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1108 06:04:41.207]     raise CalledProcessError(retcode, cmd)
W1108 06:04:41.208] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1108 06:04:41.215] Command failed
I1108 06:04:41.216] process 262 exited with code 1 after 3.7m
E1108 06:04:41.216] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1108 06:04:41.216] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1108 06:04:41.748] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1108 06:04:41.813] process 1380 exited with code 0 after 0.0m
I1108 06:04:41.813] Call:  gcloud config get-value account
I1108 06:04:42.124] process 1392 exited with code 0 after 0.0m
I1108 06:04:42.125] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1108 06:04:42.125] Upload result and artifacts...
I1108 06:04:42.125] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1192683335940313092
I1108 06:04:42.125] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1192683335940313092/artifacts
W1108 06:04:43.000] CommandException: One or more URLs matched no objects.
E1108 06:04:43.134] Command failed
I1108 06:04:43.135] process 1404 exited with code 1 after 0.0m
W1108 06:04:43.135] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1192683335940313092/artifacts not exist yet
I1108 06:04:43.135] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1192683335940313092/artifacts
I1108 06:04:44.668] process 1548 exited with code 0 after 0.0m
I1108 06:04:44.669] Call:  git rev-parse HEAD
W1108 06:04:44.672] fatal: not a git repository (or any of the parent directories): .git
E1108 06:04:44.673] Command failed
I1108 06:04:44.673] process 2074 exited with code 128 after 0.0m
I1108 06:04:44.673] Call:  git rev-parse HEAD
I1108 06:04:44.677] process 2075 exited with code 0 after 0.0m
I1108 06:04:44.678] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1108 06:04:45.593] process 2076 exited with code 0 after 0.0m
I1108 06:04:45.594] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1573150594803764'
... skipping 8 lines ...