This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-07 06:00
Elapsed3m15s
Revision
Buildergke-prow-ssd-pool-1a225945-9tvq
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/d9f29ad1-acf8-4585-85fd-28d996d55748/targets/test'}}
poddfc8b19f-0123-11ea-952f-2277ac613adf
resultstorehttps://source.cloud.google.com/results/invocations/d9f29ad1-acf8-4585-85fd-28d996d55748/targets/test
infra-commit34a664162
job-versionv1.15.6-beta.0.20+0869af612b9fd8
poddfc8b19f-0123-11ea-952f-2277ac613adf
revisionv1.15.6-beta.0.20+0869af612b9fd8

Test Failures


Up 1m36s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.20+0869af612b9fd8 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1107 06:00:53.487] process 45 exited with code 0 after 0.0m
I1107 06:00:53.487] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1107 06:00:53.487] Root: /workspace
I1107 06:00:53.488] cd to /workspace
I1107 06:00:53.488] Configure environment...
I1107 06:00:53.488] Call:  git show -s --format=format:%ct HEAD
W1107 06:00:53.492] fatal: not a git repository (or any of the parent directories): .git
I1107 06:00:53.492] process 57 exited with code 128 after 0.0m
W1107 06:00:53.493] Unable to print commit date for HEAD
I1107 06:00:53.493] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1107 06:00:54.004] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1107 06:00:54.314] process 58 exited with code 0 after 0.0m
I1107 06:00:54.314] Call:  gcloud config get-value account
... skipping 425 lines ...
W1107 06:03:11.175] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1107 06:03:11.176] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W1107 06:03:11.177] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1107 06:03:11.177] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1107 06:03:11.178] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1107 06:03:11.178] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1107 06:03:57.197] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1107 06:03:57.237] 2019/11/07 06:03:57 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.20+0869af612b9fd8 bootstrap-e2e' finished in 46.440200439s
W1107 06:03:58.681] 2019/11/07 06:03:58 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1107 06:04:00.510] 2019/11/07 06:04:00 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.20+0869af612b9fd8 bootstrap-e2e: exit status 1
W1107 06:04:00.513] Traceback (most recent call last):
W1107 06:04:00.513]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1107 06:04:00.514]     main(parse_args())
W1107 06:04:00.514]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1107 06:04:00.514]     mode.start(runner_args)
W1107 06:04:00.514]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1107 06:04:00.514]     check_env(env, self.command, *args)
W1107 06:04:00.514]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1107 06:04:00.514]     subprocess.check_call(cmd, env=env)
W1107 06:04:00.514]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1107 06:04:00.514]     raise CalledProcessError(retcode, cmd)
W1107 06:04:00.515] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1107 06:04:00.520] Command failed
I1107 06:04:00.520] process 262 exited with code 1 after 3.1m
E1107 06:04:00.521] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1107 06:04:00.521] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1107 06:04:00.971] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1107 06:04:01.018] process 1380 exited with code 0 after 0.0m
I1107 06:04:01.018] Call:  gcloud config get-value account
I1107 06:04:01.291] process 1392 exited with code 0 after 0.0m
I1107 06:04:01.292] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1107 06:04:01.292] Upload result and artifacts...
I1107 06:04:01.292] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1192320942936690693
I1107 06:04:01.293] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1192320942936690693/artifacts
W1107 06:04:02.074] CommandException: One or more URLs matched no objects.
E1107 06:04:02.181] Command failed
I1107 06:04:02.181] process 1404 exited with code 1 after 0.0m
W1107 06:04:02.182] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1192320942936690693/artifacts not exist yet
I1107 06:04:02.182] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1192320942936690693/artifacts
I1107 06:04:03.652] process 1548 exited with code 0 after 0.0m
I1107 06:04:03.653] Call:  git rev-parse HEAD
W1107 06:04:03.657] fatal: not a git repository (or any of the parent directories): .git
E1107 06:04:03.657] Command failed
I1107 06:04:03.658] process 2074 exited with code 128 after 0.0m
I1107 06:04:03.658] Call:  git rev-parse HEAD
I1107 06:04:03.662] process 2075 exited with code 0 after 0.0m
I1107 06:04:03.662] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1107 06:04:04.560] process 2076 exited with code 0 after 0.0m
I1107 06:04:04.561] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1573063587204541'
... skipping 8 lines ...