This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-06 18:01
Elapsed4m33s
Revision
Buildergke-prow-ssd-pool-1a225945-zhlt
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/9c89b6de-e0a9-4001-a547-dceaeeeb6e25/targets/test'}}
pod6014e1e6-00bf-11ea-af2d-5ea7e3f64282
resultstorehttps://source.cloud.google.com/results/invocations/9c89b6de-e0a9-4001-a547-dceaeeeb6e25/targets/test
infra-commite9d26d734
job-versionv1.15.6-beta.0.18+a1260f0d539c3b
pod6014e1e6-00bf-11ea-af2d-5ea7e3f64282
revisionv1.15.6-beta.0.18+a1260f0d539c3b

Test Failures


Up 1m36s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.18+a1260f0d539c3b bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1106 18:01:56.211] process 45 exited with code 0 after 0.0m
I1106 18:01:56.212] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1106 18:01:56.213] Root: /workspace
I1106 18:01:56.213] cd to /workspace
I1106 18:01:56.213] Configure environment...
I1106 18:01:56.214] Call:  git show -s --format=format:%ct HEAD
W1106 18:01:56.220] fatal: not a git repository (or any of the parent directories): .git
I1106 18:01:56.221] process 57 exited with code 128 after 0.0m
W1106 18:01:56.221] Unable to print commit date for HEAD
I1106 18:01:56.221] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1106 18:01:56.953] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1106 18:01:57.325] process 58 exited with code 0 after 0.0m
I1106 18:01:57.326] Call:  gcloud config get-value account
... skipping 425 lines ...
W1106 18:05:09.100] WARNING: In November 2019, node auto-upgrade will be enabled by default for newly created clusters and node pools. To disable it, use the `--no-enable-autoupgrade` flag.
W1106 18:05:09.110] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1106 18:05:09.113] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1106 18:05:09.116] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1106 18:05:09.116] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1106 18:05:09.117] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1106 18:05:55.338] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1106 18:05:55.494] 2019/11/06 18:05:55 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.18+a1260f0d539c3b bootstrap-e2e' finished in 47.422530365s
W1106 18:05:58.889] 2019/11/06 18:05:58 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1106 18:06:05.540] 2019/11/06 18:06:05 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.18+a1260f0d539c3b bootstrap-e2e: exit status 1
W1106 18:06:05.547] Traceback (most recent call last):
W1106 18:06:05.549]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1106 18:06:05.588]     main(parse_args())
W1106 18:06:05.588]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1106 18:06:05.588]     mode.start(runner_args)
W1106 18:06:05.589]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1106 18:06:05.590]     check_env(env, self.command, *args)
W1106 18:06:05.590]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1106 18:06:05.590]     subprocess.check_call(cmd, env=env)
W1106 18:06:05.591]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1106 18:06:05.591]     raise CalledProcessError(retcode, cmd)
W1106 18:06:05.601] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1106 18:06:05.623] Command failed
I1106 18:06:05.623] process 262 exited with code 1 after 4.1m
E1106 18:06:05.624] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1106 18:06:05.626] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1106 18:06:06.969] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1106 18:06:07.115] process 1356 exited with code 0 after 0.0m
I1106 18:06:07.116] Call:  gcloud config get-value account
I1106 18:06:07.996] process 1368 exited with code 0 after 0.0m
I1106 18:06:07.996] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1106 18:06:07.997] Upload result and artifacts...
I1106 18:06:08.000] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1192139933637152768
I1106 18:06:08.001] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1192139933637152768/artifacts
W1106 18:06:11.537] CommandException: One or more URLs matched no objects.
E1106 18:06:11.824] Command failed
I1106 18:06:11.826] process 1380 exited with code 1 after 0.1m
W1106 18:06:11.826] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1192139933637152768/artifacts not exist yet
I1106 18:06:11.826] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1192139933637152768/artifacts
I1106 18:06:17.479] process 1524 exited with code 0 after 0.1m
I1106 18:06:17.480] Call:  git rev-parse HEAD
W1106 18:06:17.491] fatal: not a git repository (or any of the parent directories): .git
E1106 18:06:17.492] Command failed
I1106 18:06:17.493] process 2050 exited with code 128 after 0.0m
I1106 18:06:17.493] Call:  git rev-parse HEAD
I1106 18:06:17.518] process 2051 exited with code 0 after 0.0m
I1106 18:06:17.522] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1106 18:06:20.640] process 2052 exited with code 0 after 0.1m
I1106 18:06:20.645] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1573020261991649'
... skipping 8 lines ...