This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-06 06:01
Elapsed3m7s
Revision
Buildergke-prow-ssd-pool-1a225945-d46v
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/26ae0290-1bb2-444b-b553-1ce7982592ff/targets/test'}}
podb938e58e-005a-11ea-bc86-06aa44a5a987
resultstorehttps://source.cloud.google.com/results/invocations/26ae0290-1bb2-444b-b553-1ce7982592ff/targets/test
infra-commit09649c747
job-versionv1.15.6-beta.0.18+a1260f0d539c3b
podb938e58e-005a-11ea-bc86-06aa44a5a987
revisionv1.15.6-beta.0.18+a1260f0d539c3b

Test Failures


Up 1m33s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.18+a1260f0d539c3b bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1106 06:01:15.979] process 45 exited with code 0 after 0.0m
I1106 06:01:15.980] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1106 06:01:15.980] Root: /workspace
I1106 06:01:15.980] cd to /workspace
I1106 06:01:15.980] Configure environment...
I1106 06:01:15.981] Call:  git show -s --format=format:%ct HEAD
W1106 06:01:15.984] fatal: not a git repository (or any of the parent directories): .git
I1106 06:01:15.984] process 57 exited with code 128 after 0.0m
W1106 06:01:15.984] Unable to print commit date for HEAD
I1106 06:01:15.985] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1106 06:01:16.489] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1106 06:01:16.641] process 58 exited with code 0 after 0.0m
I1106 06:01:16.641] Call:  gcloud config get-value account
... skipping 425 lines ...
W1106 06:03:17.611] WARNING: In November 2019, node auto-upgrade will be enabled by default for newly created clusters and node pools. To disable it, use the `--no-enable-autoupgrade` flag.
W1106 06:03:17.612] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1106 06:03:17.612] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1106 06:03:17.613] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1106 06:03:17.613] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1106 06:03:17.614] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1106 06:04:10.693] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1106 06:04:10.731] 2019/11/06 06:04:10 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.18+a1260f0d539c3b bootstrap-e2e' finished in 53.485638544s
W1106 06:04:12.081] 2019/11/06 06:04:12 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1106 06:04:16.061] 2019/11/06 06:04:16 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.18+a1260f0d539c3b bootstrap-e2e: exit status 1
W1106 06:04:16.063] Traceback (most recent call last):
W1106 06:04:16.063]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1106 06:04:16.063]     main(parse_args())
W1106 06:04:16.064]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1106 06:04:16.064]     mode.start(runner_args)
W1106 06:04:16.064]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1106 06:04:16.064]     check_env(env, self.command, *args)
W1106 06:04:16.064]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1106 06:04:16.064]     subprocess.check_call(cmd, env=env)
W1106 06:04:16.064]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1106 06:04:16.065]     raise CalledProcessError(retcode, cmd)
W1106 06:04:16.065] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1106 06:04:16.071] Command failed
I1106 06:04:16.071] process 262 exited with code 1 after 3.0m
E1106 06:04:16.071] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1106 06:04:16.072] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1106 06:04:16.568] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1106 06:04:16.622] process 1359 exited with code 0 after 0.0m
I1106 06:04:16.622] Call:  gcloud config get-value account
I1106 06:04:16.911] process 1371 exited with code 0 after 0.0m
I1106 06:04:16.911] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1106 06:04:16.911] Upload result and artifacts...
I1106 06:04:16.911] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1191958648927031296
I1106 06:04:16.912] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1191958648927031296/artifacts
W1106 06:04:17.792] CommandException: One or more URLs matched no objects.
E1106 06:04:17.894] Command failed
I1106 06:04:17.894] process 1383 exited with code 1 after 0.0m
W1106 06:04:17.895] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1191958648927031296/artifacts not exist yet
I1106 06:04:17.895] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1191958648927031296/artifacts
I1106 06:04:19.369] process 1527 exited with code 0 after 0.0m
I1106 06:04:19.370] Call:  git rev-parse HEAD
W1106 06:04:19.373] fatal: not a git repository (or any of the parent directories): .git
E1106 06:04:19.373] Command failed
I1106 06:04:19.374] process 2053 exited with code 128 after 0.0m
I1106 06:04:19.374] Call:  git rev-parse HEAD
I1106 06:04:19.377] process 2054 exited with code 0 after 0.0m
I1106 06:04:19.378] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1106 06:04:20.217] process 2055 exited with code 0 after 0.0m
I1106 06:04:20.217] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1572977134722927'
... skipping 8 lines ...