This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-05 06:00
Elapsed3m16s
Revision
Buildergke-prow-ssd-pool-1a225945-v2fg
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/f7c0e89a-4399-42c8-a3bd-5a5c158d9c37/targets/test'}}
pod8c4c3239-ff91-11e9-bda4-f2679650cd82
resultstorehttps://source.cloud.google.com/results/invocations/f7c0e89a-4399-42c8-a3bd-5a5c158d9c37/targets/test
infra-commite60677a2e
job-versionv1.15.6-beta.0.16+670c7810991876
pod8c4c3239-ff91-11e9-bda4-f2679650cd82
revisionv1.15.6-beta.0.16+670c7810991876

Test Failures


Up 1m37s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.16+670c7810991876 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1105 06:00:52.511] process 45 exited with code 0 after 0.0m
I1105 06:00:52.511] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1105 06:00:52.511] Root: /workspace
I1105 06:00:52.512] cd to /workspace
I1105 06:00:52.512] Configure environment...
I1105 06:00:52.512] Call:  git show -s --format=format:%ct HEAD
W1105 06:00:52.516] fatal: not a git repository (or any of the parent directories): .git
I1105 06:00:52.517] process 57 exited with code 128 after 0.0m
W1105 06:00:52.518] Unable to print commit date for HEAD
I1105 06:00:52.518] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1105 06:00:53.022] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1105 06:00:53.394] process 58 exited with code 0 after 0.0m
I1105 06:00:53.394] Call:  gcloud config get-value account
... skipping 425 lines ...
W1105 06:03:05.214] WARNING: In November 2019, node auto-upgrade will be enabled by default for newly created clusters and node pools. To disable it, use the `--no-enable-autoupgrade` flag.
W1105 06:03:05.216] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1105 06:03:05.218] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1105 06:03:05.219] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1105 06:03:05.221] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1105 06:03:05.222] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1105 06:03:56.196] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1105 06:03:56.252] 2019/11/05 06:03:56 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.16+670c7810991876 bootstrap-e2e' finished in 51.983393114s
W1105 06:03:57.836] 2019/11/05 06:03:57 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1105 06:03:59.916] 2019/11/05 06:03:59 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.15.6-beta.0.16+670c7810991876 bootstrap-e2e: exit status 1
W1105 06:03:59.919] Traceback (most recent call last):
W1105 06:03:59.920]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1105 06:03:59.920]     main(parse_args())
W1105 06:03:59.921]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1105 06:03:59.921]     mode.start(runner_args)
W1105 06:03:59.921]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1105 06:03:59.921]     check_env(env, self.command, *args)
W1105 06:03:59.922]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1105 06:03:59.922]     subprocess.check_call(cmd, env=env)
W1105 06:03:59.922]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1105 06:03:59.922]     raise CalledProcessError(retcode, cmd)
W1105 06:03:59.923] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1105 06:03:59.930] Command failed
I1105 06:03:59.930] process 262 exited with code 1 after 3.1m
E1105 06:03:59.930] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1105 06:03:59.931] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1105 06:04:00.415] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1105 06:04:00.461] process 1358 exited with code 0 after 0.0m
I1105 06:04:00.461] Call:  gcloud config get-value account
I1105 06:04:00.808] process 1370 exited with code 0 after 0.0m
I1105 06:04:00.809] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1105 06:04:00.809] Upload result and artifacts...
I1105 06:04:00.810] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1191596160293277697
I1105 06:04:00.810] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1191596160293277697/artifacts
W1105 06:04:01.716] CommandException: One or more URLs matched no objects.
E1105 06:04:01.829] Command failed
I1105 06:04:01.829] process 1382 exited with code 1 after 0.0m
W1105 06:04:01.829] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1191596160293277697/artifacts not exist yet
I1105 06:04:01.829] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1191596160293277697/artifacts
I1105 06:04:03.648] process 1526 exited with code 0 after 0.0m
I1105 06:04:03.648] Call:  git rev-parse HEAD
W1105 06:04:03.653] fatal: not a git repository (or any of the parent directories): .git
E1105 06:04:03.653] Command failed
I1105 06:04:03.653] process 2052 exited with code 128 after 0.0m
I1105 06:04:03.653] Call:  git rev-parse HEAD
I1105 06:04:03.658] process 2053 exited with code 0 after 0.0m
I1105 06:04:03.658] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1105 06:04:04.758] process 2054 exited with code 0 after 0.0m
I1105 06:04:04.759] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1572890751875503'
... skipping 8 lines ...