This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-04 18:01
Elapsed4m26s
Revision
Buildergke-prow-ssd-pool-1a225945-ftg2
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/cc662355-b968-4d31-bbdb-160b989ae56e/targets/test'}}
pod005b19b7-ff2d-11e9-8148-626a363727ef
resultstorehttps://source.cloud.google.com/results/invocations/cc662355-b968-4d31-bbdb-160b989ae56e/targets/test
infra-commite7d5b8453
job-versionv1.14.9-beta.0.16+c99bc0cf528166
pod005b19b7-ff2d-11e9-8148-626a363727ef
revisionv1.14.9-beta.0.16+c99bc0cf528166

Test Failures


Up 1m22s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.14.9-beta.0.16+c99bc0cf528166 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1104 18:01:27.644] process 45 exited with code 0 after 0.0m
I1104 18:01:27.645] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1104 18:01:27.645] Root: /workspace
I1104 18:01:27.645] cd to /workspace
I1104 18:01:27.646] Configure environment...
I1104 18:01:27.646] Call:  git show -s --format=format:%ct HEAD
W1104 18:01:27.655] fatal: not a git repository (or any of the parent directories): .git
I1104 18:01:27.656] process 57 exited with code 128 after 0.0m
W1104 18:01:27.657] Unable to print commit date for HEAD
I1104 18:01:27.657] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1104 18:01:29.361] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1104 18:01:29.777] process 58 exited with code 0 after 0.0m
I1104 18:01:29.778] Call:  gcloud config get-value account
... skipping 425 lines ...
W1104 18:04:44.130] WARNING: In November 2019, node auto-upgrade will be enabled by default for newly created clusters and node pools. To disable it, use the `--no-enable-autoupgrade` flag.
W1104 18:04:44.131] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1104 18:04:44.131] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1104 18:04:44.131] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1104 18:04:44.132] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1104 18:04:44.132] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1104 18:05:28.602] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1104 18:05:28.693] 2019/11/04 18:05:28 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.14.9-beta.0.16+c99bc0cf528166 bootstrap-e2e' finished in 45.474076635s
W1104 18:05:31.448] 2019/11/04 18:05:31 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1104 18:05:40.868] 2019/11/04 18:05:40 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.14.9-beta.0.16+c99bc0cf528166 bootstrap-e2e: exit status 1
W1104 18:05:40.870] Traceback (most recent call last):
W1104 18:05:40.870]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1104 18:05:40.873]     main(parse_args())
W1104 18:05:40.888]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1104 18:05:40.888]     mode.start(runner_args)
W1104 18:05:40.889]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1104 18:05:40.890]     check_env(env, self.command, *args)
W1104 18:05:40.890]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1104 18:05:40.890]     subprocess.check_call(cmd, env=env)
W1104 18:05:40.891]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1104 18:05:40.891]     raise CalledProcessError(retcode, cmd)
W1104 18:05:40.893] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1104 18:05:40.900] Command failed
I1104 18:05:40.900] process 262 exited with code 1 after 4.1m
E1104 18:05:40.900] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1104 18:05:40.901] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1104 18:05:42.022] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1104 18:05:42.099] process 1356 exited with code 0 after 0.0m
I1104 18:05:42.099] Call:  gcloud config get-value account
I1104 18:05:42.657] process 1368 exited with code 0 after 0.0m
I1104 18:05:42.658] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1104 18:05:42.658] Upload result and artifacts...
I1104 18:05:42.658] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1191415042923302915
I1104 18:05:42.658] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1191415042923302915/artifacts
W1104 18:05:44.057] CommandException: One or more URLs matched no objects.
E1104 18:05:44.260] Command failed
I1104 18:05:44.261] process 1380 exited with code 1 after 0.0m
W1104 18:05:44.261] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1191415042923302915/artifacts not exist yet
I1104 18:05:44.261] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1191415042923302915/artifacts
I1104 18:05:46.637] process 1524 exited with code 0 after 0.0m
I1104 18:05:46.639] Call:  git rev-parse HEAD
W1104 18:05:46.645] fatal: not a git repository (or any of the parent directories): .git
E1104 18:05:46.645] Command failed
I1104 18:05:46.646] process 2050 exited with code 128 after 0.0m
I1104 18:05:46.646] Call:  git rev-parse HEAD
I1104 18:05:46.656] process 2051 exited with code 0 after 0.0m
I1104 18:05:46.657] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1104 18:05:48.111] process 2052 exited with code 0 after 0.0m
I1104 18:05:48.113] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1572847485966137'
... skipping 8 lines ...