This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-11-04 06:01
Elapsed3m42s
Revision
Buildergke-prow-ssd-pool-1a225945-n47b
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/3c137af3-4700-4f22-83d8-51bd252b71e5/targets/test'}}
pod6aa3d056-fec8-11e9-8148-626a363727ef
resultstorehttps://source.cloud.google.com/results/invocations/3c137af3-4700-4f22-83d8-51bd252b71e5/targets/test
infra-commitf3e9c96ab
job-versionv1.14.9-beta.0.16+c99bc0cf528166
pod6aa3d056-fec8-11e9-8148-626a363727ef
revisionv1.14.9-beta.0.16+c99bc0cf528166

Test Failures


Up 1m47s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.14.9-beta.0.16+c99bc0cf528166 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I1104 06:01:05.507] process 45 exited with code 0 after 0.0m
I1104 06:01:05.507] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1104 06:01:05.508] Root: /workspace
I1104 06:01:05.508] cd to /workspace
I1104 06:01:05.508] Configure environment...
I1104 06:01:05.509] Call:  git show -s --format=format:%ct HEAD
W1104 06:01:05.514] fatal: not a git repository (or any of the parent directories): .git
I1104 06:01:05.515] process 57 exited with code 128 after 0.0m
W1104 06:01:05.515] Unable to print commit date for HEAD
I1104 06:01:05.516] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1104 06:01:06.095] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1104 06:01:06.450] process 58 exited with code 0 after 0.0m
I1104 06:01:06.451] Call:  gcloud config get-value account
... skipping 425 lines ...
W1104 06:03:40.803] WARNING: In November 2019, node auto-upgrade will be enabled by default for newly created clusters and node pools. To disable it, use the `--no-enable-autoupgrade` flag.
W1104 06:03:40.803] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W1104 06:03:40.804] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W1104 06:03:40.805] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W1104 06:03:40.805] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W1104 06:03:40.806] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W1104 06:04:31.623] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W1104 06:04:31.689] 2019/11/04 06:04:31 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.14.9-beta.0.16+c99bc0cf528166 bootstrap-e2e' finished in 51.346759213s
W1104 06:04:33.411] 2019/11/04 06:04:33 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W1104 06:04:38.376] 2019/11/04 06:04:38 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.14.9-beta.0.16+c99bc0cf528166 bootstrap-e2e: exit status 1
W1104 06:04:38.379] Traceback (most recent call last):
W1104 06:04:38.380]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W1104 06:04:38.380]     main(parse_args())
W1104 06:04:38.380]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W1104 06:04:38.380]     mode.start(runner_args)
W1104 06:04:38.380]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W1104 06:04:38.380]     check_env(env, self.command, *args)
W1104 06:04:38.380]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W1104 06:04:38.380]     subprocess.check_call(cmd, env=env)
W1104 06:04:38.381]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W1104 06:04:38.381]     raise CalledProcessError(retcode, cmd)
W1104 06:04:38.381] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E1104 06:04:38.394] Command failed
I1104 06:04:38.394] process 262 exited with code 1 after 3.5m
E1104 06:04:38.395] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I1104 06:04:38.395] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W1104 06:04:38.991] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I1104 06:04:39.052] process 1357 exited with code 0 after 0.0m
I1104 06:04:39.053] Call:  gcloud config get-value account
I1104 06:04:39.439] process 1369 exited with code 0 after 0.0m
I1104 06:04:39.439] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I1104 06:04:39.439] Upload result and artifacts...
I1104 06:04:39.440] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1191233814567849992
I1104 06:04:39.440] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1191233814567849992/artifacts
W1104 06:04:40.464] CommandException: One or more URLs matched no objects.
E1104 06:04:40.636] Command failed
I1104 06:04:40.636] process 1381 exited with code 1 after 0.0m
W1104 06:04:40.636] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1191233814567849992/artifacts not exist yet
I1104 06:04:40.636] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1191233814567849992/artifacts
I1104 06:04:42.443] process 1525 exited with code 0 after 0.0m
I1104 06:04:42.444] Call:  git rev-parse HEAD
W1104 06:04:42.450] fatal: not a git repository (or any of the parent directories): .git
E1104 06:04:42.451] Command failed
I1104 06:04:42.451] process 2051 exited with code 128 after 0.0m
I1104 06:04:42.451] Call:  git rev-parse HEAD
I1104 06:04:42.457] process 2052 exited with code 0 after 0.0m
I1104 06:04:42.458] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I1104 06:04:43.530] process 2053 exited with code 0 after 0.0m
I1104 06:04:43.532] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1572804273079577'
... skipping 8 lines ...