This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-07-21 18:00
Elapsed3m58s
Revision
Buildergke-prow-ssd-pool-1a225945-cx5g
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/94326a53-dc02-47e3-b5c9-bc588d79b507/targets/test'}}
pod5d4ff493-abe1-11e9-b82b-365474bd0c86
resultstorehttps://source.cloud.google.com/results/invocations/94326a53-dc02-47e3-b5c9-bc588d79b507/targets/test
infra-commit6d769e14d
job-versionv1.13.9-beta.0.1+e1be42a61576dc
pod5d4ff493-abe1-11e9-b82b-365474bd0c86
revisionv1.13.9-beta.0.1+e1be42a61576dc

Test Failures


Up 59s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.13.9-beta.0.1+e1be42a61576dc bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 12 lines ...
I0721 18:00:35.100] process 44 exited with code 0 after 0.0m
I0721 18:00:35.101] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0721 18:00:35.101] Root: /workspace
I0721 18:00:35.101] cd to /workspace
I0721 18:00:35.102] Configure environment...
I0721 18:00:35.102] Call:  git show -s --format=format:%ct HEAD
W0721 18:00:35.106] fatal: Not a git repository (or any of the parent directories): .git
I0721 18:00:35.107] process 56 exited with code 128 after 0.0m
W0721 18:00:35.107] Unable to print commit date for HEAD
I0721 18:00:35.108] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0721 18:00:35.658] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0721 18:00:36.040] process 57 exited with code 0 after 0.0m
I0721 18:00:36.041] Call:  gcloud config get-value account
... skipping 412 lines ...
W0721 18:04:04.274] WARNING: Starting in 1.12, new clusters will have basic authentication disabled by default. Basic authentication can be enabled (or disabled) manually using the `--[no-]enable-basic-auth` flag.
W0721 18:04:04.274] WARNING: Starting in 1.12, new clusters will not have a client certificate issued. You can manually enable (or disable) the issuance of the client certificate using the `--[no-]issue-client-certificate` flag.
W0721 18:04:04.276] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0721 18:04:04.276] WARNING: The Pod address range limits the maximum size of the cluster. Please refer to https://cloud.google.com/kubernetes-engine/docs/how-to/flexible-pod-cidr to learn how to optimize IP address allocation.
W0721 18:04:04.277] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0721 18:04:04.277] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0721 18:04:08.678] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=The required node image is not available.
W0721 18:04:08.739] 2019/07/21 18:04:08 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.13.9-beta.0.1+e1be42a61576dc bootstrap-e2e' finished in 4.882660267s
W0721 18:04:10.312] 2019/07/21 18:04:10 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0721 18:04:24.068] 2019/07/21 18:04:24 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.13.9-beta.0.1+e1be42a61576dc bootstrap-e2e: exit status 1
W0721 18:04:24.072] Traceback (most recent call last):
W0721 18:04:24.072]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0721 18:04:24.072]     main(parse_args())
W0721 18:04:24.072]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0721 18:04:24.072]     mode.start(runner_args)
W0721 18:04:24.072]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0721 18:04:24.072]     check_env(env, self.command, *args)
W0721 18:04:24.073]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0721 18:04:24.073]     subprocess.check_call(cmd, env=env)
W0721 18:04:24.073]   File "/usr/lib/python2.7/subprocess.py", line 186, in check_call
W0721 18:04:24.073]     raise CalledProcessError(retcode, cmd)
W0721 18:04:24.073] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0721 18:04:24.083] Command failed
I0721 18:04:24.083] process 259 exited with code 1 after 3.8m
E0721 18:04:24.083] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I0721 18:04:24.084] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0721 18:04:24.602] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0721 18:04:24.663] process 1380 exited with code 0 after 0.0m
I0721 18:04:24.664] Call:  gcloud config get-value account
I0721 18:04:25.013] process 1392 exited with code 0 after 0.0m
I0721 18:04:25.013] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0721 18:04:25.014] Upload result and artifacts...
I0721 18:04:25.014] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1153001777621110786
I0721 18:04:25.014] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1153001777621110786/artifacts
W0721 18:04:26.074] CommandException: One or more URLs matched no objects.
E0721 18:04:26.216] Command failed
I0721 18:04:26.217] process 1404 exited with code 1 after 0.0m
W0721 18:04:26.217] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1153001777621110786/artifacts not exist yet
I0721 18:04:26.217] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1153001777621110786/artifacts
I0721 18:04:28.022] process 1546 exited with code 0 after 0.0m
I0721 18:04:28.023] Call:  git rev-parse HEAD
W0721 18:04:28.027] fatal: Not a git repository (or any of the parent directories): .git
E0721 18:04:28.028] Command failed
I0721 18:04:28.028] process 2070 exited with code 128 after 0.0m
I0721 18:04:28.028] Call:  git rev-parse HEAD
I0721 18:04:28.034] process 2071 exited with code 0 after 0.0m
I0721 18:04:28.035] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I0721 18:04:29.267] process 2072 exited with code 0 after 0.0m
I0721 18:04:29.268] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1563689089079285'
... skipping 8 lines ...