This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-07-21 06:00
Elapsed4m16s
Revision
Buildergke-prow-ssd-pool-1a225945-9x2b
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/df5f37c5-f0e4-4207-beda-fcf25b68c14d/targets/test'}}
podc8652434-ab7c-11e9-b82b-365474bd0c86
resultstorehttps://source.cloud.google.com/results/invocations/df5f37c5-f0e4-4207-beda-fcf25b68c14d/targets/test
infra-commit6d769e14d
job-versionv1.13.9-beta.0.1+e1be42a61576dc
podc8652434-ab7c-11e9-b82b-365474bd0c86
revisionv1.13.9-beta.0.1+e1be42a61576dc

Test Failures


Up 56s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.13.9-beta.0.1+e1be42a61576dc bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 12 lines ...
I0721 06:00:34.195] process 44 exited with code 0 after 0.0m
I0721 06:00:34.196] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0721 06:00:34.196] Root: /workspace
I0721 06:00:34.196] cd to /workspace
I0721 06:00:34.196] Configure environment...
I0721 06:00:34.197] Call:  git show -s --format=format:%ct HEAD
W0721 06:00:34.202] fatal: Not a git repository (or any of the parent directories): .git
I0721 06:00:34.203] process 56 exited with code 128 after 0.0m
W0721 06:00:34.203] Unable to print commit date for HEAD
I0721 06:00:34.204] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0721 06:00:34.788] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0721 06:00:35.140] process 57 exited with code 0 after 0.0m
I0721 06:00:35.140] Call:  gcloud config get-value account
... skipping 412 lines ...
W0721 06:04:22.423] WARNING: Starting in 1.12, new clusters will have basic authentication disabled by default. Basic authentication can be enabled (or disabled) manually using the `--[no-]enable-basic-auth` flag.
W0721 06:04:22.424] WARNING: Starting in 1.12, new clusters will not have a client certificate issued. You can manually enable (or disable) the issuance of the client certificate using the `--[no-]issue-client-certificate` flag.
W0721 06:04:22.424] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0721 06:04:22.424] WARNING: The Pod address range limits the maximum size of the cluster. Please refer to https://cloud.google.com/kubernetes-engine/docs/how-to/flexible-pod-cidr to learn how to optimize IP address allocation.
W0721 06:04:22.425] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0721 06:04:22.425] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0721 06:04:27.376] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=The required node image is not available.
W0721 06:04:27.445] 2019/07/21 06:04:27 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.13.9-beta.0.1+e1be42a61576dc bootstrap-e2e' finished in 5.460552178s
W0721 06:04:29.119] 2019/07/21 06:04:29 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0721 06:04:36.000] 2019/07/21 06:04:35 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.13.9-beta.0.1+e1be42a61576dc bootstrap-e2e: exit status 1
W0721 06:04:36.001] Traceback (most recent call last):
W0721 06:04:36.001]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0721 06:04:36.004]     main(parse_args())
W0721 06:04:36.005]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0721 06:04:36.005]     mode.start(runner_args)
W0721 06:04:36.005]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0721 06:04:36.005]     check_env(env, self.command, *args)
W0721 06:04:36.006]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0721 06:04:36.006]     subprocess.check_call(cmd, env=env)
W0721 06:04:36.006]   File "/usr/lib/python2.7/subprocess.py", line 186, in check_call
W0721 06:04:36.006]     raise CalledProcessError(retcode, cmd)
W0721 06:04:36.007] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0721 06:04:36.021] Command failed
I0721 06:04:36.023] process 259 exited with code 1 after 4.0m
E0721 06:04:36.024] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I0721 06:04:36.024] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0721 06:04:36.848] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0721 06:04:36.949] process 1379 exited with code 0 after 0.0m
I0721 06:04:36.950] Call:  gcloud config get-value account
I0721 06:04:37.628] process 1391 exited with code 0 after 0.0m
I0721 06:04:37.629] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0721 06:04:37.629] Upload result and artifacts...
I0721 06:04:37.629] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1152820584950796288
I0721 06:04:37.630] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1152820584950796288/artifacts
W0721 06:04:39.579] CommandException: One or more URLs matched no objects.
E0721 06:04:39.808] Command failed
I0721 06:04:39.809] process 1403 exited with code 1 after 0.0m
W0721 06:04:39.809] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1152820584950796288/artifacts not exist yet
I0721 06:04:39.809] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1152820584950796288/artifacts
I0721 06:04:42.721] process 1545 exited with code 0 after 0.0m
I0721 06:04:42.722] Call:  git rev-parse HEAD
W0721 06:04:42.729] fatal: Not a git repository (or any of the parent directories): .git
E0721 06:04:42.729] Command failed
I0721 06:04:42.729] process 2069 exited with code 128 after 0.0m
I0721 06:04:42.730] Call:  git rev-parse HEAD
I0721 06:04:42.741] process 2070 exited with code 0 after 0.0m
I0721 06:04:42.741] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I0721 06:04:44.714] process 2071 exited with code 0 after 0.0m
I0721 06:04:44.715] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1563646004824705'
... skipping 8 lines ...