This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-07-15 18:01
Elapsed3m43s
Revision
Buildergke-prow-ssd-pool-1a225945-zhlt
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/f3560488-d439-496b-8b78-417e48930b3e/targets/test'}}
pod77daf5c0-a72a-11e9-bf1c-d671f3ed8202
resultstorehttps://source.cloud.google.com/results/invocations/f3560488-d439-496b-8b78-417e48930b3e/targets/test
infra-commit0e68a1e45
job-versionv1.13.9-beta.0.1+e1be42a61576dc
pod77daf5c0-a72a-11e9-bf1c-d671f3ed8202
revisionv1.13.9-beta.0.1+e1be42a61576dc

Test Failures


Up 57s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.13.9-beta.0.1+e1be42a61576dc bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 12 lines ...
I0715 18:01:35.620] process 44 exited with code 0 after 0.0m
I0715 18:01:35.621] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0715 18:01:35.621] Root: /workspace
I0715 18:01:35.621] cd to /workspace
I0715 18:01:35.621] Configure environment...
I0715 18:01:35.622] Call:  git show -s --format=format:%ct HEAD
W0715 18:01:35.626] fatal: Not a git repository (or any of the parent directories): .git
I0715 18:01:35.626] process 56 exited with code 128 after 0.0m
W0715 18:01:35.627] Unable to print commit date for HEAD
I0715 18:01:35.627] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0715 18:01:36.142] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0715 18:01:36.481] process 57 exited with code 0 after 0.0m
I0715 18:01:36.481] Call:  gcloud config get-value account
... skipping 412 lines ...
W0715 18:04:59.323] WARNING: Starting in 1.12, new clusters will have basic authentication disabled by default. Basic authentication can be enabled (or disabled) manually using the `--[no-]enable-basic-auth` flag.
W0715 18:04:59.324] WARNING: Starting in 1.12, new clusters will not have a client certificate issued. You can manually enable (or disable) the issuance of the client certificate using the `--[no-]issue-client-certificate` flag.
W0715 18:04:59.325] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0715 18:04:59.325] WARNING: The Pod address range limits the maximum size of the cluster. Please refer to https://cloud.google.com/kubernetes-engine/docs/how-to/flexible-pod-cidr to learn how to optimize IP address allocation.
W0715 18:04:59.326] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0715 18:04:59.326] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0715 18:05:02.076] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=The required node image is not available.
W0715 18:05:02.150] 2019/07/15 18:05:02 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.13.9-beta.0.1+e1be42a61576dc bootstrap-e2e' finished in 3.279466323s
W0715 18:05:03.774] 2019/07/15 18:05:03 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0715 18:05:08.690] 2019/07/15 18:05:08 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.13.9-beta.0.1+e1be42a61576dc bootstrap-e2e: exit status 1
W0715 18:05:08.700] Traceback (most recent call last):
W0715 18:05:08.700]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0715 18:05:08.701]     main(parse_args())
W0715 18:05:08.701]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0715 18:05:08.701]     mode.start(runner_args)
W0715 18:05:08.701]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0715 18:05:08.701]     check_env(env, self.command, *args)
W0715 18:05:08.702]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0715 18:05:08.702]     subprocess.check_call(cmd, env=env)
W0715 18:05:08.702]   File "/usr/lib/python2.7/subprocess.py", line 186, in check_call
W0715 18:05:08.702]     raise CalledProcessError(retcode, cmd)
W0715 18:05:08.703] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0715 18:05:08.703] Command failed
I0715 18:05:08.704] process 259 exited with code 1 after 3.5m
E0715 18:05:08.704] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I0715 18:05:08.704] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0715 18:05:09.244] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0715 18:05:09.299] process 1297 exited with code 0 after 0.0m
I0715 18:05:09.300] Call:  gcloud config get-value account
I0715 18:05:09.642] process 1309 exited with code 0 after 0.0m
I0715 18:05:09.642] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0715 18:05:09.642] Upload result and artifacts...
I0715 18:05:09.643] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1150827696322777090
I0715 18:05:09.643] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1150827696322777090/artifacts
W0715 18:05:10.858] CommandException: One or more URLs matched no objects.
E0715 18:05:10.995] Command failed
I0715 18:05:10.996] process 1321 exited with code 1 after 0.0m
W0715 18:05:10.996] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1150827696322777090/artifacts not exist yet
I0715 18:05:10.996] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1150827696322777090/artifacts
I0715 18:05:13.197] process 1463 exited with code 0 after 0.0m
I0715 18:05:13.198] Call:  git rev-parse HEAD
W0715 18:05:13.202] fatal: Not a git repository (or any of the parent directories): .git
E0715 18:05:13.203] Command failed
I0715 18:05:13.203] process 1987 exited with code 128 after 0.0m
I0715 18:05:13.204] Call:  git rev-parse HEAD
I0715 18:05:13.209] process 1988 exited with code 0 after 0.0m
I0715 18:05:13.210] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I0715 18:05:14.417] process 1989 exited with code 0 after 0.0m
I0715 18:05:14.418] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1563170679964066'
... skipping 8 lines ...