This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-07-13 06:00
Elapsed3m35s
Revision
Buildergke-prow-ssd-pool-1a225945-8wl3
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/610f69c8-b446-4b3e-840b-851491323793/targets/test'}}
pod7c486c75-a533-11e9-8217-96c43017ab5b
resultstorehttps://source.cloud.google.com/results/invocations/610f69c8-b446-4b3e-840b-851491323793/targets/test
infra-commit3ce030d42
job-versionv1.13.9-beta.0.1+e1be42a61576dc
pod7c486c75-a533-11e9-8217-96c43017ab5b
revisionv1.13.9-beta.0.1+e1be42a61576dc

Test Failures


Up 1m3s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.13.9-beta.0.1+e1be42a61576dc bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 12 lines ...
I0713 06:00:57.190] process 44 exited with code 0 after 0.0m
I0713 06:00:57.190] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0713 06:00:57.191] Root: /workspace
I0713 06:00:57.191] cd to /workspace
I0713 06:00:57.191] Configure environment...
I0713 06:00:57.192] Call:  git show -s --format=format:%ct HEAD
W0713 06:00:57.196] fatal: Not a git repository (or any of the parent directories): .git
I0713 06:00:57.196] process 56 exited with code 128 after 0.0m
W0713 06:00:57.196] Unable to print commit date for HEAD
I0713 06:00:57.197] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0713 06:00:57.703] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0713 06:00:58.101] process 57 exited with code 0 after 0.0m
I0713 06:00:58.101] Call:  gcloud config get-value account
... skipping 412 lines ...
W0713 06:04:12.691] WARNING: Starting in 1.12, new clusters will have basic authentication disabled by default. Basic authentication can be enabled (or disabled) manually using the `--[no-]enable-basic-auth` flag.
W0713 06:04:12.691] WARNING: Starting in 1.12, new clusters will not have a client certificate issued. You can manually enable (or disable) the issuance of the client certificate using the `--[no-]issue-client-certificate` flag.
W0713 06:04:12.692] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0713 06:04:12.693] WARNING: The Pod address range limits the maximum size of the cluster. Please refer to https://cloud.google.com/kubernetes-engine/docs/how-to/flexible-pod-cidr to learn how to optimize IP address allocation.
W0713 06:04:12.694] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0713 06:04:12.694] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0713 06:04:15.779] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=The required node image is not available.
W0713 06:04:15.831] 2019/07/13 06:04:15 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.13.9-beta.0.1+e1be42a61576dc bootstrap-e2e' finished in 3.521004533s
W0713 06:04:17.372] 2019/07/13 06:04:17 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0713 06:04:23.631] 2019/07/13 06:04:23 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.13.9-beta.0.1+e1be42a61576dc bootstrap-e2e: exit status 1
W0713 06:04:23.639] Traceback (most recent call last):
W0713 06:04:23.640]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0713 06:04:23.640]     main(parse_args())
W0713 06:04:23.641]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0713 06:04:23.641]     mode.start(runner_args)
W0713 06:04:23.641]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0713 06:04:23.641]     check_env(env, self.command, *args)
W0713 06:04:23.641]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0713 06:04:23.642]     subprocess.check_call(cmd, env=env)
W0713 06:04:23.642]   File "/usr/lib/python2.7/subprocess.py", line 186, in check_call
W0713 06:04:23.642]     raise CalledProcessError(retcode, cmd)
W0713 06:04:23.642] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0713 06:04:23.647] Command failed
I0713 06:04:23.647] process 259 exited with code 1 after 3.4m
E0713 06:04:23.647] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I0713 06:04:23.647] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0713 06:04:24.192] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0713 06:04:24.253] process 1296 exited with code 0 after 0.0m
I0713 06:04:24.254] Call:  gcloud config get-value account
I0713 06:04:24.585] process 1308 exited with code 0 after 0.0m
I0713 06:04:24.585] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0713 06:04:24.585] Upload result and artifacts...
I0713 06:04:24.586] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1149921583758839810
I0713 06:04:24.586] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1149921583758839810/artifacts
W0713 06:04:25.639] CommandException: One or more URLs matched no objects.
E0713 06:04:25.774] Command failed
I0713 06:04:25.774] process 1320 exited with code 1 after 0.0m
W0713 06:04:25.775] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1149921583758839810/artifacts not exist yet
I0713 06:04:25.775] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1149921583758839810/artifacts
I0713 06:04:27.574] process 1462 exited with code 0 after 0.0m
I0713 06:04:27.575] Call:  git rev-parse HEAD
W0713 06:04:27.580] fatal: Not a git repository (or any of the parent directories): .git
E0713 06:04:27.580] Command failed
I0713 06:04:27.581] process 1986 exited with code 128 after 0.0m
I0713 06:04:27.581] Call:  git rev-parse HEAD
I0713 06:04:27.586] process 1987 exited with code 0 after 0.0m
I0713 06:04:27.586] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I0713 06:04:28.673] process 1988 exited with code 0 after 0.0m
I0713 06:04:28.674] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1562954660016244'
... skipping 8 lines ...