This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-07-12 18:00
Elapsed3m23s
Revision
Buildergke-prow-ssd-pool-1a225945-qzk4
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/dfcac9fb-1609-4d66-b8a8-ffa34ed88ece/targets/test'}}
pode7008e3f-a4ce-11e9-8217-96c43017ab5b
resultstorehttps://source.cloud.google.com/results/invocations/dfcac9fb-1609-4d66-b8a8-ffa34ed88ece/targets/test
infra-commite49c216a1
job-versionv1.13.9-beta.0.1+e1be42a61576dc
pode7008e3f-a4ce-11e9-8217-96c43017ab5b
revisionv1.13.9-beta.0.1+e1be42a61576dc

Test Failures


Up 43s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.13.9-beta.0.1+e1be42a61576dc bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 12 lines ...
I0712 18:00:58.671] process 44 exited with code 0 after 0.0m
I0712 18:00:58.672] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0712 18:00:58.672] Root: /workspace
I0712 18:00:58.672] cd to /workspace
I0712 18:00:58.672] Configure environment...
I0712 18:00:58.673] Call:  git show -s --format=format:%ct HEAD
W0712 18:00:58.678] fatal: Not a git repository (or any of the parent directories): .git
I0712 18:00:58.678] process 56 exited with code 128 after 0.0m
W0712 18:00:58.678] Unable to print commit date for HEAD
I0712 18:00:58.679] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0712 18:00:59.197] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0712 18:00:59.544] process 57 exited with code 0 after 0.0m
I0712 18:00:59.544] Call:  gcloud config get-value account
... skipping 408 lines ...
W0712 18:04:02.926] WARNING: Starting in 1.12, new clusters will have basic authentication disabled by default. Basic authentication can be enabled (or disabled) manually using the `--[no-]enable-basic-auth` flag.
W0712 18:04:02.926] WARNING: Starting in 1.12, new clusters will not have a client certificate issued. You can manually enable (or disable) the issuance of the client certificate using the `--[no-]issue-client-certificate` flag.
W0712 18:04:02.926] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0712 18:04:02.927] WARNING: The Pod address range limits the maximum size of the cluster. Please refer to https://cloud.google.com/kubernetes-engine/docs/how-to/flexible-pod-cidr to learn how to optimize IP address allocation.
W0712 18:04:02.927] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0712 18:04:02.927] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0712 18:04:05.977] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=The required node image is not available.
W0712 18:04:06.034] 2019/07/12 18:04:06 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.13.9-beta.0.1+e1be42a61576dc bootstrap-e2e' finished in 3.510114931s
W0712 18:04:07.499] 2019/07/12 18:04:07 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0712 18:04:12.526] 2019/07/12 18:04:12 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.13.9-beta.0.1+e1be42a61576dc bootstrap-e2e: exit status 1
W0712 18:04:12.530] Traceback (most recent call last):
W0712 18:04:12.531]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0712 18:04:12.531]     main(parse_args())
W0712 18:04:12.531]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0712 18:04:12.531]     mode.start(runner_args)
W0712 18:04:12.531]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0712 18:04:12.531]     check_env(env, self.command, *args)
W0712 18:04:12.532]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0712 18:04:12.532]     subprocess.check_call(cmd, env=env)
W0712 18:04:12.532]   File "/usr/lib/python2.7/subprocess.py", line 186, in check_call
W0712 18:04:12.532]     raise CalledProcessError(retcode, cmd)
W0712 18:04:12.532] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0712 18:04:12.540] Command failed
I0712 18:04:12.540] process 259 exited with code 1 after 3.2m
E0712 18:04:12.540] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I0712 18:04:12.541] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0712 18:04:13.077] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0712 18:04:13.126] process 1284 exited with code 0 after 0.0m
I0712 18:04:13.126] Call:  gcloud config get-value account
I0712 18:04:13.443] process 1296 exited with code 0 after 0.0m
I0712 18:04:13.443] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0712 18:04:13.443] Upload result and artifacts...
I0712 18:04:13.444] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1149740396167827461
I0712 18:04:13.444] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1149740396167827461/artifacts
W0712 18:04:14.471] CommandException: One or more URLs matched no objects.
E0712 18:04:14.598] Command failed
I0712 18:04:14.598] process 1308 exited with code 1 after 0.0m
W0712 18:04:14.599] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1149740396167827461/artifacts not exist yet
I0712 18:04:14.599] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1149740396167827461/artifacts
I0712 18:04:16.450] process 1450 exited with code 0 after 0.0m
I0712 18:04:16.450] Call:  git rev-parse HEAD
W0712 18:04:16.454] fatal: Not a git repository (or any of the parent directories): .git
E0712 18:04:16.454] Command failed
I0712 18:04:16.454] process 1974 exited with code 128 after 0.0m
I0712 18:04:16.455] Call:  git rev-parse HEAD
I0712 18:04:16.459] process 1975 exited with code 0 after 0.0m
I0712 18:04:16.459] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I0712 18:04:17.556] process 1976 exited with code 0 after 0.0m
I0712 18:04:17.557] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1562911462693443'
... skipping 8 lines ...