This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2019-07-11 18:00
Elapsed4m36s
Revision
Buildergke-prow-ssd-pool-1a225945-08s9
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/0f8797b2-c6d8-4eed-b53f-d3c2b0c95ce8/targets/test'}}
podbc2b689f-a405-11e9-8217-96c43017ab5b
resultstorehttps://source.cloud.google.com/results/invocations/0f8797b2-c6d8-4eed-b53f-d3c2b0c95ce8/targets/test
infra-commit39cbdbc1f
job-versionv1.13.9-beta.0.1+e1be42a61576dc
podbc2b689f-a405-11e9-8217-96c43017ab5b
revisionv1.13.9-beta.0.1+e1be42a61576dc

Test Failures


Up 1m9s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.13.9-beta.0.1+e1be42a61576dc bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 12 lines ...
I0711 18:00:59.319] process 44 exited with code 0 after 0.0m
I0711 18:00:59.320] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0711 18:00:59.320] Root: /workspace
I0711 18:00:59.320] cd to /workspace
I0711 18:00:59.321] Configure environment...
I0711 18:00:59.321] Call:  git show -s --format=format:%ct HEAD
W0711 18:00:59.324] fatal: Not a git repository (or any of the parent directories): .git
I0711 18:00:59.325] process 56 exited with code 128 after 0.0m
W0711 18:00:59.325] Unable to print commit date for HEAD
I0711 18:00:59.325] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0711 18:00:59.846] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0711 18:01:00.184] process 57 exited with code 0 after 0.0m
I0711 18:01:00.184] Call:  gcloud config get-value account
... skipping 412 lines ...
W0711 18:05:15.972] WARNING: Starting in 1.12, new clusters will have basic authentication disabled by default. Basic authentication can be enabled (or disabled) manually using the `--[no-]enable-basic-auth` flag.
W0711 18:05:15.974] WARNING: Starting in 1.12, new clusters will not have a client certificate issued. You can manually enable (or disable) the issuance of the client certificate using the `--[no-]issue-client-certificate` flag.
W0711 18:05:15.975] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0711 18:05:15.975] WARNING: The Pod address range limits the maximum size of the cluster. Please refer to https://cloud.google.com/kubernetes-engine/docs/how-to/flexible-pod-cidr to learn how to optimize IP address allocation.
W0711 18:05:15.976] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0711 18:05:15.976] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0711 18:05:18.830] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=The required node image is not available.
W0711 18:05:18.897] 2019/07/11 18:05:18 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.13.9-beta.0.1+e1be42a61576dc bootstrap-e2e' finished in 3.483774664s
W0711 18:05:21.020] 2019/07/11 18:05:21 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0711 18:05:24.080] 2019/07/11 18:05:24 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.13.9-beta.0.1+e1be42a61576dc bootstrap-e2e: exit status 1
W0711 18:05:24.081] Traceback (most recent call last):
W0711 18:05:24.081]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0711 18:05:24.081]     main(parse_args())
W0711 18:05:24.081]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0711 18:05:24.081]     mode.start(runner_args)
W0711 18:05:24.082]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0711 18:05:24.082]     check_env(env, self.command, *args)
W0711 18:05:24.082]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0711 18:05:24.082]     subprocess.check_call(cmd, env=env)
W0711 18:05:24.082]   File "/usr/lib/python2.7/subprocess.py", line 186, in check_call
W0711 18:05:24.082]     raise CalledProcessError(retcode, cmd)
W0711 18:05:24.083] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable2', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0711 18:05:24.101] Command failed
I0711 18:05:24.102] process 259 exited with code 1 after 4.4m
E0711 18:05:24.102] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2
I0711 18:05:24.102] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0711 18:05:24.803] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0711 18:05:24.882] process 1296 exited with code 0 after 0.0m
I0711 18:05:24.883] Call:  gcloud config get-value account
I0711 18:05:25.258] process 1308 exited with code 0 after 0.0m
I0711 18:05:25.259] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0711 18:05:25.259] Upload result and artifacts...
I0711 18:05:25.260] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1149378003394891776
I0711 18:05:25.260] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1149378003394891776/artifacts
W0711 18:05:27.415] CommandException: One or more URLs matched no objects.
E0711 18:05:27.634] Command failed
I0711 18:05:27.635] process 1320 exited with code 1 after 0.0m
W0711 18:05:27.635] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1149378003394891776/artifacts not exist yet
I0711 18:05:27.636] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/1149378003394891776/artifacts
I0711 18:05:29.673] process 1462 exited with code 0 after 0.0m
I0711 18:05:29.674] Call:  git rev-parse HEAD
W0711 18:05:29.680] fatal: Not a git repository (or any of the parent directories): .git
E0711 18:05:29.680] Command failed
I0711 18:05:29.681] process 1986 exited with code 128 after 0.0m
I0711 18:05:29.681] Call:  git rev-parse HEAD
I0711 18:05:29.688] process 1987 exited with code 0 after 0.0m
I0711 18:05:29.689] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json
I0711 18:05:31.000] process 1988 exited with code 0 after 0.0m
I0711 18:05:31.002] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable2/jobResultsCache.json#1562825074686363'
... skipping 8 lines ...