This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-03-13 00:01
Elapsed4m13s
Revision
Builderaceeff03-64bd-11ea-a8b0-8ac1937716fb
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/ccd00e97-e13c-42b5-ae66-b727528fd9e6/targets/test'}}
resultstorehttps://source.cloud.google.com/results/invocations/ccd00e97-e13c-42b5-ae66-b727528fd9e6/targets/test
infra-commit35305da38
job-versionv1.17.4-beta.0.54+12bf0cb73007af
revisionv1.17.4-beta.0.54+12bf0cb73007af

Test Failures


Up 52s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.4-beta.0.54+12bf0cb73007af bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0313 00:01:24.027] process 49 exited with code 0 after 0.0m
I0313 00:01:24.028] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0313 00:01:24.028] Root: /workspace
I0313 00:01:24.028] cd to /workspace
I0313 00:01:24.028] Configure environment...
I0313 00:01:24.029] Call:  git show -s --format=format:%ct HEAD
W0313 00:01:24.039] fatal: not a git repository (or any of the parent directories): .git
I0313 00:01:24.040] process 63 exited with code 128 after 0.0m
W0313 00:01:24.040] Unable to print commit date for HEAD
I0313 00:01:24.040] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0313 00:01:25.037] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0313 00:01:25.429] process 64 exited with code 0 after 0.0m
I0313 00:01:25.430] Call:  gcloud config get-value account
... skipping 432 lines ...
W0313 00:05:18.474] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0313 00:05:18.475] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0313 00:05:18.475] WARNING: Starting with version 1.18, clusters will have shielded GKE nodes by default.
W0313 00:05:18.475] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0313 00:05:18.476] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0313 00:05:18.476] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0313 00:05:18.592] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0313 00:05:18.704] 2020/03/13 00:05:18 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.4-beta.0.54+12bf0cb73007af bootstrap-e2e' finished in 1.185645104s
W0313 00:05:20.836] 2020/03/13 00:05:20 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0313 00:05:20.843] 2020/03/13 00:05:20 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.17.4-beta.0.54+12bf0cb73007af bootstrap-e2e: exit status 1
W0313 00:05:20.846] Traceback (most recent call last):
W0313 00:05:20.847]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0313 00:05:20.847]     main(parse_args())
W0313 00:05:20.847]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0313 00:05:20.847]     mode.start(runner_args)
W0313 00:05:20.847]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0313 00:05:20.847]     check_env(env, self.command, *args)
W0313 00:05:20.847]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0313 00:05:20.847]     subprocess.check_call(cmd, env=env)
W0313 00:05:20.847]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0313 00:05:20.848]     raise CalledProcessError(retcode, cmd)
W0313 00:05:20.849] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/k8s-stable1', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0313 00:05:20.857] Command failed
I0313 00:05:20.857] process 274 exited with code 1 after 3.9m
E0313 00:05:20.858] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1
I0313 00:05:20.858] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0313 00:05:21.810] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0313 00:05:21.915] process 1462 exited with code 0 after 0.0m
I0313 00:05:21.916] Call:  gcloud config get-value account
I0313 00:05:22.801] process 1476 exited with code 0 after 0.0m
I0313 00:05:22.801] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0313 00:05:22.801] Upload result and artifacts...
I0313 00:05:22.802] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1238253707678715913
I0313 00:05:22.802] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1238253707678715913/artifacts
W0313 00:05:24.556] CommandException: One or more URLs matched no objects.
E0313 00:05:24.848] Command failed
I0313 00:05:24.848] process 1490 exited with code 1 after 0.0m
W0313 00:05:24.848] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1238253707678715913/artifacts not exist yet
I0313 00:05:24.849] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/1238253707678715913/artifacts
I0313 00:05:27.911] process 1636 exited with code 0 after 0.1m
I0313 00:05:27.912] Call:  git rev-parse HEAD
W0313 00:05:27.923] fatal: not a git repository (or any of the parent directories): .git
E0313 00:05:27.923] Command failed
I0313 00:05:27.923] process 2164 exited with code 128 after 0.0m
I0313 00:05:27.923] Call:  git rev-parse HEAD
I0313 00:05:27.934] process 2165 exited with code 0 after 0.0m
I0313 00:05:27.935] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json
I0313 00:05:29.938] process 2166 exited with code 0 after 0.0m
I0313 00:05:29.939] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100-stable1/jobResultsCache.json#1584014642755295'
... skipping 8 lines ...